WiPi Configuration help


12 posts
by Aonder » Mon Dec 17, 2012 7:09 pm
Hello,
First time posting on these forums and was hoping someone might have some pointers for me. I just got my Raspberry Pi and the WiPi. i was able to get network-configuration installed; however everytime i try to connect it to my home WEP security it bombs out. any thoughts?
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm
by drgeoff » Mon Dec 17, 2012 10:28 pm
Can you be a bit more precise? "it bombs out" isn't much to go on.
Posts: 2038
Joined: Wed Jan 25, 2012 6:39 pm
by Aonder » Mon Dec 17, 2012 10:51 pm
It doesn't connect. it will connect to the hard wire connection and has no issues. but if i unplug the ethernet cable and try to connect to the WEP wireless it never pulls an IP. it doesn't throw an error. it doesn't close the window. it just "bombs out" and doesn't pull an IP. I have triple checked the WEP security code. i feel like it just isn't passing through the correct credentials (Example: i will try to connect using WPA [knowing it won't work] and it tells me that it is the wrong security type; however when using WEP it doesn't give any errors but doesn't pull an IP)

not sure if this will help i am running the OS that comes shipped with the SD card.
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm
by Mursili » Tue Dec 18, 2012 12:45 am
My raspbian install works quite well using WPA2 security. I have not used WEP in quite a while, so I cannot really help with this. I can say that when I have typed in the WPA code wrong (due to wonderfully stuck keys) that it behaves the way you are describing.

It seems that some of the distros that have arrived pre-installed on SD cards have been quite old. Have you tried to use a new image on the card? Have you tried 'sudo apt-get update' then 'sudo apt-get upgrade', rebooted and tried again?

Good luck!
User avatar
Posts: 28
Joined: Fri Nov 23, 2012 2:12 am
by drgeoff » Tue Dec 18, 2012 10:22 am
What Wi-Fi router (or whatever) are you trying to connect to? Some of them can have an additional security feature enabled requiring the MAC address of each client to be entered into a white list in the Wi-Fi router's config pages.
Posts: 2038
Joined: Wed Jan 25, 2012 6:39 pm
by Aonder » Tue Dec 18, 2012 3:39 pm
Thanks for the things to test. i let the upgrade run last night and haven't had time to check it out since then. i will let you guys know how it went this evening. thanks for your tips thus far!
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm
by Lob0426 » Tue Dec 18, 2012 10:10 pm
If you have a pre-installed card you definitely need to run an update.

Code: Select all
sudo apt-get update && sudo apt-get upgrade


Then give it another try. It may work without any more work.

The older distros had fights between the WiFi and the Ethernet.

If it does not work please post the distro you are using. That will really help us help you.
Back-powered 256MB as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1868
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by Aonder » Wed Dec 19, 2012 1:17 am
Thank you for your help thus far. But after the upgrade then update; we still have no luck. Here is what happens when I run test:
(Start)
Configuring device wlan0 :

$ iwconfig wlan0 mode managed

$ iwconfig wlan0 essid "2WIRE329"

$ iwconfig wlan0 rate auto

$ iwconfig wlan0 key XXX...

$ ifconfig wlan0 up

DHCP may take a while, please wait...
$ dhclient wlan0
(End)

When I do an ifconfig it reveals I still have no ip for wlan0.

The router/modem is an AT&T "2WIRE". I don't think we are doing any MAC filtering though as I was able to connect 2 laptops and an assorement of other devices with out using MACs

Thank you again for your help with this and I look forward to your continued help!
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm
by Kole » Wed Dec 19, 2012 6:11 am
But after the upgrade then update

You should do it the opposite way. Update downloads the newest list of available packages. Upgrade installs them. If you try to upgrade with old list of packages, it won't find anything to upgrade, so it should be update then upgrade.


Also just in case the problem is with the DHCP server/client, try adding IP address by hand. This will tell us if the problem is authentication or something related to DHCP itself.
Posts: 29
Joined: Fri Nov 23, 2012 9:19 pm
Location: Belgrade, Serbia
by Aonder » Wed Dec 19, 2012 11:04 pm
After the update/upgrade/update/upgrade/update i am still getting the same results. I will try the static IP when i get a chance. thanks again for your input!
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm
by Aonder » Fri Dec 21, 2012 5:08 pm
The static IP resulted in the same. I will be taking my raspberry pi with me on vacation to another location i know uses WEP. i will test it there as well as it might be my modem/router
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm
by Aonder » Tue Jan 01, 2013 5:00 pm
Well after testing at another location i have concluded it isn't my router. i am now getting a new error message though and that would be:
wlan0: Unsupported driver 'ndiswrapper'

thanks again for your help everyone!
Posts: 7
Joined: Mon Dec 17, 2012 7:04 pm