error: Unable to save resume file: permission denied


50 posts   Page 2 of 2   1, 2
by oozic » Sat Dec 22, 2012 11:06 am
Ti conviene già formattarlo in ext4 o al massimo exfat, io eviterei ntfs per avere una maggior compatibilità.

Per il resto per far "partire" un avi hai bisogno di un programma ovviamente.
Non so se mplayer funziona su arm, è il primo che mi viene in mente.

Ma hai il raspi collegato ad uno schermo o ci accedi tramite ssh?
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Dec 22, 2012 2:03 pm
È collegata alla tv ma mi piacerebbe poi attivargli anche l'ssh (hai un link su come si possa fare?).

Ext4 ha lo svantaggio che se stacco l'hdd e lo collego ad un pc Windows o un'altra tv non me lo leggerebbe.

Exfat non lo conosco, è visibile sia da Linux che da Windows? Che vantaggi mi darebbe

L'uso principale che ne farò è di torrent poi quello che scarico vorrei poterlo vedere dalla tv a cui è collegato, oppure da una qualunque altra tv.

Aspetto vostri consigli preziosi:)

Ciao!
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sat Dec 22, 2012 2:42 pm
evil80 wrote:È collegata alla tv ma mi piacerebbe poi attivargli anche l'ssh (hai un link su come si possa fare?).

Ext4 ha lo svantaggio che se stacco l'hdd e lo collego ad un pc Windows o un'altra tv non me lo leggerebbe.

Exfat non lo conosco, è visibile sia da Linux che da Windows? Che vantaggi mi darebbe

L'uso principale che ne farò è di torrent poi quello che scarico vorrei poterlo vedere dalla tv a cui è collegato, oppure da una qualunque altra tv.

Aspetto vostri consigli preziosi:)

Ciao!


allora secondo me la cosa migliore da fare è installare xbmc (raspbmc/xbian/openelec) e poi ci aggiungi il plugin dei torrent...
zero sbatti e hai un mediacenter pronto per veder tutto quello che scarichi senza problemi.

puoi abilitare ssh mi pare direttamente da raspi-config.

una volta abilitata se hai un altro computer *nix (linux, osx,...) basta che dal terminale scrivi
Code: Select all
ssh utente@indirizzoIP
esempio: ssh pi@192.168.1.2

poi ti chiede la password e sei collegato.

il formato exfat è l'evoluzione del classico fat32, è quello che tutto sommato dovrebbe garantirti la maggior compatibilità tra i vari sistemi operativi (moderni).
http://it.wikipedia.org/wiki/ExFAT

se formatti in ntfs fin che lasci l'hard disk collegato al rasperry sei tranquillo non hai problemi, tramite samba ci leggono e scrivono tutti.
l'unico problema può essere che se lo stacchi e lo colleghi direttamente ad un mac non puoi scriverci sopra ma soltanto leggere.
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Dec 22, 2012 3:45 pm
Cos'è xbmc? Vuol dire che devo formattare la sd RAM e riconfigurare transmission?

Sai darmi qualche indicazione su come lo installo xbmc ? È un installer o altro?

Grazie e scusa ma si questo mondo sono nuovo!
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sat Dec 22, 2012 3:50 pm
cos'è XBMC?
http://it.wikipedia.org/wiki/Xbox_Media_Center

in breve: è un mediacenter, riproduce video audio immagini, organizza la tua libreria, è integrabile con plugin, ecc...

per funzionare ha bisogno di un sistema operativo, per il raspberry esistono 3 distribuzioni di sistema operativo con integrato xbmc:
- raspbmc http://www.raspbmc.com/
- xbian http://xbian.org/
- openelec http://openelec.tv/

per installarli devi necessariamente formattare la SD e riconfigurare transmission successivamente.

installare xbmc è molto semplice.
configurare successivamente transmission forse lo sarà un pò meno, ma se ce l'hai fatta stavolta ce la farai anche dopo ;)
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Dec 22, 2012 4:16 pm
Tutto chiaro!
Quale delle 3 distr consigli?
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sat Dec 22, 2012 4:18 pm
raspbmc probabilmente è quella più semplice da installare perchè ti fornisce un tool per scrivere l'immagine anche su windows.

io personalmente uso openelec, ma ho provato anche raspbmc e sono molto simili, c'è qualche bug nell'una e nell'altra.

volevo invece provare xbian ma non sono riuscito a farlo partire boh non ho ben capito che problema avessero le immagini.

ah aggiungo che forse per te meglio raspbmc anche xke si basa su rasbian e quindi puoi tirare giu i pacchetti con apt-get install, mentre con openelec è un sistema diverso non prevede apt
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Dec 22, 2012 6:24 pm
sto installando proprio ora raspbmc.
Ho backuppato l'immagine dell'SD e poi ho scaricato il sofware per Windows che installa in automatico i files necessari.

Ho quindi inserito la SD nella raspberry ma dopo qualche secondo mi dice che non riesce a connettersi al server di update.
Il cavo di rete è correttamente collegato e vedo anche che il router gli rilascia un indirizzo ip "192.168.1.14".
Il router è lo stesso con cui scrivo ora, quindi la connessione è attiva.

Leggendo in giro ho provato a staccare tutte le periferiche USB, ma il problema persiste...sai per caso da cosa dipende ?

Inizia una nuova odissea!
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sat Dec 22, 2012 6:54 pm
molto strano fai una cosa allora, scarica la seconda immagine, la prima è quella che fa l'update in uatomatico, la seconda è già "pre-caricata".
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Dec 22, 2012 7:03 pm
la seconda immagine ha estensione "gz", la devo scompattare nella SD oppure metto il gz e ci pensa lui?
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sat Dec 22, 2012 7:23 pm
la apri con un normale gestore di archivi credo, sicuramente con il *migliore* 7zip lo apri sicuro:
http://www.7-zip.org/
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Dec 22, 2012 7:27 pm
si sono riuscito a aprila proprio con 7-zip e contiene un solo file chiamato "sd.img".
L'ho fisicamente copiato sulla SD e poi l'ho attaccata alla RPi ma non parte nulla, come se non avesse un sistema operativo.

Ho provato anche con Win32DiskImager a fargli scrivere l'immagine sulla SD ma mi da errore.
Non è chiaro dopo aver scaricato lo zip cosa farne per ottenere una SD pronta all'uso...boh?

Idee ?
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by evil80 » Sat Dec 22, 2012 7:33 pm
aprendo anche "sd.img" con 7zip ci sono all'interno 2 file

- 0.fat
- 1.img

provo a copiare questi sulla sd ?
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by evil80 » Sat Dec 22, 2012 7:43 pm
evil80 wrote:aprendo anche "sd.img" con 7zip ci sono all'interno 2 file

- 0.fat
- 1.img

provo a copiare questi sulla sd ?


Niente neanche così, non parte nulla.
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by evil80 » Sat Dec 22, 2012 9:03 pm
credo di esserci riuscito!
ho scaricato l'immagine standalone e l'ho posizionata nella stessa cartella dell'installer, rinominando il file esattamente come quello che lui scarica al volo.
In questo modo ho inserito la SD ed è partito!

Ho già reinstallato Transmission, è tutto un altro pianeta Raspbmc!!!!
Veramente bellissimo :))))

Grazie mille e buon Natale!
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sun Dec 23, 2012 10:08 am
benissimo :)
buon natale anche a te
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Thu Jan 10, 2013 9:50 pm
Ciao,

torno a rompere le scatole :)
La Raspberry che ho comprato ha 512Mb di RAM ma XMBC me ne vede soltanto solo 256.
Così ho provato a seguire questa guida

http://www.element14.com/community/grou ... -512mb-ram

Inizia a scaricare un pò di pacchetti poi ad un certo punto si ferma e non riesco ad andare avanti.
Di seguito riporto il listato del comando :

sudo apt-get update && sudo apt-get install raspi-config libraspberrypi*
Hit http://archive.raspbian.org wheezy InRelease
Hit http://archive.raspbian.org wheezy/main armhf Packages
Hit http://archive.raspbian.org wheezy/contrib armhf Packages
Hit http://archive.raspbian.org wheezy/non-free armhf Packages
Ign http://archive.raspbian.org wheezy/contrib Translation-en
Ign http://archive.raspbian.org wheezy/main Translation-en
Ign http://archive.raspbian.org wheezy/non-free Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package raspi-config
E: Unable to locate package libraspberrypi*
E: Couldn't find any package by regex 'libraspberrypi*'

Da qui non riesco ad andare avanti dato che dovrei usare il comando "raspi-config".
Sto sbagliando qualcosa o forse su XMBC va seguita una procedura diversa ?

GRazie mille :)
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by oozic » Sat Jan 12, 2013 4:22 pm
dovresti già avere raspi-config se non erro assieme a xbmc , se dalla shell fai partire raspi-config non parte?
RPi #1: xbmc - transmission daemon
RPi #2: nginx - nodejs - samba
http://mattia-asti.it
User avatar
Posts: 245
Joined: Sun Nov 25, 2012 10:58 pm
by evil80 » Sat Jan 12, 2013 7:32 pm
No, non parte nulla.
In sostanza mi dice che il comando non esiste.

Come posso installarlo?
Grazie!
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by Lord Router » Mon Jan 28, 2013 11:17 am
...magari se spiegassi bene bene i passaggi aiuteresti qualcun'altro.... ;)
RPi #1: SDHC 8Gb Class 10 + Clear Case + Raspbian + vnc + samba + transmission-deamon
RPi #2: Molto presto ....
User avatar
Posts: 44
Joined: Sat Jan 12, 2013 4:09 pm
by Lord Router » Mon Jan 28, 2013 11:33 am
hyper wrote:Ciao, anch'io avevo lo stesso problema con transmission-deamon. Dopo 4 MB (la cache predefinita di Trasmission) il download si bloccava. Il punto fondamentale è impostare bene il mount della pen drive nel file fstab, come spiegato nella guida da te citata:
1) dal file manager ti porti su /etc;
2) menu Strumenti/Apri cartella corrente come Root;
3) tasto dx su fstab, scegli Leafpad;
4) dopo la riga #a swapfile ecc., aggiungi la riga:
/dev/sda1 /media/usbstick auto defaults,uid=109,gid=114 0 0
i valori corretti di uid e gid li ricavi rispettivamente dai comandi (da terminale):
id -u debian-transmission
id -g debian-transmission
5) controlla che dopo quest'ultima riga aggiunta in fstab ce ne sia una vuota;
6) salva fstab e riavvia, ora dovrebbe funzionare.


io con questo sistema ho risolto. :mrgreen:
Ringrazio infinitamente hyper. :mrgreen:
RPi #1: SDHC 8Gb Class 10 + Clear Case + Raspbian + vnc + samba + transmission-deamon
RPi #2: Molto presto ....
User avatar
Posts: 44
Joined: Sat Jan 12, 2013 4:09 pm
by Lord Router » Mon Feb 04, 2013 5:44 pm
Lord Router wrote:
hyper wrote:Ciao, anch'io avevo lo stesso problema con transmission-deamon. Dopo 4 MB (la cache predefinita di Trasmission) il download si bloccava. Il punto fondamentale è impostare bene il mount della pen drive nel file fstab, come spiegato nella guida da te citata:
1) dal file manager ti porti su /etc;
2) menu Strumenti/Apri cartella corrente come Root;
3) tasto dx su fstab, scegli Leafpad;
4) dopo la riga #a swapfile ecc., aggiungi la riga:
/dev/sda1 /media/usbstick auto defaults,uid=109,gid=114 0 0
i valori corretti di uid e gid li ricavi rispettivamente dai comandi (da terminale):
id -u debian-transmission
id -g debian-transmission
5) controlla che dopo quest'ultima riga aggiunta in fstab ce ne sia una vuota;
6) salva fstab e riavvia, ora dovrebbe funzionare.


io con questo sistema ho risolto. :mrgreen:
Ringrazio infinitamente hyper. :mrgreen:


Ha funzionato anche a me.
Grazie.
RPi #1: SDHC 8Gb Class 10 + Clear Case + Raspbian + vnc + samba + transmission-deamon
RPi #2: Molto presto ....
User avatar
Posts: 44
Joined: Sat Jan 12, 2013 4:09 pm
by sonico81 » Mon Feb 11, 2013 2:45 pm
Salve a tutti, scusate se mi appoggio a questa discussione ma non mi sembra di crearne una nuova per lo stesso problema.
In pratica ho un RPI con transmission e seguendo tutti i vostri passi non sono riuscito a far salvare i documenti scaricati su pendrive o hdd usb, ma solo sulla SD
ho provato a modificare il file fstab inserendo /dev/sda1 /media/"NomeDellaPendrive" default auto, uid=109,gid114, 0 0 ma al riavvio non c'era più la pendrive ne su media ne su sda1.
Provato col comando chown ma niente da fare, scarica un po' e poi da errore.
Creata una cartella sul desktop chiamata TORRENT, dati i permessi con chmod -R 777 e modificato il file settings.json, i file vengono scaricati senza problemi; se eseguo la stessa procedura per la pendrive ottengo l'errore di impossibilità di scaricare i file.

Avete altri suggerimenti ??

Grazie
Posts: 1
Joined: Mon Feb 11, 2013 2:30 pm
by evil80 » Mon Feb 11, 2013 8:23 pm
Ciao,

la strada dei permessi l'ho ampiamente seguita in tutte le salse ed ha me non ha mai funzionato.
Ho risolto più semplicemente, ovvero imparando che il daemon di Transmission venga eseguito con l'utente root.

Basta che vai in /etc/init.d/ e li trovi il file di configurazione di transmission (in pratica lo stesso che avvi o stoppi).

Li ti basta fare un'occhiata e vedrai che subito in altro troverai lo user utilizzato "transmission-user" o qualcosa del genere.
Modificalo in "root" salva e riavvia il servizio.
Così va tutto da che root scrive dove vuole.

Ovviamente il file devi modificarlo con permessi di root (facendo quindi "su").

Magari non è la soluzione più eleganti e a molti non piacerá...ma la vita è già complicata, semplifichiamola quando si può!

Ciaooooo
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm
by evil80 » Mon Feb 11, 2013 8:25 pm
Scusate i mille orrori ortografici...maledetti correttori sui Cell!!

Ciao:)
Posts: 35
Joined: Fri Dec 07, 2012 9:52 pm