apt-get update fails with raspbian/main armhf Packages 404


11 posts
by MrUmunhum » Sun Oct 28, 2012 10:51 pm
Hi group,

Title says it all, fresh install, apt-get update returned this:
# apt-get update --fix-missing
Ign http://raspbian.nwlinux.us pool InRelease
Ign http://raspbian.nwlinux.us pool Release.gpg
Ign http://raspbian.nwlinux.us pool Release
Hit http://mirrordirector.raspbian.org wheezy InRelease
Ign http://141.30.228.4 raspbian InRelease
Hit http://archive.raspberrypi.org wheezy InRelease
Ign http://141.30.228.4 raspbian Release.gpg
Hit http://mirrordirector.raspbian.org wheezy/main armhf Packages
Err http://raspbian.nwlinux.us pool/main armhf Packages
404 Not Found
Hit http://archive.raspberrypi.org wheezy/main armhf Packages
Ign http://raspbian.nwlinux.us pool/main Translation-en_GB
Ign http://raspbian.nwlinux.us pool/main Translation-en
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Ign http://141.30.228.4 raspbian Release
Ign http://archive.raspberrypi.org wheezy/main Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en_GB
Err http://141.30.228.4 raspbian/main armhf Packages
404 Not Found
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en_GB
Ign http://141.30.228.4 raspbian/main Translation-en_GB
Ign http://141.30.228.4 raspbian/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en_GB
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
W: Failed to fetch http://raspbian.nwlinux.us/raspbian/dis ... f/Packages 404 Not Found

W: Failed to fetch http://141.30.228.4/pub/mirrors/raspbia ... f/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
root@raspdev:~#

My /etc/apt/sources.list
# cat /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi



Any help?

Thanks for your time.
Posts: 29
Joined: Fri Aug 05, 2011 4:37 pm
by MrUmunhum » Sun Oct 28, 2012 11:32 pm
OK, I found that apt-get should be looking for binary-armhf not just armhf. So how do I tell him?
Posts: 29
Joined: Fri Aug 05, 2011 4:37 pm
by plugwash » Sun Oct 28, 2012 11:36 pm
What is the result of cat /etc/apt/sources.list.d/* ?
How did you install raspbian?

My first guess though would be that something is messing with your internet connection.
Forum Moderator
Forum Moderator
Posts: 2434
Joined: Wed Dec 28, 2011 11:45 pm
by MrUmunhum » Mon Oct 29, 2012 12:16 am
The system was built from: archlinuxarm-2012-09-16.zip

root@raspdev:~# cat /etc/apt/sources.list.d/*
deb http://archive.raspberrypi.org/debian/ wheezy main
deb http://raspbian.nwlinux.us/raspbian pool main
deb http://141.30.228.4/pub/mirrors/raspbian raspbian main

root@raspdev:~# L /etc/apt/sources.list.d/*
-rw-r--r--. 1 500 root
Posts: 29
Joined: Fri Aug 05, 2011 4:37 pm
by plugwash » Mon Oct 29, 2012 12:42 am

Those sources lines are both broken.

You need to find the files in sources.list.d that contain them and either remove them or fix them.
Forum Moderator
Forum Moderator
Posts: 2434
Joined: Wed Dec 28, 2011 11:45 pm
by MrUmunhum » Sat Nov 03, 2012 9:27 pm
I reinstalled with the 1210-10 image. Ran apt-get update which failed, waited two days then reran apt-get update which worked.
Posts: 29
Joined: Fri Aug 05, 2011 4:37 pm
by Devon Mafia » Fri Jan 25, 2013 11:53 pm
i have a similar problem, should i get an update or just sort out the tinternet? my error was

WARNING: The following packages cannot be authenticated!
lynx-cur lynx
Install these packages without verification [y/N]? y
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main lynx-cur armhf 2.8.8dev.12-2
Temporary failure resolving 'mirrordirector.raspbian.org'
Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main lynx all 2.8.8dev.12-2
Temporary failure resolving 'mirrordirector.raspbian.org'
Failed to fetch http://mirrordirector.raspbian.org/rasp ... _armhf.deb Temporary failure resolving 'mirrordirector.raspbian.org'
Failed to fetch http://mirrordirector.raspbian.org/rasp ... -2_all.deb Temporary failure resolving 'mirrordirector.raspbian.org'
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
User avatar
Posts: 117
Joined: Thu Jan 10, 2013 2:16 pm
by plugwash » Sat Jan 26, 2013 12:17 am
Devon Mafia wrote: Temporary failure resolving 'mirrordirector.raspbian.org'

That error almost certainly means that your internet connection is broken.
Forum Moderator
Forum Moderator
Posts: 2434
Joined: Wed Dec 28, 2011 11:45 pm
by max95 » Thu Feb 21, 2013 4:17 pm
I have a similar problem. I browsed through the forum and most people think it's an internet connection problem and are suggesting to edit resolv.conf and add google's DNS servers. But my connection is working, I can ping or wget anything from any domain name ...
What's wrong then?
Posts: 2
Joined: Thu Feb 21, 2013 4:10 pm
by plugwash » Thu Feb 21, 2013 4:53 pm
Tell us what errors you are getting and we can troubleshoot your problem.
Forum Moderator
Forum Moderator
Posts: 2434
Joined: Wed Dec 28, 2011 11:45 pm
by max95 » Thu Feb 21, 2013 5:15 pm
I solved the problem. I noticed that I have a filesystem read-only message at the end of the apt-get errors. The problem was a broken SD card.

Regards
max95
Posts: 2
Joined: Thu Feb 21, 2013 4:10 pm