New install - Openbox syntax error


13 posts
by Joebacca » Wed Aug 15, 2012 7:12 am
This is the third time I flash my rpi. I keep getting an error once I reboot a couple times.

Code: Select all
---Openbox Syntax Error---
One or more XML syntax errors were found while parsing the Openbox configuration files. See stdout for more information. The last error was in file "/home/pi/.config/openbox/lxde-rc.xml" line 1, with message: Start tag expected, "<" not found


I opened the lxde-rc.xml file and it's blank! Like I said, third time this happens, I am getting rather annoyed... Hope someone has the answer! :)
Posts: 6
Joined: Sat Aug 04, 2012 2:50 am
by alteng » Thu Sep 06, 2012 6:40 pm
Same problem. July image did not have this problem.
Posts: 1
Joined: Thu Sep 06, 2012 6:29 pm
by mrmac476 » Wed Sep 12, 2012 3:47 am
Same for me! Does anyone know what I should do?
Posts: 1
Joined: Wed Sep 12, 2012 3:45 am
by LapinBleu » Wed Sep 12, 2012 9:04 am
Same here...
Posts: 2
Joined: Wed Sep 12, 2012 8:54 am
by LapinBleu » Wed Sep 12, 2012 6:51 pm
I could correct this problem by simply copying the files that are blank in pi's directory (~/.config/openbox/lxde-rc.xml and ~/.config/lxpanel/LXDE/panels/panel, as far as I know) from root's directory (/root/.config/...).
Posts: 2
Joined: Wed Sep 12, 2012 8:54 am
by stryker » Sat Sep 22, 2012 12:32 am
Did that fix work for you? I've not been able to locate the files in the /root file tree to copy over.
Can I wget them from somewhere?

Thanks for your advice, Geoff
Posts: 8
Joined: Fri Jan 27, 2012 5:36 am
by pnunn » Sun Oct 14, 2012 12:23 am
Just hit this one too. Has anyone managed to sort it, or can post a copy of their xml files so we can copy them into place?

Ta

Peter.
Posts: 1
Joined: Sun Oct 14, 2012 12:03 am
by aylwinlo » Sat Oct 20, 2012 10:28 pm
Posts: 1
Joined: Sat Oct 20, 2012 10:20 pm
by RaspberryPiBeginners » Fri Dec 28, 2012 12:39 am
I got this error and now i've got no start bar
Click here for my unofficial YouTube Channel > http://goo.gl/oFYBD
User avatar
Posts: 203
Joined: Fri May 11, 2012 6:54 am
Location: Soham, Cambridgeshire
by alexlittle » Tue Jan 15, 2013 10:49 pm
I came across too, the way I've 'fixed' it is just to create a new user account - using:
Code: Select all
sudo useradd <username>


then when I log in as this new user I get the background image, start menu bar - although I don't get the default desktop icons.

I guess you could also use a similar process to delete and recreate the default 'pi' account.

Hope that helps someone :-)
Alex
Posts: 3
Joined: Tue Jan 15, 2013 10:37 pm
by SmartyP » Sat Oct 26, 2013 2:53 pm
I ran into this same issue. I ended up booting another SD card that worked, FTP'ing down the lxde_rc.xml from that setup, and then FTP'ing into this new setup and copying over the empty lxde_rc.xml with the one from my working setup. That got rid of the bad XML error on starting up Openbox ("startx"), however I am still missing the start menu bar along the bottom.. :/

FWIW, the install I'm using is wheezy-raspbian-armel (for soft-float).

Anyone know how to fix the missing start bar next?
Posts: 2
Joined: Sat Oct 26, 2013 2:00 pm
by SmartyP » Sat Oct 26, 2013 2:56 pm
Sorry for the quick followup, but a quick-fix is to open LXTerminal and stop lxpanel and start it back up..

killall lxpanel
lxpanel
Posts: 2
Joined: Sat Oct 26, 2013 2:00 pm
by NMTech » Sat Feb 08, 2014 12:06 am
Just a simple solution. Use sudo su and then startx.
1200MHz RPi :) Overclocker 14 Years Old :D
User avatar
Posts: 4
Joined: Thu Jan 23, 2014 3:14 am