USB Wifi Dongles and Power Usage


32 posts   Page 1 of 2   1, 2
by CCitizenTO » Sat Jul 14, 2012 4:10 pm
So yeah I know the RPi Model B requires 5V/700mA to run and this accounts for 200mA of power going to the USB ports (for Keyboard/Mouse).

I also noticed that in the wiki people are using 5V/2A adapters. I was wondering if you use a more powerful power supply to give power to the Pi if it's possible to put higher powered USB devices into the USB port directly without needing a powered hub to give them juice.

Anyways the idea I wanted to get across was that I've been doing some looking around and see that USB Wifi Dongles draw anywhere from 100mA to 500mA depending on models at least according to TrendNET's site. I havent seen power usage numbers from other vendors. Also the Mini/Nano adapter seemed to come in around 100mA-210mA and I have a few of the Edimax ones laying around and was considering using one of those.

Anyways if people more experienced with this sort of stuff are able to test how much current a given usb peripheral draws like the Wifi dongles that would be helpful since my goal is to build a PirateBox on a RPi and having to power the RPi and a powered hub sort of kills the portability of it.
Posts: 81
Joined: Sun May 20, 2012 2:14 am
by Roughnecks » Thu Jul 19, 2012 9:14 pm
Hi,

I have a similar project in mind (providing an open Wifi-Access Point with a bridged VPN).

I have power problems too.
I use:
- some cheap power supply (it says "Output: DC 5.4V / 1000mA")
- the cheapest, AP enabled Wifi-USB-Dongle i could find: TP-Link TL-WN821N
- and a Raspberry PI, obviously

So, I toyed around with my setup and had a lot of trouble of getting everything to work. With the fresh Raspbian Image all works better now, almost out of the box - except the power problem.

Scenario 1:
Using an USB-Powered Hub (for the wifi dongle) everything works ok, my Wifi AP starts just fine

Scenario 2:
Using one of the RPIs built-in USB-Ports, it seems it can't get enough power. It just won't work.

#2 is the preferred one - can anybody help me please and tell me what my options are to get the wifi dongle work without a powered usb hub?

Thanks
- Ben
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by herrb » Fri Jul 20, 2012 1:51 pm
What you could probably try is this: use a USB-Y-cable and see whether the power you get through both USB ports is enough for your wlan dongle. Don't know whether this makes a difference on the PI.

In any case, I'd personally think this is cutting a bit close to the bone. I guess you'll be much better off getting yourself a little powered 4-port hub and use that one to power the PI (using a Y-Cable) and your wlan module.

I run my setup with a powered 7-port hub on a 5V/3.5A power supply

upstream plug of hub -> one of the PI's USB ports
PI's power socket -> via USB-Y-cable in two ports on the hub (gives the PI 1 Amp)
wlan dongle -> hub
keyboard -> hub
mouse -> hub

once I get around to it I'll try running a 2.5" USB drive off the hub with another Y cable.

All this with one power supply, so minumum amount of mains cabling.
Posts: 5
Joined: Mon Jul 16, 2012 12:21 pm
by piglet » Fri Jul 20, 2012 2:08 pm
CCitizenTO wrote:. I was wondering if you use a more powerful power supply to give power to the Pi if it's possible to put higher powered USB devices into the USB port directly without needing a powered hub to give them juice.


No, due to the polyfuses used in the Pi on the USB, which are rated 140mA- they will "blow" (well, stop current until they reset over time).
User avatar
Posts: 530
Joined: Sat Aug 27, 2011 1:16 pm
by Roughnecks » Sat Jul 21, 2012 12:40 pm
Mmmm ok, too bad.It seems I can't get the TP-Link dongle to work without a powerd hub.
Fortunately I could try the same thing with a spare Micro-USB dongle that seems to draw less power (it's "Digitus DN-7042" ) and costs almost the same. I got it to work after a little hassle compiling the Realtek hostapd version and 8192cu.ko drivers. No hub required, range seems to be ok for my purpose.

Thanks everybody for your input! Now that I have a working access point with the RPi I can continue working on my secret evil genius project ;)
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by piranha » Sun Jul 22, 2012 1:27 pm
Hey Roughnecks !!

Thanks for this tip !! I've been struggling with a 300Mbit D-Link DWA-140 that eventually didn't work with the RPI (it was a B3 rev., anyway..). I'm trying to figure a way to create a wifi AP just like you did and so i just ordered a DN-7042-1 on your advice.

Please, could you be kind enough to tell me (us) how you successfully:
1) installed the wifi usb key on the RPI ?
2) installed the hostap on the RPI ?

(sorry i'm not a big linux expert so details on command lines would be more than welcome..)

Thank you so much :o)
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by Roughnecks » Sun Jul 22, 2012 9:17 pm
Hi piranha!
I'll post a detailed instruction later this week, unfortunately I'm a bit busy this week.

Maybe this helps you already:
- latest raspbian image
- install kernel 3.2 and the kernel sources and headers! (<- really important!)
- download the realtek 8192cu driver package from.. (sorry, wrong computer, don't have the link now, just google please)
- extract the zip on your real computer and see the documentation folder for a PDF file that describes how to compile a) the driver and b) the realtek-hostap version (yes it's different from that from debian)
- be sure after you compiled the driver that it is loaded! mine was put into another directory and I had a the debian-driver and the realtek-driver and the debian driver was loaded by default (i then simply copied the realtek over the debian)
- use the realtek hostap binary, not the one from debian (that's why above i had to install kernel 3.2 with sources), then you should get your very own access point on the Raspberry Pi :)

Ok, that was almost step by step from my memory. Again, I hope I can post more detailed later this week. Hope that helps a bit already :)
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by piranha » Sun Jul 22, 2012 9:33 pm
Thank you for these informations, Roughnecks !!
I'll try these once i receive my wifi usb key !!
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by piranha » Fri Jul 27, 2012 1:40 pm
Hey Roughnecks (& others!),

I received my digitus wifi usb dongle and am trying to follow your instructions.
Obviously, a lot of issues are coming and help would be more than appreciated :)

So:
- latest raspbian image CHECK
- install kernel 3.2 FAILED
here is what i did:
I followed the instructions on this website:
http://www.bootc.net/projects/raspberry-pi-kernel/

I started by updating the firmware of my RPi by doing this:
https://github.com/Hexxeh/rpi-update
http://goo.gl/1BOfJ -> copy paste file /usr/bin/rpi-update
chmod +x /usr/bin/rpi-update
sudo apt-get install ca-certificates git-core
rpi-update
reboot

works fine!!!

then i resume on the kernel 3.2 installation and as i try to install the linux image package:
"dpkg -i linux-image-3.2.23-rpi1+_1_armel.deb"
then i get a : "package architecture (armel) does not match system (armhf)"

I understand that my architecture does not match what i m trying to install but i don't see a solution at this point. Could you please give me details on how to install kernel 3.2 ? Thank you !! :)

- install .. kernel sources and headers! (<- really important!)

apt-get install linux-source-3.2 linux-headers-3.2.0-3-all
works fine, i hope these are what will be required afterwards ..

- download the realtek 8192cu driver package from.. (sorry, wrong computer, don't have the link now, just google please)

i took it from http://www.realtek.com.tw/downloads/sea ... ord=8192cu

- extract the zip on your real computer and see the documentation folder for a PDF file that describes how to compile a) the driver and b) the realtek-hostap version (yes it's different from that from debian)

the corresponding pdf file lacks a bit of details.
please could you help (again, sorry..)

there is a driver folder, i guess i am meant to perform:
make clean
make
make install ?

as for the hostap application, should i do the same for the folder "wpa_supplicant_hostapd-0.8" ?

- be sure after you compiled the driver that it is loaded! mine was put into another directory and I had a the debian-driver and the realtek-driver and the debian driver was loaded by default (i then simply copied the realtek over the debian)

how to ensure your drivers are properly loaded ?

- use the realtek hostap binary, not the one from debian (that's why above i had to install kernel 3.2 with sources), then you should get your very own access point on the Raspberry Pi :)

could you be kind enough to give an example of your hostapd.conf file please?

i know it's a lot of questions :?
but again, i would really appreciate these informations !!
cheers !! :D
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by Roughnecks » Fri Jul 27, 2012 6:52 pm
Hi,

here's what I did (hope it works!), If not, tell me what doesn't work please, then I'll have a look what's wrong.
For ease of use, login as root (and save your data from the sd card before...).
First the commands what to do, afterwards my configuration files.

Download and "install" the 3.2 kernel (plus header files):
Code: Select all
apt-get update
apt-get install linux-image-3.2.0-3-rpi linux-headers-3.2.0-3-rpi
cd /boot/
cp kernel.img kernel.img.3.1.9.backup
mv vmlinuz-3.2.0-3-rpi kernel.img
reboot



Download the "RTL8188C_8192C_USB_linux_v3.4.3_4369.20120622" driver file from realtek.
Unzip it (I unzipped to /rtl ("mkdir /rtl"))

Code: Select all
cd /rtl/RTL8188C_8192C_USB_linux_v3.4.3_4369.20120622/
chmod +x install.sh
./install.sh
cd wpa_supplicant_hostapd/
unzip wpa_supplicant_hostapd-0.8_rtw_20120622.zip
cd wpa_supplicant_hostapd-0.8
cd hostapd/
make



now we have: the realtek driver, and the realtek hostapd binary
the install.sh script put the driver into the wrong(?) directory.
because I didn't know better, I just copied the realtek driver over the debian driver:


Code: Select all
cp /lib/modules/3.2.0-3-rpi/kernel/drivers/net/wireless/8192cu.ko /lib/modules/3.2.0-3-rpi/kernel/drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.ko



now reboot. It should work if you start as root:


Code: Select all
cd /rtl/RTL8188C_8192C_USB_linux_v3.4.3_4369.20120622/wpa_supplicant_hostapd/wpa_supplicant_hostapd-0.8/hostapd/
./hostapd -dd /etc/hostapd/hostapd.rtl8192.conf


If all is ok, you now have your own wifi access point on the raspberry pi :)

attention: if you don't use "./" before hostapd, it will run the debian version, not the realtek hostapd from the directory you did cd into!

Ok, here my configuration files:

/etc/network/interfaces
auto lo eth0 #br0

iface lo inet loopback

iface eth0 inet static
address 192.168.1.14
gateway 192.168.1.1
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255

# Wireless Interface
iface wlan1 inet static
address 192.168.1.14
network 192.168.1.0
gateway 192.168.1.1
netmask 255.255.255.0
broadcast 192.168.1.255


your network configuration may be different!

/etc/hostapd/hostapd.rtl8192.conf
interface=wlan1
ssid=abcdefg
channel=1
#hw_mode=g
#bridge=br0



Instead of wlan1 you can also use wlan0 (this is because I tried another wifi-usb-dongle before).

attention: this is the MOST BASIC hostapd configuration I there is. Use it only for testing purposes.
If your hostapd is running, check with your mobile phone for an open wifi called "abcdefg".
If you see it, everything works fine. You can't connect to it yet, though. You need to setup a bridge network.

For PROPER!!! hostapd config (with wpa2 encryption, bridging to your own network, and so on) see these links:
https://bbs.archlinux.org/viewtopic.php?id=135974
http://forum.doozan.com/read.php?2,6300
For a bridged setup you will need to: apt-get install bridge-utils

Good luck, tell me how it went :)
- Ben


P.S.: I really do not know if you need that... please try without it first:
apt-get install rfkill network-manager
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by piranha » Sun Jul 29, 2012 10:40 am
Hey Ben !

I can't tell you how much i appreciate your reply. Thank you so much for giving me so many details !!

I will be able to resume my Raspberrian activities tonight .. so i'll follow your instructions, and will definitely give you a feedback on how it went !! :D

How about you, how is your secret evil genius project doing ? ;)

cheers,
Fabien
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by piranha » Mon Jul 30, 2012 1:36 pm
Hey Ben,
So i followed your instructions and it worked great.
However, i can't seem to easily set up my access point, but since it appeared once i'll keep working on in, might be a bit unstable -- obviously it is a configuration issue and i'll try to read the links in your posts.
As you asked, i tried without using "apt-get install rfkill network-manager" and it was ok !!
Thank you again!
Fab
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by Roughnecks » Mon Jul 30, 2012 6:13 pm
Hi Fab,
that's strange. do you have the dongle plugged in during boot? do you use any other USB devices at the same time? can you post the output of dmesg? do you get any "smsc95xx 1-1.1:1.0: eth0: kevent 2 may have been dropped" errors during boot maybe?
maybe it helps to increase vm.min_free_kbytes or to disable the ethernet turbomode with smsc95xx.turbo_mode=N (mentioned here: viewtopic.php?p=134136#p134136).
hope you get it stable and working again!
- Ben
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by piranha » Tue Jul 31, 2012 6:09 pm
I did reinstall from scratch, performed once again your instructions and this time i got everything working fine except that after 45 seconds of working wifi AP, the console (that shows the ourput of ./hostapd -dd ..) displays this message:
"l2_packet_receive - recvfrom: Network is down"
then the LED of the dongle stops working and the wifi AP disappears..

I have not found the cause yet, although i have the feeling it may be linked to power saving configuration since the output of dmesg gives:
http://pastebin.com/uukqw1Bm

To answer your questions: i do have the dongle plugged in during boot and i do not have any other USB device plugged apart from the dongle.

I saw your advices related to vm.min_free_kbytes or smsc95xx.turbo_mode=N, but i am not sure that they are linked to this issue since the first one is for OOM and the second one is for the "smsc95xx 1-1.1:1.0: eth0: kevent 2 may have been dropped", which both issues i don't seem to have..

Didn't you meet this behavior on your RPi too ?

Thank you,
-Fab
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by Roughnecks » Tue Jul 31, 2012 7:28 pm
huh.. strange! maybe you need more stuff that I have installed accidentially.
I mentioned:
Code: Select all
apt-get install rfkill network-manager

above. maybe that solves the problem already. Please check "wpasupplicant" too:
Code: Select all
apt-get install wpasupplicant


if that doesn't work either, I have no clue... maybe just post all your config files.. but I guess they don't look much different then the ones I posted...
During the 45 seconds, can you "connect"? Your mobile should say something like "trying to get IP address..." ....?

- Ben

by the way, that's my output:
Code: Select all
root@raspberrypi:/home/pi# /rtl/RTL8188C_8192C_USB_linux_v3.4.3_4369.20120622/wpa_supplicant_hostapd/wpa_supplicant_hostapd-0.8/hostapd/hostapd -dd /etc/hostapd/hostapd.rtl8192.conf
random: Trying to read entropy from /dev/random                                                                                                                                                                     
Configuration file: /etc/hostapd/hostapd.rtl8192.conf                                                                                                                                                               
drv->ifindex=3                                                                                                                                                                                                       
l2_sock_recv==l2_sock_xmit=0x0x48d650                                                                                                                                                                               
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)                                                                                                                                                                   
Allowed channel: mode=1 chan=1 freq=2412 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=2 freq=2417 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=3 freq=2422 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=4 freq=2427 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=5 freq=2432 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=6 freq=2437 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=7 freq=2442 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=8 freq=2447 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=9 freq=2452 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=10 freq=2457 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=11 freq=2462 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=12 freq=2467 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=1 chan=13 freq=2472 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=1 freq=2412 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=2 freq=2417 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=3 freq=2422 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=4 freq=2427 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=5 freq=2432 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=6 freq=2437 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=7 freq=2442 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=8 freq=2447 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=9 freq=2452 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=10 freq=2457 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=0 chan=11 freq=2462 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=2 chan=36 freq=5180 MHz max_tx_power=0 dBm                                                                                                                                                     
Allowed channel: mode=2 chan=40 freq=5200 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=44 freq=5220 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=48 freq=5240 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=52 freq=5260 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=56 freq=5280 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=60 freq=5300 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=64 freq=5320 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=100 freq=5500 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=104 freq=5520 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=108 freq=5540 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=112 freq=5560 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=116 freq=5580 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=120 freq=5600 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=124 freq=5620 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=128 freq=5640 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=132 freq=5660 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=136 freq=5680 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=140 freq=5700 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=149 freq=5745 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=153 freq=5765 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=157 freq=5785 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=161 freq=5805 MHz max_tx_power=0 dBm
Allowed channel: mode=2 chan=165 freq=5825 MHz max_tx_power=0 dBm
Completing interface initialization
Mode: IEEE 802.11g  Channel: 1  Frequency: 2412 MHz
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x1
RATE[3] rate=110 flags=0x1
RATE[4] rate=60 flags=0x0
RATE[5] rate=90 flags=0x0
RATE[6] rate=120 flags=0x0
RATE[7] rate=180 flags=0x0
RATE[8] rate=240 flags=0x0
RATE[9] rate=360 flags=0x0
RATE[10] rate=480 flags=0x0
RATE[11] rate=540 flags=0x0
Flushing old station entries
Deauthenticate all stations
+rtl871x_sta_deauth_ops, ff:ff:ff:ff:ff:ff is deauth, reason=2
rtl871x_set_key_ops
rtl871x_set_key_ops
rtl871x_set_key_ops
rtl871x_set_key_ops
Using interface wlan3 with hwaddr 00:e0:4c:09:e9:97 and ssid 'test'
rtl871x_set_wps_assoc_resp_ie
rtl871x_set_wps_beacon_ie
rtl871x_set_wps_probe_resp_ie
rtl871x_set_beacon_ops
rtl871x_set_hidden_ssid_ops
wlan3: Setup of interface done.
random: Got 20/20 bytes from /dev/random
Wireless event: cmd=0x8b15 len=20

Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by piranha » Wed Aug 01, 2012 11:51 am
Thanks, but i tried with the 3 packages and it didn't change much (except maybe buying one more minute.. weird). I tried to reinstall everything from scratch, just in case, and it's still the same behavior. I have no idea.
Configuration files have been kept as minimal/unchanged as possible. Actually, i'm just changing the hostapd.conf and nothing else ..
I have been trying with other wifi channels, just in case, but no ..
Also i tried to upgrade the firmware (the wlan0 interface disappeared), hence i reinstalled from scratch ..

What's different from you is that the output of my hostapd gives:
Code: Select all
random: Got 20/20 bytes from /dev/random
Wireless event: cmd=0x8b15 len=20
Wireless event: cmd=0x8b15 len=20
Wireless event: cmd=0x8b19 len=8
Wireless event: cmd=0x8b19 len=8
Wireless event: cmd=0x8b19 len=8
Wireless event: cmd=0x8b19 len=8
Wireless event: cmd=0x8b19 len=8
l2_packet_receive - recvfrom: Network is down
Wireless event: cmd=0x8b15 len=20


It's just so weird that we have the same hardware and settings and we don't get similar behaviors :|

- Fab

ps: to answer your question, the client tries to get an IP indeed.
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by Roughnecks » Wed Aug 01, 2012 5:27 pm
really strange :shock:

can you post your hostapd.conf? I'll try with your config... maybe I can reproduce it.
what's "uname -r" telling you?

greetings,
Ben
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by piranha » Wed Aug 01, 2012 10:10 pm
Hey Ben !

uname -r returns "3.2.0-3-rpi".

hostapd.conf is the one you wrote in your post:
Code: Select all
interface=wlan0
ssid=abcdefg
channel=1
#hw_mode=g
#bridge=br0


I also tried with the hostapd.conf found in the "/rtl/wpa..../hostapd" original folder.

Always, after a while, the message "l2_packet_receive - recvfrom: Network is down" shows up, the dongle LED stops working and the Wifi AP signal is dropped.

Do you think of other files that you may have modified ?
Could i see your hostapd.conf please ?

Thank you!!
- Fab
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by piranha » Thu Aug 02, 2012 1:48 pm
Also, by the way, could it be an electric power issue ?
How do you "feed" your RPi ?

Do you think trying ArchLinux might help somehow .. ?
(not sure that evolving to kernel 3.2 would be that easy with Arch)
Posts: 10
Joined: Sun Jul 22, 2012 1:17 pm
by Roughnecks » Thu Aug 02, 2012 6:15 pm
I use a 1000mAh power supply. But I don't think it's power related. As you say it works for a minute or so...
Do you start the LXDE gui? Have you tried the vm.min_free_kbytes settings meanwhile?
I've never used ArchLinux and I don't know wether it would change anything, anyway, you could give it a try.
If I find enough time I'll dd my SD-Card and upload it somehwere, or - if it's possible for you - you could upload your image. I'm a bit busy, as usually... :|
Greetings,
Ben
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by Roughnecks » Sat Aug 04, 2012 11:47 am
Hi Fab, sent you a private message just in case you didn't notice :)
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by avitada » Tue Aug 07, 2012 11:03 am
Hi i wonder if any one can help.
i have got wireless USB "Sitecom 150N" apart from seeing it on my >lsusb.
not sure how to make it work .i 'm familiar with linux but not to the extend that the other guys are showing in this post.
thank you
David A
Posts: 3
Joined: Tue Aug 07, 2012 10:54 am
by Roughnecks » Tue Aug 07, 2012 7:59 pm
Hi avitada,
can you post the exact model? It should be somewhere in the "lsusb" output.
Greetings,
Ben
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am
by avitada » Wed Aug 08, 2012 3:50 pm
Thank you Ben
when the system bootup i can see under USB product RTL8188S adaptor.
under >lsusb sitecom Europe B.V

i also loaded network manager GUI from synaptic.
when i try to give myself a static ip address (in order to connect to my laptop)
it does not look like it change it /etc/network/interfaces have just dhcp. this is my second issue..
thank you for your help Ben
Posts: 3
Joined: Tue Aug 07, 2012 10:54 am
by Roughnecks » Wed Aug 08, 2012 4:21 pm
Here is a great walkthrough: http://omer.me/2012/04/setting-up-wirel ... pberry-pi/
If you can't get it to work with that tutorial, please come back here :)
Posts: 22
Joined: Sun Jun 03, 2012 11:47 am