debian hangs at keymap [Solved]


16 posts
by sorinm » Sun May 13, 2012 7:16 am
After i used dpkg-reconfigure keyboard and set my keyboard to us , debian hangs 3 min at setting preliminary keymap

It also says.. Skipping font and keymap setup (handled by console-setup) and then also hangs about 1 min at setting up console font and keymap.
User avatar
Posts: 138
Joined: Sat Mar 03, 2012 10:41 am
Location: Romania
by sorinm » Sun May 13, 2012 7:55 am
Sorry for double post. I wrote from ICS stock browser and double posted.
User avatar
Posts: 138
Joined: Sat Mar 03, 2012 10:41 am
Location: Romania
by paaland » Sun May 13, 2012 8:20 am
I experience the same. Did a reconfigure since I use a norwegian keyboard layout, but the slow boot is really a pain. Thankfully the raspi is mostly on :)

I tried searching the forum as well as google, but I did not find anyting that was helpful.
Dragon 32>BBC Model B>PC>PC>PC>PC>Raspberry PI (circle complete)
User avatar
Posts: 68
Joined: Mon Mar 12, 2012 2:30 pm
Location: Norway
by Otis » Sun May 13, 2012 4:12 pm
+1
User avatar
Posts: 4
Joined: Mon Feb 13, 2012 12:43 pm
by aaroncoffey » Mon May 14, 2012 6:50 pm
Same issue here, debian squeeze, US keymap.
Posts: 10
Joined: Mon May 14, 2012 6:43 pm
by Otis » Mon May 14, 2012 8:12 pm
Otis wrote:+1


I should have added, debian 19-4 & US keymap.
User avatar
Posts: 4
Joined: Mon Feb 13, 2012 12:43 pm
by jojopi » Thu May 17, 2012 7:11 am
This is a real-time-clock related issue. Debian uses some very slow shell and perl to build the keyboard map. It tries to cache the results, but this depends on timestamps being monotonic across boots.

The best solution for now is to run "sudo setupcon" once manually. Preferably immediately after changing the keyboard layout, but any time when the clock is set correctly should be fine.

Incidentally, the Cambridge "set_recent_time.sh" hack is nearly useless. It runs far too late in the boot sequence to fix most of the issues, and it does not work at all in timezones west of Greenwich. Is there a preferred way to report bugs in the distribution?
User avatar
Posts: 2131
Joined: Tue Oct 11, 2011 8:38 pm
by jacques » Thu May 17, 2012 4:44 pm
kudos to jojopi
Posts: 28
Joined: Thu May 03, 2012 6:18 pm
by sorinm » Thu May 17, 2012 7:26 pm
Ok, this issue is solved, Thanks ! :)
User avatar
Posts: 138
Joined: Sat Mar 03, 2012 10:41 am
Location: Romania
by Otis » Fri May 18, 2012 12:57 am
sorinm wrote:Ok, this issue is solved, Thanks ! :)


Worked great for me as well. Thanks!
User avatar
Posts: 4
Joined: Mon Feb 13, 2012 12:43 pm
by philipm » Wed Jun 06, 2012 1:20 pm
I tried this (setupcon presumably should be done before you start x since a normal terminal window isn't a console), and it's still pretty slow booting. And I did remember to set the date. But at least the key map is right.
Posts: 29
Joined: Mon Aug 29, 2011 9:46 am
by gkovacsp » Fri Jun 08, 2012 6:51 pm
sudo setupcon cured my pi as well
Posts: 1
Joined: Fri Jun 08, 2012 6:50 pm
by Wenceslao » Mon Jun 11, 2012 10:15 pm
Thanks Jojopi. I was bragging to my friends about the Pi and it looked bad when it took several minutes to boot. Now it's up in running quickly.
Posts: 1
Joined: Mon Jun 11, 2012 9:54 pm
by o9p0 » Mon Jul 09, 2012 5:24 am
Thanks, sudo setupcon solved my problem when i change my keyboard to PT.
Posts: 6
Joined: Thu Jun 28, 2012 2:53 am
by rocketero » Tue Jul 17, 2012 1:29 am
thanks also here, I was starting to worry why it was taking so long to boot and seemed like hanging at the "Setting Preliminary Keymap .." boot message. that short solution really fix it.
Posts: 64
Joined: Wed Jul 11, 2012 5:45 pm
by rew » Sat Apr 27, 2013 2:38 pm
Still works. :-)

Note that you CAN run it when logged in over SSH into the raspberry pi. (I was a bit scared it might mess up my X session on my PC somehow, but on second thought that should be unlikely... )
Check out our raspberry pi addons: http://www.bitwizard.nl/catalog/
User avatar
Posts: 396
Joined: Fri Aug 26, 2011 3:25 pm