Keyboard layout "german" ? (resolved)


6 posts
by RABIS50 » Tue May 15, 2012 7:43 am
Hi,
is there a way to change (permanently) the keyboard layout in "german" ?
Distro is Debian "squeeze".

Thanks
Rabis50
User avatar
Posts: 8
Joined: Tue May 15, 2012 6:56 am
by abishur » Tue May 15, 2012 3:16 pm
sudo nano /etc/default/keyboard

find where it says

XKBLAYOUT=”gb”

and change the gb to the two letter code for german :-)
Dear forum: Play nice ;-)
User avatar
Forum Moderator
Forum Moderator
Posts: 4250
Joined: Thu Jul 28, 2011 4:10 am
Location: USA
by aaroncoffey » Tue May 15, 2012 4:51 pm
Added to the wiki with attribution. Thanks!
http://elinux.org/R-Pi_Troubleshooting# ... ut_Devices
Posts: 10
Joined: Mon May 14, 2012 6:43 pm
by ruinah » Mon Jun 11, 2012 1:47 am
I followed this advice to switch my keyboard layout from 'gb' to 'us', as I was without the | key in the GB layout. I am currently using a Logitech K400 wireless keyboard & touchpad combo, which both work fine in LXDE. Unfortunately, now my pi temporarly hangs at "Setting preliminary keymap". Eventually, it times out, but then gets stuck in a loop repeating "phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware." This repeats until it eventually times out as well. Everything else seems to work just fine after that. I was wondering if there's some way of fixing this? I should mention that I'm still fairly novice at Linux use.
Posts: 3
Joined: Mon Jun 11, 2012 1:38 am
by Lob0426 » Mon Jun 11, 2012 4:07 pm
Try dpkg reconfigure.

sudo dpkg-reconfigure locales

Make sure you uncheck en-gb.utf8 and check yours, use space bar and Tab
Then run:

sudo dpkg-reconfigure keyboard-configuration.

To change your time zone run:

sudo dpkg-reconfigure tzdata

To get past the hang ups during boot:

sudo setupcon
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1907
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by ruinah » Wed Jun 13, 2012 11:45 pm
Thanks for the awesome help! I determined that the "failed to get firmware" error was being caused by my USB wireless dongle, but the keymap problem has been cleared up. Thanks!
Posts: 3
Joined: Mon Jun 11, 2012 1:38 am