Automatic setup for RTL8188CUS based wifi adapters


 
1148 posts   Page 26 of 46   1 ... 23, 24, 25, 26, 27, 28, 29 ... 46
by bastian94 » Mon Aug 13, 2012 10:20 am
I don't know a thing about programing so idon't know were i should change in your script. the fireware that is recuired for my usb dongle i have it it's included in the latest rasbian
Posts: 64
Joined: Fri Jun 08, 2012 7:57 pm
Location: Sweden
by MrEngman » Mon Aug 13, 2012 11:05 am
Florisvos wrote:Do you have a guide for atheros chipsets?


Sorry, no.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Montala » Mon Aug 13, 2012 11:14 am
bastian94 wrote:I don't know a thing about programing so idon't know were i should change in your script. the fireware that is recuired for my usb dongle i have it it's included in the latest rasbian

If you are using a wi-fi adapter (such as the Asus-USBN10) for which the drivers are already included in Raspbian "wheezy, then you don't really need to use a script at all.

Have a look at viewtopic.php?f=66&t=12330 to read about some others users experiences, which will be similar for other adapters.

Actually I am not really sure which chipset drivers are included in "wheezy"... it would be good to know!
User avatar
Posts: 638
Joined: Mon Mar 05, 2012 11:54 pm
Location: Herefordshire (U.K.)
by juniperz » Mon Aug 13, 2012 8:22 pm
Firstly, thanks MrEngman, from this complete linux noobie with a Raspberry Pi fresh out of the box yesterday.
It was all going so well. The scrip worked (after a few false starts) and I was wifi connected without touching an ethernet cable. It then offered the system updates, which I took. At the end it said that it should reboot and that if it stopped on reboot, then turning off then on again should work, and that this had never been known to fail (famous last words).
It didn't reboot. I turned off the power supply at the wall, waited, then powered up. It boots, goes through a lot of boot info, then just sits on a black screen with a flashing cursor (underline). I had originally set it to boot into the desktop, which it had done many times today. Now it always just sits with the flashing cursor.
You can type characters in. Enter gives a new line, but no syntax error messages, so I don't think it is any kind of command line. Help please?
Posts: 2
Joined: Mon Aug 13, 2012 8:18 pm
by biwa7636 » Tue Aug 14, 2012 4:14 pm
Hi guys,
I have to say that the ASUS-N10 for me is such a pain of ass. :evil:
Here is what I have done and any help is appreicated.
--------------------------------------------------------------------------------------------------------
Basically there are three methods right now:
1. Engman who wrote a script and help you set up your wifi automatically.
2. Montala using wicd and wicd-gtk to use GUI to set up network
3. Popiman install the kernal and interfaces/modules/neworkrestart....etc.
--------------------------------------------------------------------------------------------------------
Here are the settings showed up on my Pi
Hardware:
ASUS N10 wifi connect to the usb port on the Pi board. Mice(LogitechM110) and keyboard(Kensington) connected using unpowered hub.

Software:
OS: wheesy 7-15 version
lsusb: BUS 001 Device 016: ID 0b05:1786 ASUSTeck Computer, Inc. USB-N10 802.11n Network Adapter [Realteck RTL8188SU]

/etc/network/interfaces
Code: Select all
auto lo
iface lo inet loopback
iface eth0 inet dhcp
allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-ssid "BigLebowski"
wpa-psk "iloveCel1neD1on"


When I type in .networking restart...
Here is what they showed:
Code: Select all
Running /etc/init.d/netowrking restart is deprecated because it may not r
[warnble some interfaces..(warning))]
...
Listening on LPF/wlan0/c8:60:00:5e:2c:30
Sending  on LPF/wlan0/c8:60:00:5e:2c:30
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
Unable to obtain a lease on frist try. Exiting.
Failed to bring up wlan0.
done.


I even can't see the wifi dongler's tiny blue light right now..
Posts: 24
Joined: Mon Aug 06, 2012 2:23 pm
by MrEngman » Tue Aug 14, 2012 4:50 pm
biwa7636 wrote:Hi guys,
I have to say that the ASUS-N10 for me is such a pain of ass. :evil:
Here is what I have done and any help is appreicated.
--------------------------------------------------------------------------------------------------------
Basically there are three methods right now:
1. Engman who wrote a script and help you set up your wifi automatically.
2. Montala using wicd and wicd-gtk to use GUI to set up network
3. Popiman install the kernal and interfaces/modules/neworkrestart....etc.
--------------------------------------------------------------------------------------------------------
Here are the settings showed up on my Pi
Hardware:
ASUS N10 wifi connect to the usb port on the Pi board. Mice(LogitechM110) and keyboard(Kensington) connected using unpowered hub.

Software:
OS: wheesy 7-15 version
lsusb: BUS 001 Device 016: ID 0b05:1786 ASUSTeck Computer, Inc. USB-N10 802.11n Network Adapter [Realteck RTL8188SU]

/
I even can't see the wifi dongler's tiny blue light right now..


My script installs the driver for realtek rtl8188CUS devices not rtl8188SU devices like your N10. The N10 device uses a a different driver and if you use my script the wifi will not work because the wrong driver will be installed.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by biwa7636 » Tue Aug 14, 2012 5:10 pm
Thanks for your fast reply Mr.Engman
Posts: 24
Joined: Mon Aug 06, 2012 2:23 pm
by Montala » Tue Aug 14, 2012 5:23 pm
To avoid confusion I have replied in the Asus-N10 thread!
User avatar
Posts: 638
Joined: Mon Mar 05, 2012 11:54 pm
Location: Herefordshire (U.K.)
by mattura » Tue Aug 14, 2012 10:49 pm
Looks like a nice tool.
But it has a problem when it lists the wireless networks, I get a list of one:
wlan0 interface doesn't support scanning

My dmesg also has the following line after the usb adapter:
8192cu: disagrees about version of symbol module_layout

Any ideas?
Posts: 20
Joined: Tue Aug 14, 2012 6:51 pm
by MrEngman » Tue Aug 14, 2012 11:37 pm
mattura wrote:Looks like a nice tool.
But it has a problem when it lists the wireless networks, I get a list of one:
wlan0 interface doesn't support scanning

My dmesg also has the following line after the usb adapter:
8192cu: disagrees about version of symbol module_layout

Any ideas?

The dmesg output says the driver version that's installed is not valid for the kernel version you have. This shouldn't happen. That is why you see "wlan0 interface doen't support scanning" as the driver is not loaded when it tries the wireless network scan.

Are you using a wired internet connection when you run the script or are you copying the files to the SD card and running with no initial internet connection?

What distro are you using? Has it been updated/upgraded/modified? If yes, how? What is the output of command
Code: Select all
uname -a
.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by mattura » Wed Aug 15, 2012 10:29 am
I have a wired connection to the Pi.
I'm using Wheezy as downloaded with Berryboot, which gives:

Code: Select all
Linux raspberrypi 3.1.9-cutdown-aufs #23 PREEMPT Mon Aug 13 15:20:21 CEST 2012 armv6l GNU/Linux


On a fresh install of the above your script now bombs out with an "unrecognised software version".

It seems that Berryboot currently installs a strange version of Wheezy (though I'm not sure where it comes from or how to change it). It is nice to have a dual boot between OpenElec and Wheezy, any idea what I'd have to do to get this working?
Thanks
Posts: 20
Joined: Tue Aug 14, 2012 6:51 pm
by wallarug » Wed Aug 15, 2012 12:04 pm
mattura wrote:Looks like a nice tool.
But it has a problem when it lists the wireless networks, I get a list of one:
wlan0 interface doesn't support scanning

My dmesg also has the following line after the usb adapter:
8192cu: disagrees about version of symbol module_layout

Any ideas?

Same problem!
Youtube Channel: http://www.youtube.com/user/CMDenterprises
Project page: http://code.google.com/p/cmd-robot/
~~ Now selling Apps on the Google Play, WP and Apple App Stores. ~~
Posts: 432
Joined: Mon May 14, 2012 8:21 am
by MrEngman » Wed Aug 15, 2012 12:16 pm
wallarug wrote:
mattura wrote:Looks like a nice tool.
But it has a problem when it lists the wireless networks, I get a list of one:
wlan0 interface doesn't support scanning

My dmesg also has the following line after the usb adapter:
8192cu: disagrees about version of symbol module_layout

Any ideas?

Same problem!

What does command uname -a show?
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by wallarug » Wed Aug 15, 2012 12:48 pm
MrEngman wrote:
wallarug wrote:I posted here a few days ago.

I have been experiencing some problems with the RPi relating to the wireless and network connectivity:
1. I can now only boot the device when the wireless adapter is plugged in.
2. I cannot use ethernet anymore
3. The rpi-update did not complete when the script was run.

Any fixes for the above will be apreciated.

wallarug

I saw your post from yesterday that said it was all working!

Looks like rpi-update may have corrupted the SD card. I'm not sure exactly how to fix this other than starting with a new image or possibly running rpi-update again. rpi-update does make a backup of the boot directory in directory /boot.bak so it may be possible to recover by copying the files in /boot.bak back to the /boot directory.
Code: Select all
sudo cp /boot.bak/* /boot
No need to use "sudo" if logged in as root. Probably best to try this first.

To run rpi-update again you will probably need to delete the file /boot/.firmware_revision
Code: Select all
sudo rm /boot/.firmware_revision
otherwise it is likely to say the firmware is already up to date.

If you continue to have problems it may be best to try posting in the troubleshooting forum for more help.

The only problem I have now is Problem 3 which has seemed to have corrupted the SD card becasue some software oesn't work. I am going to start fresh and see what happens.

So basically, run it and then enter settings and follow insturctions and everything should work.

Also, How can I install multiple networks onto one adapter? I have two networks that I would be using the device on and I would like to be able to connect with the same SD card. The one problem is, they are two different security types. One is 'open' the other is sercured with WPA2. How can I have both registered?
Youtube Channel: http://www.youtube.com/user/CMDenterprises
Project page: http://code.google.com/p/cmd-robot/
~~ Now selling Apps on the Google Play, WP and Apple App Stores. ~~
Posts: 432
Joined: Mon May 14, 2012 8:21 am
by MrEngman » Wed Aug 15, 2012 2:32 pm
wallarug wrote:The only problem I have now is Problem 3 which has seemed to have corrupted the SD card becasue some software oesn't work. I am going to start fresh and see what happens.

So basically, run it and then enter settings and follow insturctions and everything should work.

Also, How can I install multiple networks onto one adapter? I have two networks that I would be using the device on and I would like to be able to connect with the same SD card. The one problem is, they are two different security types. One is 'open' the other is sercured with WPA2. How can I have both registered?

You should be able to do that with wpa_supplicant. I have one image set up to do that. There is a load of stuff on the internet about wpa_supplicant.

You will need to change the file /etc/network/interfaces and make a file /etc/wpa_supplicant.wpa_supplicant.conf

On my system I did the following - change /etc/network/interfaces
Code: Select all
#wpa-ssid "SSID"                                 <-- comment out with # or delete
#wpa-psk "PASSWORD"                              <-- comment out with # or delete
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf <-- add line
And then created file /etc/wpa_supplicant/wpa_supplicant.conf
Code: Select all
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1

network={
ssid="SSID-1"
key_mgmt=WPA-PSK
proto=RSN
pairwise=CCMP TKIP
group=CCMP TKIP
#psk="PASSWORD"   <- plain text password, uncomment to use this, comment out or delete if using hex-password
psk=HEX-PASSWORD  <- hex encoded password, delete if using plain text password
}

network={
ssid="SSID-2"
key_mgmt=NONE
}


I have not tried it with an unsecured network so those settings may or may not work. My knowledge of wpa_supplicant is almost nil so if you've any questions the Troubleshooting thread may be a better to make enquiries. There is an application wpa_passphrase that can convert your plain text password into a hex encoded password.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Snakehead321 » Wed Aug 15, 2012 5:18 pm
I successfully ran this script on raspian, now I am trying it on a distro with some stuff per installed and I'm getting a 747: let: not found thing when I try to run the script. I'm pretty much a newb at Linux so any help would be appreciated
Posts: 7
Joined: Mon Aug 13, 2012 10:22 pm
by MrEngman » Wed Aug 15, 2012 6:41 pm
Snakehead321 wrote:I successfully ran this script on raspian, now I am trying it on a distro with some stuff per installed and I'm getting a 747: let: not found thing when I try to run the script. I'm pretty much a newb at Linux so any help would be appreciated


Try
Code: Select all
sudo bash /boot/install-rtl8188...
No need for sudo if logged in as root.

Scripts can be run by several different script handlers. My install script needs to run using bash. The script has some commands used in it that are specific to bash. Several people have reported similar problems, but not this particular one, when using SSH. It appears to change the default script handler. Defining bash in the command line should force it to use bash to run the script.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by GarethD » Wed Aug 15, 2012 9:06 pm
Hi I have tried to run this script on my Raspberry Pi but each time it stops with the following:-

"The RTL8188CUS driver module is not installed.
You have 0 wifi adapters configured.
The Pi has an internet connection.
Any files needed for the installation/upgrade will be downloaded from the
Internet.

Unrecognised software version: Linux raspberrypi 3.1.9+ #272 PREEMPT Tue Aug 7 22:51:44 BST 2012 armv6l GNU/Linux

Downloading the latest script.
The script you're using is the latest version.

Aborting the rtl8188cus installation script"


It seems that the version of Rasbian installed is not recognised by the script.
Please help as I am a Noob with Linux and Pi.
Posts: 14
Joined: Wed Aug 15, 2012 8:58 pm
by MrEngman » Wed Aug 15, 2012 11:30 pm
GarethD wrote:Hi I have tried to run this script on my Raspberry Pi but each time it stops with the following:-

"The RTL8188CUS driver module is not installed.
You have 0 wifi adapters configured.
The Pi has an internet connection.
Any files needed for the installation/upgrade will be downloaded from the
Internet.

Unrecognised software version: Linux raspberrypi 3.1.9+ #272 PREEMPT Tue Aug 7 22:51:44 BST 2012 armv6l GNU/Linux

Downloading the latest script.
The script you're using is the latest version.

Aborting the rtl8188cus installation script"


It seems that the version of Rasbian installed is not recognised by the script.
Please help as I am a Noob with Linux and Pi.


Hi GarethD,

Sorry to hear you've had problems. Looks like I've had problems with files not syncing correctly with Dropbox. It should be OK now. Run the script which should now download the latest version which should now be upto date. Then run it again.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Snakehead321 » Wed Aug 15, 2012 11:48 pm
MrEngman wrote:
Snakehead321 wrote:I successfully ran this script on raspian, now I am trying it on a distro with some stuff per installed and I'm getting a 747: let: not found thing when I try to run the script. I'm pretty much a newb at Linux so any help would be appreciated


Try
Code: Select all
sudo bash /boot/install-rtl8188...
No need for sudo if logged in as root.

Scripts can be run by several different script handlers. My install script needs to run using bash. The script has some commands used in it that are specific to bash. Several people have reported similar problems, but not this particular one, when using SSH. It appears to change the default script handler. Defining bash in the command line should force it to use bash to run the script.

MrEngman

Thanks, this worked, just waiting for the dongle to start flashing now
Posts: 7
Joined: Mon Aug 13, 2012 10:22 pm
by GarethD » Thu Aug 16, 2012 12:02 am
MrEngman wrote:
GarethD wrote:Hi I have tried to run this script on my Raspberry Pi but each time it stops with the following:-

"The RTL8188CUS driver module is not installed.
You have 0 wifi adapters configured.
The Pi has an internet connection.
Any files needed for the installation/upgrade will be downloaded from the
Internet.

Unrecognised software version: Linux raspberrypi 3.1.9+ #272 PREEMPT Tue Aug 7 22:51:44 BST 2012 armv6l GNU/Linux

Downloading the latest script.
The script you're using is the latest version.

Aborting the rtl8188cus installation script"


It seems that the version of Rasbian installed is not recognised by the script.
Please help as I am a Noob with Linux and Pi.


Hi GarethD,

Sorry to hear you've had problems. Looks like I've had problems with files not syncing correctly with Dropbox. It should be OK now. Run the script which should now download the latest version which should now be upto date. Then run it again.



Many thanks for the speedy reply MrEngman, thats fixed it great. :D
Posts: 14
Joined: Wed Aug 15, 2012 8:58 pm
by Snakehead321 » Thu Aug 16, 2012 12:22 am
Okay, so it the light came on, but now it won't connect because I said WEP instead of WPA2, what should I do? I tried to connect to my unsecured network afterwards, but that didn't work either
Posts: 7
Joined: Mon Aug 13, 2012 10:22 pm
by MrEngman » Thu Aug 16, 2012 1:52 am
Snakehead321 wrote:Okay, so it the light came on, but now it won't connect because I said WEP instead of WPA2, what should I do? I tried to connect to my unsecured network afterwards, but that didn't work either


You will need to edit the file /etc/network/interfaces.

If you've set your network to use WEP you will have three lines at the end of the file something like
Code: Select all
iface wlan0 inet dhcp
wireless-essid NETWORK-NAME   <-- your network SSID with NO quotation marks
wireless-key NETWORK-KEY      <-- your network password with NO quotation marks

To set it for WPA/WPA2 either comment out or delete the two lines wireless-essid and wireless-key and add the two lines with wpa-ssid and wpa-psk
Code: Select all
#wireless-essid NETWORK-NAME  <-- comment out with # or delete line
#wireless-key NETWORK-KEY     <-- comment out with # or delete line
wpa-ssid "NETWORK-NAME"       <-- add line with your network SSID in quotation marks
wpa-psk "NETWORK-PASSWORD"    <-- add line with your network password in quotation marks

For a network with NO security replace the two lines with network name and password with the single line
Code: Select all
wireless-essid NETWORK-NAME  <-- your network SSID with NO quotation marks

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by wallarug » Thu Aug 16, 2012 10:07 am
I ran the script on a clean install but the rpi-update corrupted the SD card again. It froze at the attached file.

When I run it again, it says:
invaild agruement (times by 20)
for files located in the /lib/module/.../net/wireless/

Any ideas?
Attachments
Rpi-update.PNG
Rpi-update.PNG (55.71 KiB) Viewed 2519 times
Youtube Channel: http://www.youtube.com/user/CMDenterprises
Project page: http://code.google.com/p/cmd-robot/
~~ Now selling Apps on the Google Play, WP and Apple App Stores. ~~
Posts: 432
Joined: Mon May 14, 2012 8:21 am
by MrEngman » Thu Aug 16, 2012 2:55 pm
wallarug wrote:I ran the script on a clean install but the rpi-update corrupted the SD card again. It froze at the attached file.

When I run it again, it says:
invaild agruement (times by 20)
for files located in the /lib/module/.../net/wireless/

Any ideas?

If you interrupt rpi-update that is a bad idea. That is probably why you are now having problems.

rpi-update can take a long time. A lot longer than a few minutes so just wait for it to finish.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1789
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK