Programmare Arduino con RPi su Raspbian


5 posts
by musinfo » Fri Jan 04, 2013 12:47 am
Salve a tutti,
spero qualcuno possa aiutarmi a risolvere un problema che non mi permette di programmare Arduino UNO attraverso l'apposita IDE che gira su Raspbian.
L'installazione della IDE di Arduino è avvenuta senza problemi tramite
Code: Select all
sudo apt-get install arduino

Arduino è collegato a RaspberryPi tramite una porta USB, è correttamente riconosciuto come device su /dev/ttyACM0 e sto operando con l'utente "pi" di default che è presente nel gruppo dialout, ma quando provo a caricare un qualsiasi sketch solamente il led "L" (quello sull'out 13) lampeggia in maniera irregolare, mentre entrambi i led TX e RX rimangono spenti.
La conseguenza è che la IDE non rileva alcuna anomalia, nessun messaggio di errore viene mostrato sia in fase di compilazione sia in fase di caricamento del programma sulla Flash Memory, ma in effetti nessun nuovo codice viene caricato in memoria. Per la cronaca: nessun problema nella programmazione su una piattaforma Windows, quindi da escludere malfunzionamenti di Arduino.

Grazie!
Posts: 2
Joined: Thu Jan 03, 2013 11:50 pm
by zaxxon-x » Fri Jan 04, 2013 7:43 pm
Conosco Arduino solo di nome, ma per caso si alimenta dal bus usb?
Se è così potresti provare ad inserire un hub autoalimentato tra il Raspy e l'Arduino, potrebbe essere quello il problema.
Posts: 9
Joined: Sun Dec 16, 2012 11:20 am
by akash73 » Sat Jan 05, 2013 11:55 am
Anche io tendo a propendere per un eccessivo assorbimento sulla USB
prova con un hub alimentato.
----
Andrea

Pi 256 Mb
http://www.akash.it/category/informatica/raspberry-pi/
Posts: 9
Joined: Sat Mar 31, 2012 9:49 am
Location: Turin, IT
by musinfo » Sat Jan 05, 2013 2:55 pm
Avevo già provato a connettere Arduino sia direttamente su una porta USB di RPi sia su un hub alimentato ma il risultato è il medesimo, ovvero quello descritto nel primo post.
Posts: 2
Joined: Thu Jan 03, 2013 11:50 pm
by jackwatt » Fri May 30, 2014 10:13 am
è possibile compilare l'ide 1.5 beta per arduinoDUE ?
Posts: 2
Joined: Fri Mar 15, 2013 8:20 am