Ambilight con raspberry


122 posts   Page 4 of 5   1, 2, 3, 4, 5
by nyar » Mon May 27, 2013 8:33 pm
La captura que has puesto esta bien, no tiene problemas de software al parecer.

Parece claro que es un fallo de hardware.

Suponiendo que hayas hecho bien las conexiones, que parece que sí, el fallo solo puede estar en los dos extremos y yo haría esto.

1. Intentaría probar el spi con la guia que he colgado unos posts antes.

2. Comprobaría que llega la alimentación a los leds.

3. Por si el primer led esta roto y corta la comunicación al resto lo quitaría y probaría a ver.

Saludos y suerte.
Posts: 61
Joined: Mon May 14, 2012 10:50 pm
by ttidds » Tue May 28, 2013 9:41 am
Este viernes me llevo un polimetro del curro a casa y lo pruebo todo bien.
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by sgruben » Wed May 29, 2013 9:38 am
Cuando apago la raspi, la apago desde XBMC, pero no desconecto tension ni RPI ni en la tira de ws2801.

Al rato poco a poco se van encendiendo luces, y ya si lo dejo toda la noche parece una discoteca eso. Pero la raspi esta apagada.

¿POrque puede ser?¿como puedo hacer para que no luzcan, sin tener que quitar la tensión?
Posts: 9
Joined: Thu Mar 14, 2013 1:30 pm
by nyar » Sat Jun 01, 2013 1:08 pm
sgruben wrote:Cuando apago la raspi, la apago desde XBMC, pero no desconecto tension ni RPI ni en la tira de ws2801.

Al rato poco a poco se van encendiendo luces, y ya si lo dejo toda la noche parece una discoteca eso. Pero la raspi esta apagada.

¿POrque puede ser?¿como puedo hacer para que no luzcan, sin tener que quitar la tensión?


En mi caso las variaciones de tensión hacen que se enciendan leds aunque el raspberry este parado. Por ejemplo tengo un subwoofer autoamplificado que provoca un destello cuando lo enciendo y si el rbp esta apagado provoca que se queden algunos leds encendidos. No le he prestado atención pero puede ser un problema de masas, por ahí puedes tener algo que mirar.
Posts: 61
Joined: Mon May 14, 2012 10:50 pm
by MrDenisse » Sun Jun 02, 2013 11:46 am
Hola chicos, estoy hecho un lio con todas las configuraciones que colgais y no se bien como hacer todo este tinglado.
Ya tengo las tiras de led (4 tiras de 1 m. de los ws2801), me falta comprar la fuente de alimentación, que para los leds que necesito voy a comrpar una de 5V 10A para que no me falte.
La historia está al instalar todo en la raspberry.
Tengo una LG 42LW5500 de 42 pulgadas y habia pensado en dejar justo 104leds (32 arriba, 32 abajo y 20 para cada lado), por lo que he podido leer por aqui hay un tutorial para instalarlo justo para este numero de leds.
Mi intención es conectar solo los leds al raspberry sin usar un arduino. La version que tengo es la de 512mb y creo que aunque sea con un poco de overclock si es necesario, debe funcionar.
¿Alguno puede decirme que tutorial sigo?
¿Que distro os ha dado menos problemas a la hora de montar todo el "chiringuito" este?
¿Alguna recomendación?
1 saludo y gracias de antemano.
Posts: 11
Joined: Sun Mar 10, 2013 11:55 pm
by ttidds » Mon Jun 03, 2013 8:37 am
MrDenisse wrote:Hola chicos, estoy hecho un lio con todas las configuraciones que colgais y no se bien como hacer todo este tinglado.
Ya tengo las tiras de led (4 tiras de 1 m. de los ws2801), me falta comprar la fuente de alimentación, que para los leds que necesito voy a comrpar una de 5V 10A para que no me falte.
La historia está al instalar todo en la raspberry.
Tengo una LG 42LW5500 de 42 pulgadas y habia pensado en dejar justo 104leds (32 arriba, 32 abajo y 20 para cada lado), por lo que he podido leer por aqui hay un tutorial para instalarlo justo para este numero de leds.
Mi intención es conectar solo los leds al raspberry sin usar un arduino. La version que tengo es la de 512mb y creo que aunque sea con un poco de overclock si es necesario, debe funcionar.
¿Alguno puede decirme que tutorial sigo?
¿Que distro os ha dado menos problemas a la hora de montar todo el "chiringuito" este?
¿Alguna recomendación?
1 saludo y gracias de antemano.


Yo también tengo 104 leds, aunque modelo LDP8806. Nose si te refieres al tutorial que hay en este post, o a otro en el post ingles que se referia tambien para una configuracion de 104 leds.

De todas formas, te recomendaria que siguieras el ultimo tutorial que hay aqui. Esta basadao en un tutorial que hizo un compañero recopilando la informacion que se daba en varios hilos ingleses hacerca de este tema, y que encontraras aqui.

http://pibob.nadnerb.co.uk/software.html

Sin embargo, varios posts mas atras, veras que yo mismo estructuro un mini tutorial basandome en el tutorial de este enlace, pero con varias modificaciones sugeridas por el compañero nyar, que mejorarian la respuesta de nuestras RbPi.

Mi opinion es que pruebes los pasos que indico mas atras, y en el punto en el que tienes que crear la configuracion boblight.conf, puedes descargarte mi archivo de configuracion y modificar el tipo y el refresco en base a las caracteristicas de tu tira led. Lo demas estaria configurado para los 104 leds.

ttidds wrote:Recopilando vuestras ultimas correcciones, paso a editar los puntos que no me habían quedado claros para dejarlo todo ya por escrito y aclarado.

1. Primero instalamos la distro Raspbmc
2. Instalamos y compilamos Boblight, los comandos los introducimos en el terminal ya sea mediante ssh o en la propia raspi:

2.1. Actualizamos: sudo initctl stop xbmc
sudo apt-get update

2.2. Instalamos paquetes gcc, g++ y subversion:
sudo apt-get install make gcc g++ subversion

2.3. Descargamos fuente boblgiht:
svn checkout http://boblight.googlecode.com/svn/trunk/ /home/pi/boblight_source

2.4. Configurar y comprobar:
cd /home/pi/boblight_source/
./configure --without-portaudio --without-x11 --without-libusb

2.5. Ejecutar:
make;sudo make install

3. Una vez hecho esto, configuramos y testeamos:

3.1. Debemos crear un archivo "boblight.conf" en el que este la configuración de nuestros leds. Puedes bajarte el mio:

sudo wget https://dl.dropboxusercontent.com/u/649 ... d8806.conf -O /etc/boblight.conf

#config file for LPD8806

[global]
interface 127.0.0.1
port 19333

[device]
name device1
type lpd8806 Deberias modificar esto
output /dev/spidev0.0
channels 6
interval 20000
rate 1000000 Y seguramente esto tambien
debug off #turn this on to see what it's doing with the serial port


3.2. Iniciamos el daemon:
sudo boblightd -f > /dev/nul

3.3. Testeamos los leds poniendoles en verde:
sudo boblight-constant 00FF00

3.4. Si nos da error, reiniciamos:
sudo reboot

3.5. Si seguimos teniendo problema, deberemos revisar la configuracion de "bobligh.conf"

3.6. Configuramos el daemon para que se arranque automaticamente (no lo pongo, esta en las instrucciones).


4. Ahora toca la parte del XBMC.

4.1. Descargamos la build de XBMC creada por nyar.
cd /home/pi
wget https://www.dropbox.com/s/mf3p4ubuujlr8 ... 514.tar.gz

4.1.1. Si no nos deja descargar, la copiamos en la carpeta /home/pi

4.2. Detenemos la actual build de XBMC y creamos una consola para instalar la version de XBMC de nyar con nightly, para que cada vez que actualicemos XBMC no tengamos que volver a instalar esta version:
sudo initctl stop xbmc
mkdir -p .upgrade/xbmc-rbp-pibob-20130514

4.2.1. Descomprimimos la build dentro del archivo creado:
tar -zxf xbmc-rbp-pibob-20130429.tar.gz -C .upgrade/xbmc-rbp-pibob-20130429

4.3. Creamos un fichero de configuración para que se comunique con boblight:
sudo nano /home/pi/boboptions.txt
Al hacer lo anterior de esa manera, esto se seguiria haciendo aqui???

4.4. Copiamos lo siguiente en dicho fichero y guardamos.

enabled=true
host=localhost
port=19333
priority=128
sizedown=112
margin=5
timeout=35
interpolation=0
speed=100
autospeed=0
saturation=1.0
threshold=15

4.5. Por ultimo reiniciamos:
sudo reboot
[/quote]

4.6. Ahora, al iniciarse, debemos ir a la configuracion de Raspbmc, y en la seccion de nightlys cambiamos a la nueva version, y volvemos a reiniciar.[/quote]
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by MrDenisse » Mon Jun 03, 2013 11:30 pm
ttidds wrote:
MrDenisse wrote:Hola chicos, estoy hecho un lio con todas las configuraciones que colgais y no se bien como hacer todo este tinglado.
Ya tengo las tiras de led (4 tiras de 1 m. de los ws2801), me falta comprar la fuente de alimentación, que para los leds que necesito voy a comrpar una de 5V 10A para que no me falte.
La historia está al instalar todo en la raspberry.
Tengo una LG 42LW5500 de 42 pulgadas y habia pensado en dejar justo 104leds (32 arriba, 32 abajo y 20 para cada lado), por lo que he podido leer por aqui hay un tutorial para instalarlo justo para este numero de leds.
Mi intención es conectar solo los leds al raspberry sin usar un arduino. La version que tengo es la de 512mb y creo que aunque sea con un poco de overclock si es necesario, debe funcionar.
¿Alguno puede decirme que tutorial sigo?
¿Que distro os ha dado menos problemas a la hora de montar todo el "chiringuito" este?
¿Alguna recomendación?
1 saludo y gracias de antemano.


Yo también tengo 104 leds, aunque modelo LDP8806. Nose si te refieres al tutorial que hay en este post, o a otro en el post ingles que se referia tambien para una configuracion de 104 leds.

De todas formas, te recomendaria que siguieras el ultimo tutorial que hay aqui. Esta basadao en un tutorial que hizo un compañero recopilando la informacion que se daba en varios hilos ingleses hacerca de este tema, y que encontraras aqui.

http://pibob.nadnerb.co.uk/software.html

Sin embargo, varios posts mas atras, veras que yo mismo estructuro un mini tutorial basandome en el tutorial de este enlace, pero con varias modificaciones sugeridas por el compañero nyar, que mejorarian la respuesta de nuestras RbPi.

Mi opinion es que pruebes los pasos que indico mas atras, y en el punto en el que tienes que crear la configuracion boblight.conf, puedes descargarte mi archivo de configuracion y modificar el tipo y el refresco en base a las caracteristicas de tu tira led. Lo demas estaria configurado para los 104 leds.

ttidds wrote:Recopilando vuestras ultimas correcciones, paso a editar los puntos que no me habían quedado claros para dejarlo todo ya por escrito y aclarado.

1. Primero instalamos la distro Raspbmc
2. Instalamos y compilamos Boblight, los comandos los introducimos en el terminal ya sea mediante ssh o en la propia raspi:

2.1. Actualizamos: sudo initctl stop xbmc
sudo apt-get update

2.2. Instalamos paquetes gcc, g++ y subversion:
sudo apt-get install make gcc g++ subversion

2.3. Descargamos fuente boblgiht:
svn checkout http://boblight.googlecode.com/svn/trunk/ /home/pi/boblight_source

2.4. Configurar y comprobar:
cd /home/pi/boblight_source/
./configure --without-portaudio --without-x11 --without-libusb

2.5. Ejecutar:
make;sudo make install

3. Una vez hecho esto, configuramos y testeamos:

3.1. Debemos crear un archivo "boblight.conf" en el que este la configuración de nuestros leds. Puedes bajarte el mio:

sudo wget https://dl.dropboxusercontent.com/u/649 ... d8806.conf -O /etc/boblight.conf

#config file for LPD8806

[global]
interface 127.0.0.1
port 19333

[device]
name device1
type lpd8806 Deberias modificar esto
output /dev/spidev0.0
channels 6
interval 20000
rate 1000000 Y seguramente esto tambien
debug off #turn this on to see what it's doing with the serial port


3.2. Iniciamos el daemon:
sudo boblightd -f > /dev/nul

3.3. Testeamos los leds poniendoles en verde:
sudo boblight-constant 00FF00

3.4. Si nos da error, reiniciamos:
sudo reboot

3.5. Si seguimos teniendo problema, deberemos revisar la configuracion de "bobligh.conf"

3.6. Configuramos el daemon para que se arranque automaticamente (no lo pongo, esta en las instrucciones).


4. Ahora toca la parte del XBMC.

4.1. Descargamos la build de XBMC creada por nyar.
cd /home/pi
wget https://www.dropbox.com/s/mf3p4ubuujlr8 ... 514.tar.gz

4.1.1. Si no nos deja descargar, la copiamos en la carpeta /home/pi

4.2. Detenemos la actual build de XBMC y creamos una consola para instalar la version de XBMC de nyar con nightly, para que cada vez que actualicemos XBMC no tengamos que volver a instalar esta version:
sudo initctl stop xbmc
mkdir -p .upgrade/xbmc-rbp-pibob-20130514

4.2.1. Descomprimimos la build dentro del archivo creado:
tar -zxf xbmc-rbp-pibob-20130429.tar.gz -C .upgrade/xbmc-rbp-pibob-20130429

4.3. Creamos un fichero de configuración para que se comunique con boblight:
sudo nano /home/pi/boboptions.txt
Al hacer lo anterior de esa manera, esto se seguiria haciendo aqui???

4.4. Copiamos lo siguiente en dicho fichero y guardamos.

enabled=true
host=localhost
port=19333
priority=128
sizedown=112
margin=5
timeout=35
interpolation=0
speed=100
autospeed=0
saturation=1.0
threshold=15

4.5. Por ultimo reiniciamos:
sudo reboot


4.6. Ahora, al iniciarse, debemos ir a la configuracion de Raspbmc, y en la seccion de nightlys cambiamos a la nueva version, y volvemos a reiniciar.[/quote][/quote]

Debo ser muy zoquete porque no paso del punto 3.1
He de decir que soy bastante nuevo en linux, pero practicamente todos tutoriales que he encontrado de esto y otras cosas para el raspberry, es tan sencillo como abrirlo por ssh con putty y copiar/pegar las lineas que poneis los eruditos xD.
Mi problema erradica en que no se como narices debo editarlo. Hago todos los pasos copiando y pegando tal y como los pones pero no soy capaz de que en el test, los leds se me pongan del mismo color.
¿Podrias hecharme una mano con algun tipo de tuto o aclaración aun mas "para tontos"?
De veras que llevo tiempo con esto y leyendo aqui y allá, pero por unas cosas o por otras no consigo dar con el kit de la cuestion.
1 saludo y gracias por todo.

P.D.: si es menos quebradero de cabeza que explicarmelo, agradeceria que alguien que tenga instalado todo y le funcione correctamente, suba una imagen de SD a Mega (por poner un ejemplo) tal y como la tiene y me guie a cambiar lo indispensable para mi configuración.
Posts: 11
Joined: Sun Mar 10, 2013 11:55 pm
by ttidds » Tue Jun 04, 2013 7:06 am
Cuanto te bajas mi fichero de configuracion, debes abrirlo para editarlo con el siguiente comando:

sudo nano /etc/boblight.conf

Modificas los valores que te he indicado en base a los que se corresponden con tu tira de led.

Por lo que entiendo, llegas hasta este punto verdad?

3.3. Testeamos los leds poniendoles en verde:
sudo boblight-constant 00FF0


Cual es el problema? no se te encienden los leds?
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by MrDenisse » Tue Jun 04, 2013 9:53 am
ttidds wrote:Cuanto te bajas mi fichero de configuracion, debes abrirlo para editarlo con el siguiente comando:

sudo nano /etc/boblight.conf

Modificas los valores que te he indicado en base a los que se corresponden con tu tira de led.

Por lo que entiendo, llegas hasta este punto verdad?

3.3. Testeamos los leds poniendoles en verde:
sudo boblight-constant 00FF0


Cual es el problema? no se te encienden los leds?


Pues a ver, edito el boblight.conf y lo pongo tal cual lo tienes tu, pero cambiando la linea type lpd8806 por ws2801 que son los leds que tengo.
guardo el archivo modificado y cuando meto la linea "sudo boblight -f > /dev/nul" me dice permiso denegado.
Despues al meter la linea para testear los leds me sale "ERROR: SO_ERROR 127.0.0.1:19333 Connection refused
Waiting 10 seconds before trying again" y asi todo el rato.
Decir que de momento solo lo estoy probando con una tira led porque mi hermano (que es el que se dedica a soldar xD), no me ha podido hacer nada mas que las soldaduras de la que va conectada al puerto GPIO y no tengo puesto el empalme del cable de alimentacion externo entre la raspberry y la tira de led. De momento alimento la tira con la alimentacion normal de la raspberri mediante el microusb con un cargador de 2A que creo que es mas que suficiente para que se encienda una tira.
De hecho, cuando enciendo la raspberry se ilumina de diferentes colores el promer led de la tira.

Sabiendo todo esto, ¿por donde sigo la instalacion?
Posts: 11
Joined: Sun Mar 10, 2013 11:55 pm
by ttidds » Wed Jun 05, 2013 7:20 am
Si as seguido los pasos, lo primero es configurar bien el archivo boblight.conf. Busca en google un ejemplo para tu tira led. No solo tienes que cambiar lpd8806 por ws2801... sino que tambien tienes que cambiar el refresco (rate) en base a las caracteristicas de tu tira.

Aqui tienes una guia de configuracion de este archivo:

https://code.google.com/p/boblight/wiki/boblightconf


Lo siguiente, es conectar la tira de leds correctamente. Prueba estas cosas primero, y a ver si te sigue dando el mismo problema.

Sino tendras que esperar que se pase alguien mas por aqui, porque yo tambien estoy atascado en el punto de que aunque la parte de software parece que me funciona bien, no consigo que se enciendan los leds.
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by MrDenisse » Wed Jun 05, 2013 10:43 pm
ttidds wrote:Si as seguido los pasos, lo primero es configurar bien el archivo boblight.conf. Busca en google un ejemplo para tu tira led. No solo tienes que cambiar lpd8806 por ws2801... sino que tambien tienes que cambiar el refresco (rate) en base a las caracteristicas de tu tira.

Aqui tienes una guia de configuracion de este archivo:

https://code.google.com/p/boblight/wiki/boblightconf


Lo siguiente, es conectar la tira de leds correctamente. Prueba estas cosas primero, y a ver si te sigue dando el mismo problema.

Sino tendras que esperar que se pase alguien mas por aqui, porque yo tambien estoy atascado en el punto de que aunque la parte de software parece que me funciona bien, no consigo que se enciendan los leds.


He probado a cambiar el rate a 33600 con otro boblight.conf que encontre por google para mi tira led, pero era para 150 canales, no para 312. ¿Hay que hacer algun tipo de calculo para adaptar el rate a los canales?
De todas formas, aun modificando el rate no soy capaz de hacer que se ilumine la tira. me dice siempre permiso denegado...
¿Que mas puedo intentar?
1 saludo y gracias de nuevo por todo.

EDITO: con un poquito de ayuda del tutorial de Pibob (http://pibob.nadnerb.co.uk/software.html), he hecho lucir los leds con el color que le ponga.
Despues he seguido tu tutorial para instalar lo necesario del xbmc pero me da error siempre en el paso 4.1 porque no se com dices que se copia en el 4.1.1, pero siguiendo el de pibob si me ha dejado seguir. me imagino que la finalidad e instalacion es la misma que pones tu aqui...
Total, que he llegado hasta el final del tuto de Pibob y parece ser que ya se comunica el boblight con el xbmc porque cuando inicio una peli me lucen los leds por un par de segundos, pero no consigo que reproduzcan los colores dentro de la pelicula, supongo que habrá que irse despues al addon dentro del xbmc a modificar los valores de treshold y demas ¿verdad? ¿que valores le pongo para que empiece la fiesta de colorines led xD?.
Posts: 11
Joined: Sun Mar 10, 2013 11:55 pm
by ttidds » Thu Jun 06, 2013 7:29 am
Como te comente, yo aun no consigo que se me enciendan los leds, tengo que verificar que la tira de leds esta bien y que tampoco es problema del puerto GPIO.

No sabria decirte lo del XBMC porque aun no he llegado. El tutorial lo complete con lo pasos que indica nadnerb en su tuto mas las recomendaciones de nyar.

Lo del punto 4.1, se trata de descargarte su version de XBMC en vez de la que propone nadnerb, por lo que se realizara de la misma forma pero copiando el otro enlace. Lo de copiarlo manualmente si no te funciona la descarga, sinceramente ni lo he probado ni se como se haria.

Comentame un poco que es lo que te fallaba y como lo has solucionado.
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by MrDenisse » Thu Jun 06, 2013 9:46 am
ttidds wrote:Como te comente, yo aun no consigo que se me enciendan los leds, tengo que verificar que la tira de leds esta bien y que tampoco es problema del puerto GPIO.

No sabria decirte lo del XBMC porque aun no he llegado. El tutorial lo complete con lo pasos que indica nadnerb en su tuto mas las recomendaciones de nyar.

Lo del punto 4.1, se trata de descargarte su version de XBMC en vez de la que propone nadnerb, por lo que se realizara de la misma forma pero copiando el otro enlace. Lo de copiarlo manualmente si no te funciona la descarga, sinceramente ni lo he probado ni se como se haria.

Comentame un poco que es lo que te fallaba y como lo has solucionado.

Pues hice todo el tutorial tuyo hasta el punto de encender los leds y luego hice el de pibob de nadnerb (http://pibob.nadnerb.co.uk/software.html) entero y en el punto 3.1.A modifique el boblight.conf para mis 104 les y al llegar al test de color de los les funcionó, por lo que si no se iluminan cuando llegas el fallo está en el boblight.conf.
Ahora me toca pelearme con la configuración del xbmc para que salten los colorines en las pelis...
Posts: 11
Joined: Sun Mar 10, 2013 11:55 pm
by ttidds » Mon Jun 10, 2013 7:08 am
Bueno, tras comprobar con el polimetro que el problema era un contacto en la alimentación de la tira led, he conseguido que funcione.

He instalado la version nightly de nyar de XBMC y todo me ha ido correctamente.

Sin embargo, tengo un pequeño problema de lag. Al reproducir algún video los leds van con retraso respecto a la imagen, y van como a golpes, no realizan la transicion de manera fluida.

Donde se pueden ajustar estos parámetros?

Adjunto un par de fotos de como me ha quedado. Otra cosa que me mosquea es que hay un led que mientras los demas estan blancos, este esta en morado, cual puede ser la razon?
Attachments
2.png
Detalle led
2.png (40.73 KiB) Viewed 602 times
1.png
Instalacion
1.png (44.14 KiB) Viewed 602 times
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by davisdmg » Mon Jun 10, 2013 3:39 pm
lo del led raro tiene pinta de esta jodido :(

para que las transiciones no sean tan bestias, baja la velocidad, yo uso esto:

enabled=true
host=localhost
port=19333
priority=128
sizedown=112
margin=5
timeout=35
interpolation=0
speed=75
autospeed=0
saturation=1.5
threshold=30
Posts: 23
Joined: Wed May 01, 2013 11:53 am
by nyar » Mon Jun 10, 2013 6:59 pm
Me alegro que encontraras el problema.

El iluminarse a golpes puede ser cosas del rate. Subelo y pruebas a ver si soluciona algo.

Saludos
Posts: 61
Joined: Mon May 14, 2012 10:50 pm
by davisdmg » Tue Jun 11, 2013 10:34 am
por cierto nyar, cual es tu ultimo xbmc parcheado disponible?
Posts: 23
Joined: Wed May 01, 2013 11:53 am
by nyar » Tue Jun 11, 2013 8:15 pm
davisdmg wrote:por cierto nyar, cual es tu ultimo xbmc parcheado disponible?

El de mayo. Pero de todas formas va a quedar obsoleta en poco tiempo. Sam esta preparando la actualización de junio que llevará por el parche ya incluido y no habrá que usar builds personalizadas.
Posts: 61
Joined: Mon May 14, 2012 10:50 pm
by ttidds » Wed Jun 12, 2013 6:35 am
nyar wrote:Me alegro que encontraras el problema.

El iluminarse a golpes puede ser cosas del rate. Subelo y pruebas a ver si soluciona algo.

Saludos


Subido el rate a 2000000 y sigue igual. El caso es que tiene un pequeño lag respecto a la imagen. En imagenes lentas no hay problema, pero en escenas de accion donde igual hay una explosion si que se nota mucho el retardo. Aparte de eso, las transiciones no son suaves, sino que van a golpes.

nyar wrote:lo del led raro tiene pinta de esta jodido

para que las transiciones no sean tan bestias, baja la velocidad, yo uso esto:

enabled=true
host=localhost
port=19333
priority=128
sizedown=112
margin=5
timeout=35
interpolation=0
speed=75
autospeed=0
saturation=1.5
threshold=30


Tambien he modificado estos parametros, pero nada.

Que otra posibilidad hay para que se produzca este retraso? Porque nose la tira ldp8806 en que badurate maximo puede operar. En los valores superiores, supongo que bajando el speed ira mas fluido pero conllevara mayor retraso tambien. Podria solucionarse haciendole overclock a la rasp??


PD: Buscando un poco he encontrado varias posibles soluciones, aunque antes las expongo ya que algunas es posible que no sirvan de mucho:

1- modificar los valores de la siguiente manera:

enabled=true
host=localhost
port=19333
priority=128
interpolation=1
speed=50
autospeed=25
saturation=1.1
threshold=20
value=1.5

2. Modificar el .bat para arrancar el programa donde se especificaba la velocidad del puerto , pasarlo de 9600 a 115200. (A que archivo se refiere y como se haria?)

3. Es posible que sea por la version de boblight o algo del estilo? He visto que hay una version de speedy que dicen que va bastante bien y que no produce lags.
https://github.com/Speedy1985/boblightd ... to-compile


nyar wrote:El de mayo. Pero de todas formas va a quedar obsoleta en poco tiempo. Sam esta preparando la actualización de junio que llevará por el parche ya incluido y no habrá que usar builds personalizadas.


En cuanto este comentalo por favor.
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by davisdmg » Wed Jun 12, 2013 8:34 am
yo uso la version de speedy y va realmente bien.
Posts: 23
Joined: Wed May 01, 2013 11:53 am
by ttidds » Wed Jun 12, 2013 11:10 am
Os pongo el link al video para que veais lo que comento.

Seguramente que probare con la version de speedy a ver si mejora.


http://www.youtube.com/watch?v=KW6SfxnT ... e=youtu.be
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by ttidds » Thu Jun 13, 2013 9:41 am
Ayer instale el boblight the speedy. La instalacion fue bien, pero no pude realizaar el ultimo paso:

Part 1. shutdown XBMC for faster compiling and update the feeds:

sudo initctl stop xbmc
sudo apt-get update

Part 2. install necessary dependencies:

sudo apt-get install make gcc g++ git libboost-dev libtool

Part 3. Clone the optimized source:

cd ~
git clone git://github.com/Speedy1985/boblightd-for-raspberry.git

Part 4. Compile:

cd boblightd-for-raspberry/
./configure
make;sudo make install
Now take a kop of coffee and wait till the compiling is finisched.


Part 5. Move the files to /usr/lib:

mv /usr/local/lib/libboblight.* /usr/lib/


Al hacer esto, me decia que no era posible o algo asi. Despues pase a realizar las pruebas de los leds. Tuve que modificar el boblight.conf ya que para este boblight el nombre de los leds debe ser especifico:

READ THIS: This version needs another lightnames in boblight.conf, only 3 chars not more and not lower

[light] name 1 << This is wrong, it must be XX1 or 001 or 1XX
color red ambilight 1
color green ambilight 2
color blue ambilight 3
hscan 30 35
vscan 90 100


Despues, a la hora de probar, no me concuerdan los colores rojo, verde y azul, pero la vez anterior tampoco lo hacian y lo consegui intercambiando los valores hexadecimales en el boblight.conf.

La parte que he indicado al principio, es significativa para que funcione correctamente? porque como comento, segui los pasos y ese ultimo paso no me lo realziaba bien.
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm
by davisdmg » Fri Jun 14, 2013 2:56 pm
sudo ldconfig


eso funciona
Posts: 23
Joined: Wed May 01, 2013 11:53 am
by nyar » Mon Jun 17, 2013 6:28 pm
La versión oficial de raspbmc ya soporta boblight sin necesidad de instalar boblight ni de construir una build personalizada.

Saludos
Posts: 61
Joined: Mon May 14, 2012 10:50 pm
by ttidds » Tue Jun 18, 2013 7:09 am
osea que, simplemente con actualizar a la nueva version de Raspbmc, sin hacer nada mas, funcionaria?

Supongo que aun asi necesitaremos algun tipo de configuracion para los leds.

Si lo instalas comentanos que tal va. Yo acabo de conseguir ponerlo y esperare un poco antes de volver a meterme al trapo.
Posts: 40
Joined: Mon Apr 08, 2013 1:23 pm