[TUTO] Configurar el Pi para Transmission


188 posts   Page 5 of 8   1, 2, 3, 4, 5, 6, 7, 8
by Endoval » Sun Oct 07, 2012 3:02 pm
Buenas. Tengo un problema con la parte de la red local. Yo seguí los pasos religiosamente pero cuando llego al final me aparece esto:
"403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details."

La líneas en cuestión están tal que así:

"rpc-whitelist": "127.0.0.1,127.168.x.x",
"rpc-whitelist-enabled": true,

En algo me he confundido y no tengo claro el que.

Un saludo.
Posts: 4
Joined: Sun Oct 07, 2012 2:56 pm
by Locorroco » Sun Oct 07, 2012 9:07 pm
zmxn wrote:Buenas,

para el password para la interficie web, se debe escribir cifrada o puedo escribirla directamente? en el documento de configuración.

En caso que sea necesario, que tipo de cifrado es?

Para el usuario si que es directo ¿no?


Con eso tuve yo un cacao de cuidado. Yo ponía una contraseña normal y al rato cuando volvía a verla para ver si había puesto todo bien, me salían números y letras que yo no había escrito, así que la volvía a cambiar. Así unas pocas veces, hasta que me dí cuenta que lo que pasaba era que el transmission me cifraba la clave :oops:

Así que si puedes poner la clave sin cifrar, ya que el transmission te la cifra.

El usuario es directo.
Posts: 7
Joined: Sat Sep 15, 2012 12:16 am
by Locorroco » Mon Oct 08, 2012 11:14 am
Endoval wrote:Buenas. Tengo un problema con la parte de la red local. Yo seguí los pasos religiosamente pero cuando llego al final me aparece esto:
"403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details."

La líneas en cuestión están tal que así:

"rpc-whitelist": "127.0.0.1,127.168.x.x",
"rpc-whitelist-enabled": true,

En algo me he confundido y no tengo claro el que.

Un saludo.



Tienes que poner rpc-whitelist": "127.0.0.1,192.168.x.x"

Ese es tu fallo.
Posts: 7
Joined: Sat Sep 15, 2012 12:16 am
by Virutas » Mon Oct 08, 2012 11:30 am
Ufff, no se que le pasa a mi PI ultimamente pero es ponerle un par de torrents con buenas fuentes y descargar al tope de la línea y el transmission se casca, tengo que conectarme por SSH y reiniciar el servicio, aunque al ratito vuelve a fallar.

¿Alguien sabe por qué es? Tengo puesto de límite 30 peers por torrent y máximo 100 peers en total. ¿Tengo que modificar el vm.min_free_kbytes y el smsc95xx.turbo_mode=N? ¿Este último para qué sirve?

Un saludo
Posts: 25
Joined: Wed Sep 12, 2012 6:51 am
by Endoval » Mon Oct 08, 2012 1:35 pm
Locorroco wrote:
Endoval wrote:Buenas. Tengo un problema con la parte de la red local. Yo seguí los pasos religiosamente pero cuando llego al final me aparece esto:
"403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details."

La líneas en cuestión están tal que así:

"rpc-whitelist": "127.0.0.1,127.168.x.x",
"rpc-whitelist-enabled": true,

En algo me he confundido y no tengo claro el que.

Un saludo.



Tienes que poner rpc-whitelist": "127.0.0.1,192.168.x.x"

Ese es tu fallo.


Corregí el fallo :oops: Pero me sigue saliendo exactamente la misma pantalla.
Posts: 4
Joined: Sun Oct 07, 2012 2:56 pm
by Serval » Mon Oct 08, 2012 2:45 pm
prueba con "127.0.0.1,192.168.*.*"

o incluso: "*.*.*.*"
Posts: 5
Joined: Mon Jul 09, 2012 6:40 am
by Locorroco » Mon Oct 08, 2012 5:18 pm
Endoval wrote:
Locorroco wrote:
Endoval wrote:Buenas. Tengo un problema con la parte de la red local. Yo seguí los pasos religiosamente pero cuando llego al final me aparece esto:
"403: Forbidden

Unauthorized IP Address.

Either disable the IP address whitelist or add your address to it.

If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.

If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details."

La líneas en cuestión están tal que así:

"rpc-whitelist": "127.0.0.1,127.168.x.x",
"rpc-whitelist-enabled": true,

En algo me he confundido y no tengo claro el que.

Un saludo.



Tienes que poner rpc-whitelist": "127.0.0.1,192.168.x.x"

Ese es tu fallo.


Corregí el fallo :oops: Pero me sigue saliendo exactamente la misma pantalla.


¿Estas poniendo 192.168.x.x?¿O pone exactamente la ip de la raspberry?

Debes poner algo así: 192.168.1.40, en la mayoría de los casos solo varía el último valor, pero en algunos routers se cambia el segundo valor también. Mira cual es la ip de tu raspberry y ponla ahí.
Posts: 7
Joined: Sat Sep 15, 2012 12:16 am
by Endoval » Mon Oct 08, 2012 8:59 pm
Locorroco wrote:
¿Estas poniendo 192.168.x.x?¿O pone exactamente la ip de la raspberry?

Debes poner algo así: 192.168.1.40, en la mayoría de los casos solo varía el último valor, pero en algunos routers se cambia el segundo valor también. Mira cual es la ip de tu raspberry y ponla ahí.


No, hombre, tengo los dos valores puestos como dios manda. Se me ocurrió que puede ser algo de la configuración del ordenador desde donde quiero entrar. Está conectado al router pero no se si hace falta algo más.
Posts: 4
Joined: Sun Oct 07, 2012 2:56 pm
by doodom » Thu Oct 25, 2012 11:25 am
Ya que en este hilo se ha hablado de clientes torrent, una pregunta estúpida. ¿Hay alguna manera de conseguir deluge 1.3.4 o superior para Raspbian que no sea compilando desde las fuentes? Porque en teoría la versión 1.3.3 que está en los repositorios no soporta enlaces magnéticos, y a parte me ha dado muchos problemas para coger ficheros .torrent.

Un saludo y gracias.
Posts: 8
Joined: Tue Oct 23, 2012 9:25 pm
by rafaestevez » Thu Oct 25, 2012 2:52 pm
A mi me funcinan los enlaces magnéticos en el transmission. ¿a que te refieres exáctamente?
User avatar
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am
by zmxn » Fri Oct 26, 2012 3:13 pm
Entiendo que tiene problemas con el deluge, no con el transmission
Posts: 5
Joined: Fri Oct 05, 2012 11:15 am
by rafaestevez » Sat Oct 27, 2012 8:29 am
Vale, entendí que quería instalar el deluge porque el transmission no tenía enlaces magnéticos.
User avatar
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am
by nitrosito » Mon Oct 29, 2012 5:36 pm
Hola!
Nadie guarda las descargas incompletas en el raspberry?
Lo digo porque, estar escribiendo toooodo el rato, los bytes que se baja de los archivos que estan descargando, van todos al pendrive/HDD , y estar hay: bajo, guardo datos, bajo, guardo datos.
Nose, quizás, tanta escritura en el pendrive no sea buena xDD , 4 o 5 horas escribiendo pequeños datos jajaja.
Alguien ha guardado incompletas en /incopmletas por ejemplo?
Yo es que no se porque la /home tiene tan poco espacio, si lo pongo hay se me llena en nada
Si creamos una carpeta en "/" y le damos permisos 777 , tendremos más imagino,no?
alguien ha provado?
Un saludo
Posts: 8
Joined: Sun Oct 28, 2012 9:08 pm
by LucasBols » Tue Nov 06, 2012 12:04 am
Hola,

La instalación del transmission fué casi todo un éxito, tuve algunos problemitas con los permisos de acceso, como no tuve ganas de ver con qué usuario levanta transmission, decidí poner chmod ugo=rwx para todo el árbol de /media, por que sin esos permisos, cuando empezaba a descargar un torrent se quejaba y lo paraba

Otro tema fué la redirección (nat) del puerto del router, tuve que habilitar el 51413

transmission se está comiendo el 50% de la cpu con 6 torrents

Ahora estoy usando transmission desde W7 con transmission-remote-gui http://code.google.com/p/transmisson-remote-gui/ es una interfase gtk muy práctica, incluso se "esconde" en la bandeja de sistema

El próximo paso es smb para poder acceder desde win, y después veré si existe un port de minidlna o de tvmobili que son los que tengo en el serv linux

Saludos
Posts: 1
Joined: Mon Nov 05, 2012 7:20 pm
by rafaestevez » Fri Nov 09, 2012 9:28 pm
Últimamente se me cierra transmissión y me aparece esta traza:

Code: Select all
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377688] [ 1978]   109  1978      843        0   0       0             0 avahi-daemon
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377710] [ 1979]   109  1979      843        0   0       0             0 avahi-daemon
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377733] [ 2089]     0  2089     2034        0   0       0             0 cupsd
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377754] [ 2103]   110  2103     5990        0   0       0             0 colord
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377776] [ 2113]   110  2113    10735        0   0       0             0 colord-sane
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377798] [ 2329]   102  2329     1385        4   0       0             0 ntpd
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377820] [ 2388]   106  2388    12639        5   0       0             0 transmission-da
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377842] [ 2394]     0  2394     1773        0   0     -17         -1000 sshd
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377864] [ 2564] 65534  2564      501        0   0       0             0 thd
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377885] [ 2578]     0  2578     1050        0   0       0             0 vsftpd
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377908] [ 2594]     0  2594      418        0   0       0             0 minissdpd
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377929] [ 2607]     0  2607      993        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377950] [ 2608]     0  2608      993        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377973] [ 2609]     0  2609      993        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.377994] [ 2610]     0  2610      993        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378016] [ 2611]     0  2611      993        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378038] [ 2612]     0  2612      993        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378059] [ 2613]     0  2613      513        0   0       0             0 getty
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378081] [11212]     0 11212      436        1   0     -17         -1000 ifplugd.agent
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378105] [11213]     0 11213      436        1   0     -17         -1000 ifplugd.agent
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378127] [11214]     0 11214      424        8   0     -17         -1000 cat
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378148] [11215]     0 11215      436        0   0     -17         -1000 net.agent
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378171] [11216]     0 11216      424        7   0     -17         -1000 cat
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378192] [11217]     0 11217      391        7   0     -17         -1000 cat
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378213] [11218]     0 11218     1006        4   0       0             0 cron
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378232] Out of memory: Kill process 2388 (transmission-da) score 61 or sacrifice child
Nov  9 22:17:03 raspberrypi kernel: [ 1101.378252] Killed process 2388 (transmission-da) total-vm:50556kB, anon-rss:0kB, file-rss:20kB
User avatar
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am
by MayCry » Sun Nov 11, 2012 7:19 pm
Gracias al tutorial por fin tengo el Transmission funcionando, pero me ha instalado la versión 2.52, ¿alguien sabe como puedo actualizarlo a la versión 2.71?
Posts: 3
Joined: Sun Nov 11, 2012 7:17 pm
by selie » Tue Dec 04, 2012 7:07 pm
Buenas!! Yo tengo la siguiente pregunta. Mi idea es llevarme el hd a casa de mi novia y así por lo que en el daemon-transmission he editado para que me montar automáticamente el disco duro cuando lance el demonio y que lo desmonte al parar, todo esto por comodidad.
La cosa es que si no tengo un disco duro insertado y lanzo el script falla y ya no arranca el proceso, por lo que mi idea es crear un if si hay algo conectado en /dev/sda1 por ejemplo que lo monte y else que lance el start sin mas.

Alguna idea please?

Gracias!!
Posts: 2
Joined: Tue Dec 04, 2012 7:02 pm
by juanmagmz » Sun Dec 23, 2012 12:05 pm
Buenas,

No sé si solo me pasa a mi, pero por mas que he abierto el puerto que pide transmission y todo, no consigo que SUBA archivos.

La descarga de momento va sin problemas, pero no consigo que suba nada.

Si alguien puede ayudarme se lo agradeceria jeje

Saludos!
Posts: 1
Joined: Sun Dec 23, 2012 12:03 pm
by Artro » Tue Dec 25, 2012 7:08 pm
Buenas tardes, soy un perfecto novato en el uso de linux y de momento hago correr el transmission.
El problema que se me presenta es que en el acceso al transmission en varias descargas me arroja el siguiente error :
- error: numerical result of range (aqui ruta de la descarga)
Gracias por el post me ha sido de mucha ayuda y gracias de antemano por las posibles soluciones.
Posts: 1
Joined: Tue Dec 25, 2012 6:48 pm
by raspberrypivictim » Mon Jan 07, 2013 1:15 pm
Hola a todos,

Tengo un problemilla a la hora de descargar torrents que tienen algún fichero que contiene la letra Ñ.

Al poco rato de ponerlo a descargar me salta el siguiente error

Error: Invalid argument (/home/pi/usb/descargas/ficheroconÑ

En el fichero de descargas no hace nada, yo sospecho que no es capaz de crear el fichero en el filesystem por la Ñ.

Ocurre lo mismo utilizando rtorrent

Puede ser algo del encoding? He intentado buscar algo pero no encuentro nada.

Googleando la gente comenta que si se pudiera implementar la opción de cambiar el nombre del fichero a descargar desde el propio fichero .torrent, pero no esposible porque entonces cambiaría el .torrent.

¿Alguno se ha visto en esta tesitura y puede arrojar algo de luz?

Muchas gracias y un saludo a todos
Posts: 26
Joined: Sun Jan 22, 2012 10:35 pm
by micerinos » Wed Jan 09, 2013 1:24 am
raspberrypivictim wrote:Hola a todos,

Tengo un problemilla a la hora de descargar torrents que tienen algún fichero que contiene la letra Ñ.

Al poco rato de ponerlo a descargar me salta el siguiente error

Error: Invalid argument (/home/pi/usb/descargas/ficheroconÑ

En el fichero de descargas no hace nada, yo sospecho que no es capaz de crear el fichero en el filesystem por la Ñ.

Ocurre lo mismo utilizando rtorrent

Puede ser algo del encoding? He intentado buscar algo pero no encuentro nada.

Googleando la gente comenta que si se pudiera implementar la opción de cambiar el nombre del fichero a descargar desde el propio fichero .torrent, pero no esposible porque entonces cambiaría el .torrent.

¿Alguno se ha visto en esta tesitura y puede arrojar algo de luz?

Muchas gracias y un saludo a todos


Cual es el formato de la partición que usas? Pon el resultado de los siguientes comandos:
mount
cat /etc/fstab

Si es algo más general que un gazapo de tu configuración, este tipo de cuestiones se merece un post separado.

Un saludo
Posts: 74
Joined: Fri Nov 09, 2012 11:15 am
Location: Madrid, Spain
by loboo » Sun Jan 20, 2013 2:46 am
Tengo un problema con transmission en raspbian, Cuando arranco el transmission la velocidad para navegar en cualquier ordenador de mi casa va como el culo, da igual que limite la velocidad de descarga y de subida a 1 kb/s que no le ponga limite, en cuanto lo enciendo algunas paginas no se abren o tardan muchisimo.

lo tengo conectado por cable al router, le tengo puesto en conexiones:

Max peers per torrent 60
max peer overall 240

La velocidad da igual lo que ponga a 1 kb/s o sin limite.

otra cosa, normalmente me descarga a el tope de linea 650 kb/s ahora no pasa de 300 kb/s y no tengo limitada la velocidad de descarga.
Posts: 2
Joined: Sun Jan 20, 2013 2:40 am
by nyar » Sun Jan 20, 2013 7:49 pm
loboo wrote:Tengo un problema con transmission en raspbian, Cuando arranco el transmission la velocidad para navegar en cualquier ordenador de mi casa va como el culo, da igual que limite la velocidad de descarga y de subida a 1 kb/s que no le ponga limite, en cuanto lo enciendo algunas paginas no se abren o tardan muchisimo.

lo tengo conectado por cable al router, le tengo puesto en conexiones:

Max peers per torrent 60
max peer overall 240

La velocidad da igual lo que ponga a 1 kb/s o sin limite.

otra cosa, normalmente me descarga a el tope de linea 650 kb/s ahora no pasa de 300 kb/s y no tengo limitada la velocidad de descarga.


¿Has probado hacer un reinicio al router?

Parece como si se saturará, prueba utilizar transmission en tu ordenador para descartar problemas causados por el pi.
Posts: 61
Joined: Mon May 14, 2012 10:50 pm
by raspberrypivictim » Mon Jan 21, 2013 7:39 am
micerinos wrote:
raspberrypivictim wrote:Hola a todos,

Tengo un problemilla a la hora de descargar torrents que tienen algún fichero que contiene la letra Ñ.

Al poco rato de ponerlo a descargar me salta el siguiente error

Error: Invalid argument (/home/pi/usb/descargas/ficheroconÑ

En el fichero de descargas no hace nada, yo sospecho que no es capaz de crear el fichero en el filesystem por la Ñ.

Ocurre lo mismo utilizando rtorrent

Puede ser algo del encoding? He intentado buscar algo pero no encuentro nada.

Googleando la gente comenta que si se pudiera implementar la opción de cambiar el nombre del fichero a descargar desde el propio fichero .torrent, pero no esposible porque entonces cambiaría el .torrent.

¿Alguno se ha visto en esta tesitura y puede arrojar algo de luz?

Muchas gracias y un saludo a todos


Cual es el formato de la partición que usas? Pon el resultado de los siguientes comandos:
mount
cat /etc/fstab

Si es algo más general que un gazapo de tu configuración, este tipo de cuestiones se merece un post separado.

Un saludo



La partición del pincho está en fat32. Tras mucho dar vueltas y no conseguir nada, he formateado a ext4 y el problema ha desaparecido. Voy a dejar el misterio sin resolver ... de momento.

Muchas gracias
Posts: 26
Joined: Sun Jan 22, 2012 10:35 pm
by loboo » Mon Jan 21, 2013 3:01 pm
nyar wrote:
loboo wrote:Tengo un problema con transmission en raspbian, Cuando arranco el transmission la velocidad para navegar en cualquier ordenador de mi casa va como el culo, da igual que limite la velocidad de descarga y de subida a 1 kb/s que no le ponga limite, en cuanto lo enciendo algunas paginas no se abren o tardan muchisimo.

lo tengo conectado por cable al router, le tengo puesto en conexiones:

Max peers per torrent 60
max peer overall 240

La velocidad da igual lo que ponga a 1 kb/s o sin limite.

otra cosa, normalmente me descarga a el tope de linea 650 kb/s ahora no pasa de 300 kb/s y no tengo limitada la velocidad de descarga.


¿Has probado hacer un reinicio al router?

Parece como si se saturará, prueba utilizar transmission en tu ordenador para descartar problemas causados por el pi.


Si, reinicie el router unas cuantas veces para descartar ese problema.

Cambie los parametros del transmission.

Max peers per torrent a 40 y max peers overall a 180 y me funciona perfectamente.

Como teneis puesto vosotros esos parametros.

Un saludo y gracias por responder
Posts: 2
Joined: Sun Jan 20, 2013 2:40 am