Cannot check root file system ... not mounted read


6 posts
by Luke Wilkinson » Tue Jun 26, 2012 8:54 pm
I installed raspbian using the installer method and manually partitioned so I could have / on an external usb hard drive (SOOO much faster..!)

everything is working perfectly, although I'm getting these two annoying messages during boot

Tue Jun 26 21:17:07 2012: mount: you must specify the filesystem type
Tue Jun 26 21:17:07 2012: [....] Cannot check root file system because it is not mounted read-only. [FAIL] failed!

I'm not sure of the origin of the first one, but the second one is the real concern.

This concerns me because I would prefer that the filesystem receive it's periodic checkup during boot, and this implies that this wont be happening.

I've tried modifying the cmdline.txt to specify the root filesystem be read only without success.

I've verified that the fstab is correct, although It seems the problem cant be to do with this anyway, as the messages relating to mounting from fstab come later in the boot. for completeness, here it is:
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda3 during installation
UUID=3a8a8526-2352-4759-b308-7670aa4e0897 / ext4 noatime,errors=remount-ro 0 1
# /boot/ was on /dev/mmcblk0p1 during installation
/dev/mmcblk0p1 /boot/ vfat utf8 0 0
# swap was on /dev/sda2 during installation
UUID=cc391e4d-2bb0-4118-9bc3-bc55d5e1f319 none swap sw 0 0

I'm sure I'll figure this out eventually, but I'm hoping someone else has already seen and fixed this one?

Is anyone else using an external hard drive for / and NOT getting this? If so I'd like to know what ive done differently.

cheers for any help.
Posts: 4
Joined: Mon Jun 25, 2012 10:23 am
by mpthompson » Wed Jun 27, 2012 1:26 am
Luke Wilkinson wrote:everything is working perfectly, although I'm getting these two annoying messages during boot

Tue Jun 26 21:17:07 2012: mount: you must specify the filesystem type
Tue Jun 26 21:17:07 2012: [....] Cannot check root file system because it is not mounted read-only. [FAIL] failed!


In the cmdline.txt file you may try adding "rootfstype=ext3" or "rootfstype=ext4" (whichever matches the root partition type) to see if that fixes the first message and perhaps the second. The linux parameters are documented here:

http://oreilly.com/linux/excerpts/97805 ... rence.html

Also, if you have an ext4 partition, make sure that ext4 is supported in the kernel you are using. I think that a kernel may use an ext4 filesystem as an ext3 filesystem if ext4 support isn't provided, which may lead to some funkiness such as the messages you are seeing.
User avatar
Forum Moderator
Forum Moderator
Posts: 620
Joined: Fri Feb 03, 2012 7:18 pm
Location: San Carlos, CA
by dangardner » Sat Sep 22, 2012 2:10 pm
In case anybody else comes across this thread as a result of searching for the title, adding an "ro" parameter to /boot/cmdline.txt fixed it for me and allowed my system to fsck correctly.
Posts: 3
Joined: Sat Sep 15, 2012 8:54 pm
by szopler » Sat Aug 10, 2013 10:04 pm
"ro"...
But why the hell parameters are called 'elevator'?!
Posts: 2
Joined: Sat Jul 27, 2013 9:12 pm
by peewee2 » Sun Aug 11, 2013 8:00 pm
why would a machine be faster booting from an external USB hard drive ?

That makes no sense to me, I would be very surprised if a pi could boot in less than 1 min booting from a USB disk.

Pete
Posts: 53
Joined: Sun Apr 14, 2013 7:04 pm
by rpdom » Mon Aug 12, 2013 6:16 am
peewee2 wrote:why would a machine be faster booting from an external USB hard drive ?

That makes no sense to me, I would be very surprised if a pi could boot in less than 1 min booting from a USB disk.

Pete


Because the USB interface is faster than the SD card interface?

As for how long it takes to boot, is that to full desktop or cli/text mode? I get 42 seconds to text mode login without overclock, on an old, slow disk.
Posts: 3540
Joined: Sun May 06, 2012 5:17 am
Location: Essex, UK