Login as root via ssh, telnet and ftp


7 posts
by Nyromith » Sat Jun 01, 2013 3:14 pm
I know, three awful ideas in one title. But I use my pi as a web server for practicing, and security is not a concern.

I configured all three to allow root login, but it only works on ttys. When I'm trying to login from my Debian XFCE terminal or from a Mac the login fails at the password stage. Is there something I should enable to allow a root login from any device?

Thanks.
Posts: 3
Joined: Sat Jun 01, 2013 3:06 pm
by dehein » Sat Jun 01, 2013 3:58 pm
You need to give the root account a password? Have you done it?
Code: Select all
sudo passwd root

You should also check your ssh config
Code: Select all
sudo nano /etc/ssh/sshd_config

Search for PermitRootLogin and change it to yes.
Posts: 20
Joined: Fri Mar 01, 2013 9:46 pm
by rpdom » Sat Jun 01, 2013 4:12 pm
dehein wrote:You need to give the root account a password? Have you done it?
Code: Select all
sudo passwd root


This should be sufficient.

You should also check your ssh config
Code: Select all
sudo nano /etc/ssh/sshd_config

Search for PermitRootLogin and change it to yes.


That should already be set, I believe. Certainly I've not needed to change it on the Pi I allow remote root ssh login on.
User avatar
Posts: 3708
Joined: Sun May 06, 2012 5:17 am
Location: Essex, UK
by Nyromith » Sat Jun 01, 2013 4:39 pm
Those things are already configured. The weird thing is that all the services fail after the password prompt, so I suspect the problem is not related to each service individually.
Posts: 3
Joined: Sat Jun 01, 2013 3:06 pm
by pjc123 » Sun Jun 02, 2013 11:55 am
I can only speak for SSH and sftp, as I don't use the non-secure methods. Other then setting up the root password, as previously mentioned, and setting up the SSH server with raspi-config or manually, it just works for me. The only issue I have had in the past with SSH was that the question that comes up regarding the acceptance of the SSH keys was not displayed, therefore the connection failed. Since all three methods don't work in your case, have you changed anything in the firewall or accept/deny files on the pi, or your router permissions, although I am not sure at what point the connection is prevented (Before the login/password or after).
Posts: 910
Joined: Thu Mar 29, 2012 3:37 pm
by Nyromith » Mon Jun 03, 2013 7:05 pm
The problem was that my password consisted of numbers only. Changed it to letters and it was solved.
Maybe it's some kind of a system-wide security policy.
Posts: 3
Joined: Sat Jun 01, 2013 3:06 pm
by ayezee33 » Thu May 01, 2014 10:17 pm
I was going to suggest this. I had my ssh password contain numbers and the same thing happened to me.
Posts: 13
Joined: Tue Feb 25, 2014 12:15 am