IPv6 on Raspbian


21 posts
by Sander » Tue Aug 28, 2012 4:09 pm
I just discovered Raspbian (August image) has no IPv6 enabled by default. Can someone explain why?

To solve this, I used "sudo nano /etc/modules", added "ipv6" at the end, and rebooted.

However, I would prefer to have IPv6 enabled by default.
User avatar
Posts: 174
Joined: Wed Aug 31, 2011 1:01 pm
by paaland » Tue Aug 28, 2012 4:25 pm
Whats the problem? You found out how to enable it. Fact is most people have no need for ip6, very few home routers support this. So I see no reason to enable anything by default that most people have no need for.
Dragon 32>BBC Model B>PC>PC>PC>PC>Raspberry PI (circle complete)
User avatar
Posts: 68
Joined: Mon Mar 12, 2012 2:30 pm
Location: Norway
by Sander » Tue Aug 28, 2012 5:39 pm
paaland wrote:Whats the problem? You found out how to enable it. Fact is most people have no need for ip6, very few home routers support this. So I see no reason to enable anything by default that most people have no need for.



Ouch ... the old IPv6 argument of the past. I would rather not dive into that, but let's give a 2012 update:

1) all other OSes (Ubuntu, Debian, Fedora, OSX, Windows Vista/7) have IPv6 enabled in their plain, basic installation
2) My ISP provides native IPv6
3) My VPS-provider provides IPv6
4) Installing miredo will give you IPv6 connectivity
5) google.com, yahoo.com, facebook.com, etc are IPv6 enabled

PS: for people Googling, the error message of "sudo insmod ipv6" is:

"Error: could not load module ipv6: No such file or directory"
User avatar
Posts: 174
Joined: Wed Aug 31, 2011 1:01 pm
by plugwash » Tue Aug 28, 2012 8:21 pm
Sander wrote:PS: for people Googling, the error message of "sudo insmod ipv6" is:

"Error: could not load module ipv6: No such file or directory"

iirc insmod (unlike modprobe) takes the full path of the kernel module, not just it's name.
Moderator
Moderator
Posts: 1964
Joined: Wed Dec 28, 2011 11:45 pm
by Sander » Tue Aug 28, 2012 8:29 pm
plugwash wrote:
Sander wrote:PS: for people Googling, the error message of "sudo insmod ipv6" is:

"Error: could not load module ipv6: No such file or directory"

iirc insmod (unlike modprobe) takes the full path of the kernel module, not just it's name.


Ouch. That looks like it:

Code: Select all
pi@raspbian-armhf-SJ ~/kul/miredo/miredo-debian $ sudo insmod ipv6
Error: could not load module ipv6: No such file or directory
pi@raspbian-armhf-SJ ~/kul/miredo/miredo-debian $ sudo modprobe ipv6
pi@raspbian-armhf-SJ ~/kul/miredo/miredo-debian $



Thank you.

BTW: my IPv6 remark still stands.
User avatar
Posts: 174
Joined: Wed Aug 31, 2011 1:01 pm
by Jim JKla » Tue Aug 28, 2012 11:12 pm
Why not go the whole hog and enable IPv8.

Oh yes that would mean enabling the time shift wormhole. ;)

I remember it's allready enabled on the SD Microdot that comes with the model "F" :D

Ok I'll make do with IPv4 as My ISP has not enabled IPv6. :(
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by TarjeiB » Wed Aug 29, 2012 8:21 am
I actually put my pi on an IPv6 only network the first time around and was quite surprised it didn't have the module loaded by default. I mean, why is IPv4 then enabled by default? :P

I guess it's just a matter of threshold of usage before something should be enabled by default or not - and seeing all other OS do this now, I guess RPi maybe should as well. Even if enabling an additional module for loading is simple.
Posts: 123
Joined: Thu Jul 12, 2012 3:33 pm
by blueadept » Wed Aug 29, 2012 10:45 am
TarjeiB wrote:I actually put my pi on an IPv6 only network the first time around and was quite surprised it didn't have the module loaded by default. I mean, why is IPv4 then enabled by default? :P

I guess it's just a matter of threshold of usage before something should be enabled by default or not - and seeing all other OS do this now, I guess RPi maybe should as well. Even if enabling an additional module for loading is simple.


Those other OS's have a substantially larger memory footprint and are designed to run on hardware which is not so restricted in terms of RAM/CPU as the RPi. The level of usage of IPv6 is still quite low, and while on it's own it may not make a difference, there are plenty of other things that would be a "nice to have" and before long you've got no memory left.

I use IPv6, but it does make sense that it's not loaded by default, just the same as btrfs is not loaded by default.
Posts: 20
Joined: Wed Aug 29, 2012 8:42 am
by dom » Wed Aug 29, 2012 11:26 am
Loading ipv6 consumes 300K of RAM. For the vast majority of users who's ISP does not support ipv6 that is just wasted memory.
If your ISP supports ipv6 then feel free to enable it.
Moderator
Moderator
Posts: 3859
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by Joe Schmoe » Wed Aug 29, 2012 12:19 pm
To Mr. Sander, let me just point out that you will never get very far in the FOSS world with arguments like "You should do X". What you will always gets back is "*You* can do X" (but leave me out of it).

I.e., in the FOSS mindset, the problem always ends when we get to "Here's how *you* can fix it (for yourself)".
Never answer the question you are asked. Rather, answer the question you wish you had been asked.

- Robert S. McNamara - quoted in "Fog of War" -
Posts: 2250
Joined: Sun Jan 15, 2012 1:11 pm
by Jim JKla » Wed Aug 29, 2012 12:53 pm
There is nothing wrong with the FOSS mindset (assuming that its Free Open Source Software) and "Here's how *you* can fix it (for yourself)" provided the instructions are clear and understandable. ;)
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by mpthompson » Wed Aug 29, 2012 11:14 pm
Jim JKla wrote:There is nothing wrong with the FOSS mindset (assuming that its Free Open Source Software) and "Here's how *you* can fix it (for yourself)" provided the instructions are clear and understandable. ;)


Ah, but the effort to make clear and understandable instructions does take time and effort on the part of someone. Here in the Raspbian forums I think we see an entire spectrum of help being offered by community members. This is only natural because the widely divergent backgrounds and experiences of the Raspberry Pi users. With most other FOSS projects, the communities seem to be more homogenous with members having more, or less, a common experience level and outlook towards the project. With the Raspberry Pi, constructive-chaos with 1000's of users going in different directions seeming to be the rule rather than the exception.

Anyway, I guess the good news is that if neede, ipv6 is relatively easy to enable and use. On the flip side, it's still useless to a large number of users who are at the mercy of what capabilities are offered by their Internet service provider.
User avatar
Moderator
Moderator
Posts: 620
Joined: Fri Feb 03, 2012 7:18 pm
Location: San Carlos, CA
by Jim JKla » Thu Aug 30, 2012 6:38 am
We are in the midst of the Bazzar Eric Raymond proposed in his talk "The Cathederal and the Bazzar" (its on you tube somewhere) the RaspberryPi bazzar happens to be big and diverse with lots of stalls with loads of free stuff. :D
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 1935
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by hanse » Sat Sep 22, 2012 7:54 pm
Not having IPv6 enabled by default will make installation of exim4, since exim4 by default listens to ::1, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610918

I installed exim4-daemon-heavy, but I assume the problem is present when installing exim4 too.

I think enabling IPv6 by default is a sound thing to do. Those who care about 300K RAM can disable it, if they don't need it.
Posts: 1
Joined: Sat Sep 22, 2012 7:30 pm
by loz » Thu Mar 07, 2013 12:46 pm
There's an error in the FAQ: http://www.raspbian.org/RaspbianFAQ#How ... se_IPv6.3F
"How do I enable or use IPv6?
Easy. sudo modprobe ipv6 will enable it immediately. If you want it to automatically be enabled at boot, just add ipv6 on a line by itself at the end of /etc/modules.conf. "

As written above, it's /etc/modules, not /etc/modules.conf.

If anybody knows who is in charge of the FAQ, please feel free to contact him or her.
Model B 256 Web Server Raspbian/NGinx/Prosody : http://photo-grenoble.com/
Posts: 12
Joined: Tue Jan 10, 2012 2:31 pm
Location: Grenoble/France
by plugwash » Thu Mar 07, 2013 12:50 pm
loz wrote:As written above, it's /etc/modules, not /etc/modules.conf.

Fixed
Moderator
Moderator
Posts: 1964
Joined: Wed Dec 28, 2011 11:45 pm
by coldair » Tue Apr 16, 2013 6:27 am
QQ截图20130416141844.png
QQ截图20130416141844.png (52.69 KiB) Viewed 7283 times
Posts: 3
Joined: Thu Mar 21, 2013 4:03 am
by TarjeiB » Tue Apr 16, 2013 8:52 am
coldair wrote:
QQ截图20130416141844.png

You still need to use "ping6" on linux.
Posts: 123
Joined: Thu Jul 12, 2012 3:33 pm
by coldair » Tue Apr 16, 2013 8:55 am
TarjeiB wrote:
coldair wrote:
The attachment QQ截图20130416141844.png is no longer available

You still need to use "ping6" on linux.



thx very much!
QQ截图20130416165507.png
QQ截图20130416165507.png (44.65 KiB) Viewed 7281 times
Posts: 3
Joined: Thu Mar 21, 2013 4:03 am
by jaraco » Thu Sep 12, 2013 1:05 pm
I'm also inclined to say that IPv6 should be installed by default. Part of bootstrapping the IPv6 ecosystem is having it available for developers to use. I recently received a bug report that the basic example in my persona library doesn't work https://bitbucket.org/jaraco/jaraco.persona/issue/1/basic-install-of-jp-and-running-of-example. All because I used '::0' as the bind address. I want the example to work on IPv4 and IPv6, but without IPv6 being installed and present (regardless of whether that particular user actually has IPv6 connectivity), the example fails.
Posts: 1
Joined: Thu Sep 12, 2013 12:58 pm
by Brian Cunnie » Sun Sep 29, 2013 11:05 pm
I think it should be enabled by default, too. The argument that 300kB (less than 0.1% of 512MB) required by the IPv6 kernel module creates excessive memory pressure seems somewhat spurious.
User avatar
Posts: 1
Joined: Sun Sep 29, 2013 11:00 pm