rpi-update


5 posts
by bfromcolo » Fri Aug 17, 2012 6:52 pm
How do get rpi-update installed and working in Raspian? I get command not found. apt-get install does not find it.

Thanks
Posts: 21
Joined: Sat Aug 11, 2012 11:20 pm
by SirLagz » Fri Aug 17, 2012 7:05 pm
In the latest raspbian, they have changed the package name.
Look for raspberrypi-bootloader - That is the somewhat more stable package.
If you want cutting edge, you will need the rpi-update script, which you can get at https://github.com/Hexxeh/rpi-update/blob/master/rpi-update
My Blog - http://www.sirlagz.net
Visit my blog for Tips, Tricks, Guides and More !
WiFi Issues ? Have a look at this post ! http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=44044
Posts: 1704
Joined: Mon Feb 20, 2012 8:53 am
Location: Perth, Australia
by bfromcolo » Fri Aug 17, 2012 7:52 pm
Thanks for responding. I was hoping a more recent firmware update would help with issues with network when using USB hubs that are well documented in other threads. It does appear that raspberrypi-bootloader is installed, since apt-get tells me its at the latest version. When I try to execute it I get command not found. find and whereis are not telling me where to look, and its not in /usr/bin like rpi-config would have been. My Linux experience has been limited to playing around Ubuntu, I would appreciate any help if I am going about this the wrong way.
Posts: 21
Joined: Sat Aug 11, 2012 11:20 pm
by MakerDyne » Fri Aug 17, 2012 10:29 pm
The package raspberrypi-bootloader isn't a program to fetch the latest firmware. The package itself is the latest (stable) firmware. To make sure that you've got the latest version provided by it, use aptitude to update it: run
Code: Select all
sudo aptitude update && sudo aptitude full-upgrade
Posts: 8
Joined: Wed Aug 15, 2012 8:50 am
by bfromcolo » Fri Aug 17, 2012 10:44 pm
OK so when it ran and said it was at the latest version that actually meant my firmware was at the latest "official" version.

I managed to get rpi-update working following instruction on the WIKI trouble shooting page. That did install a newer version of firmware, but still has not resolved the problems with my USB hub and WIFI adapter.

Thanks
Posts: 21
Joined: Sat Aug 11, 2012 11:20 pm