Another go round with a corrupted SD card


15 posts
by caderoux » Sat Oct 27, 2012 8:46 pm
Should I be running something newer than this?:

Linux raspberrypi 3.2.27+ #250 PREEMPT Thu Oct 18 19:03:02 BST 2012 armv6l

I have 2 RPis, and the one in the living room just failed again to survive a reboot after its latest apt-get upgrade. It had been running fine for a few weeks. All my SD cards are identical Sandisk 8GB cards which have been reliable otherwise.

There was a segmentation fault when updating squeak-vm:

Preparing to replace squeak-vm 1:4.4.7.2357-1.1 (using .../squeak-vm_1%3a4.4.7.2357-1.1+rpi1_armhf.deb) ...
Unpacking replacement squeak-vm ...
Processing triggers for gnome-icon-theme ...
Segmentation fault
WARNING: icon cache generation failed
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for shared-mime-info ...
Processing triggers for mime-support ...
Setting up squeak-vm (1:4.4.7.2357-1.1+rpi1) ...

Hardware problem?
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by Lob0426 » Sun Oct 28, 2012 3:05 am
That is the newest firmware. If your other RasPi updates with no problems then move your other card over to it for updates, then move it back.

My RasPi server gets corrupted about every other time I try to update it. This never happens if I move it to my Lapdock and update it. I suspect it is the 8GB Transcend card in my server. Another possibility is that my 500ma power supply on the server just does not have enough juice to work for an update. it runs for weks without problem. still trying to figure out which it is. the RasPi that is in the server worked just fine in the Lapdock also.
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1942
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by caderoux » Sun Oct 28, 2012 3:09 am
Lob0426 wrote:That is the newest firmware. If your other RasPi updates with no problems then move your other card over to it for updates, then move it back.

My RasPi server gets corrupted about every other time I try to update it. This never happens if I move it to my Lapdock and update it. I suspect it is the 8GB Transcend card in my server. Another possibility is that my 500ma power supply on the server just does not have enough juice to work for an update. it runs for weks without problem. still trying to figure out which it is. the RasPi that is in the server worked just fine in the Lapdock also.


This one has been updating fine since I stopped overclocking (which is when I had the first issue).

Would it be more reliable to move root to a USB drive instead of SD? Or a powered USB drive?
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by caderoux » Sun Oct 28, 2012 3:50 am
Lob0426 wrote:That is the newest firmware. If your other RasPi updates with no problems then move your other card over to it for updates, then move it back.

My RasPi server gets corrupted about every other time I try to update it. This never happens if I move it to my Lapdock and update it. I suspect it is the 8GB Transcend card in my server. Another possibility is that my 500ma power supply on the server just does not have enough juice to work for an update. it runs for weks without problem. still trying to figure out which it is. the RasPi that is in the server worked just fine in the Lapdock also.


The PSU on it was a .85A Amazon Kindle charger. I put on another charger which is rated for 1.2A to see if it corrupts any time soon. Seems like these issues never happened before the overclocking feature was released.
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by Lob0426 » Sun Oct 28, 2012 6:18 am
Mine was not overclocked at all. I turned it off after the last update crash. I was able to bring it up to date on my Lapdock even though I had just turned "mild" over-clocking back on. Matter of fact I had to update raspi-config just to see the over-clock settings. The power Supply is looking like it might be the problem. Maybe it (the RasPi) just draws too much current when it is doing the updates.

I backed it up with win32diskimager. So I may just try to push it and see what the voltage drops down too.

It does seem like the over-clocking has brought out SD card issues again. When people saw 1000MHz they set it straight too that. That is not the way to get a stable over-clock at all. You start low and work up, not the other way around.

The "server" RasPi tested out with the following, with no overvolt.
arm_freq=900
core_freq=320
gpu_freq=320
sdram_freq=500

But the 900MHZ setting (medium) in raspi-config sets core at 333MHZ. My RasPi did not like anything over a 320MHz core.
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1942
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by caderoux » Sun Oct 28, 2012 3:09 pm
Lob0426 wrote:That is the newest firmware. If your other RasPi updates with no problems then move your other card over to it for updates, then move it back.


I'm going to keep the #160 from the standard image on this other Pi too.
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by caderoux » Mon Oct 29, 2012 1:41 am
Looks like the #250 firmware is now in the standard update...
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by caderoux » Tue Oct 30, 2012 4:04 am
I was playing with Raspcontrol and apparently the first RPi I have shows void on the warranty. I'm still not sure what sets that bit after reading 30 pages of thread here on the forum. So some combination of what I thought was recommended and I put in when the overclocking options were first publicized managed to set the warranty bit. This may have also contributed to the first SD card corruption. Not sure about the second, unless my device is actually damaged from the overclocking in some way.
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by metis » Mon Nov 05, 2012 8:27 pm
odd that no one tried or suggested this.

I was experiencing corrupt sd card, and since I added the sync option in my fstab file, I'm not experiencing corruption anymore:

/etc/fstab
----------
/dev/mmcblk0p3 / ext4 defaults,sync,noatime 0 0

It has a drawback, it reduces the write speed on the sdcard since it writes right away the data on the card. But at least, no corruption anymore (for me).
Posts: 4
Joined: Mon Nov 05, 2012 8:23 pm
by caderoux » Tue Nov 06, 2012 12:38 am
metis wrote:odd that no one tried or suggested this.

I was experiencing corrupt sd card, and since I added the sync option in my fstab file, I'm not experiencing corruption anymore:

/etc/fstab
----------
/dev/mmcblk0p3 / ext4 defaults,sync,noatime 0 0

It has a drawback, it reduces the write speed on the sdcard since it writes right away the data on the card. But at least, no corruption anymore (for me).


Does a reboot automatically sync? I can't recall a time where the machine was shutdown abnormally for any reason around the times it failed to reboot. I keep them running 24x7 and always have an open SSH shell into them from my main desktop (which never seems to lose connection, despite being wireless and one of the RPis being on a wirelessly bridged segment and the other connected to my main switched segment).
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans
by metis » Tue Nov 06, 2012 2:14 am
Well the sync option tells the kernel to write immediatly the data to the filesystem instead of doing async writes. So, you're always sure that there's no data left to be commited on the sd card. It should be useful in power outages scenarios as well. So, each time a process tries to write something, it is actually done. Not sure if it answers your question.

Regards
Posts: 4
Joined: Mon Nov 05, 2012 8:23 pm
by TheGremlyn » Mon Dec 03, 2012 5:03 am
How much of a change in write speed did you see?
Posts: 2
Joined: Mon Dec 03, 2012 3:20 am
Location: San Diego, CA
by Drubih » Thu Dec 20, 2012 11:41 pm
'evening,

Same thing here, have been scratching my head for a couple of days. At first I thought it was the Lexar 400x SD Card. After all, I guess it makes sense;
After adding the "sync" option into the /etc/fstab I can confirm that the data corruption disappeared. However, with it, the performances disappeared as well. Looking with "top", it confirms that the "sync" works; lots of cpu time lost on I/O waitstates and overal system load goes through the roof. I haven't exactly timed it, but I would say it is roughly 10 times slower as opposed to not have "sync".

By the way, I already made a habbit of using sync;sync;shutdown -h now, but even when sync'ing just before shutdown didn't do the trick.
Posts: 3
Joined: Thu Dec 20, 2012 11:34 pm
by nicobi » Thu Jan 17, 2013 8:54 pm
I don't know if this is relevant to your issue or can help, but I use a power button, that launches shutdown ;) :

http://nicbi.blogspot.fr/2013/01/how-to ... rutal.html
Posts: 2
Joined: Thu Sep 27, 2012 8:44 pm
by caderoux » Thu Jan 17, 2013 9:00 pm
nicobi wrote:I don't know if this is relevant to your issue or can help, but I use a power button, that launches shutdown ;) :

http://nicbi.blogspot.fr/2013/01/how-to ... rutal.html


Cool idea. I always shutdown and reboot from ssh, but this is a good option.
Posts: 46
Joined: Tue Jun 12, 2012 8:04 pm
Location: New Orleans