No sound control in Deb rel 2012-08-16-wheezy-raspbian


5 posts
by dwreid55 » Sat Aug 25, 2012 7:14 pm
I did some searches and didn't see this topic so am starting a new one. If there is another topic addressing this, apologies.

My configuration:
HDMI monitor / NO sound capability
Analog sound connected to amplified speakers
2012-08-16-wheezy-raspbian

I've been doing a lot of research to solve sound problems in the Wheezy release. Some applications will produce analog sound. Some will not. After making some of the suggested tweaks I had vlc working and some games such as Frozen Bubble and the Python games but still no sound from some other applications such as GWELED.

After making some other suggested tweaks I finally had the system so polluted that I decided to start fresh. I downloaded and imaged the latest release as of this post. 2012-08-16-wheezy-raspbian

The image to the SD card went fine. I booted the system and found that this release has no tools/apps/preferences/utilities for controlling sound at all. There is no way to set the volume. The applications that produce sound do so at a very low volume. I've looked high and low but can't find a way to control sound.

Does anyone have any suggestions or guidance?

Thank you in advance.
Posts: 12
Joined: Wed Jul 11, 2012 3:13 am
by xmanmonk » Sun Aug 26, 2012 1:56 am
I've got mplayer (command line) installed on my pi, and it will adjust the volume levels, but unfortunately the adjustments are not working properly. The sound seems to be either too low, or way too loud and distorted.

In the gui (after typing startx at the command line), you should have a volume control way over on the right bottom corner of the screen. It wasn't there for me at first, and then I learned that you had to run a little command after you log in on the command line in order to make it work:

sudo modprobe snd_bcm2835

This should get it running. You may want to put this into a startup file or some other shell script to make it easier. That way, you won't have as much to type. Hope that helps.
-xmanmonk
User avatar
Posts: 35
Joined: Tue Jul 17, 2012 5:11 am
by dwreid55 » Sun Aug 26, 2012 2:11 am
Thanks for the suggestions. The previous image I was using didn't require the modprobe command. It was just "there". There was also a setting in preferences that is no longer there. I'll give that a try and see if it helps. I get sound without the modprobe command, I just don't have any controls or settings. There used to be a preferences GUI that listed the hardware, allowed you to select the output as HDMI or Analog and mono or stereo and allowed me to test the speakers. Now... not there after I installed the current image. There also used to be a menu for sound and music and an audio player. Those are also missing from the current image. Odd.

I'll post back with the results.

Thank you again.
Posts: 12
Joined: Wed Jul 11, 2012 3:13 am
by dwreid55 » Thu Aug 30, 2012 12:43 am
With the software update today (2012-08-29) I have sound working properly again.

I did the normal apt-get update
apt-get upgrade

I noticed that there was a package held back so did apt-get dist-upgrade to install new versions of software.

Following this I added the volume control app back to the task bar.

Rebooted.

Voila. Sound seems to work fine.

Note: Using the volume control in an application such as VLAN can cause distorted sound. This appears to be due to the fact that some applications control the amount of pre-amplification into the "sound card" and not the amount of amplification on the output stage of the "sound card". Doing this can over drive the input stage of the "sound card" and cause clipping and distortion. The ALSA volume control controls the amplification on the output stage and provides cleaner sound without all of that distortion.

I've also noticed that when the processor is busy with sound, things that cause new windows to appear or to be replotted can cause a popping or rapid clicking in the sound. I'm guessing that this occurs when plotting video causes the busy CPU to drop sound frames. At least it does not happen if you leave the mouse alone and don't try to do too much multi-tasking.

Hope that this is helpful to someone or anyone.
Posts: 12
Joined: Wed Jul 11, 2012 3:13 am
by Win7ine » Fri Aug 31, 2012 9:43 pm
Well there is a Volume setting application you can use at the command prompt or in LXterminal. It is ALSAMIXER. Works much better than the GUI volume controller in the taskbar. BTW for people who miss the Volume Speaker icon and functionality it can be added in "Add/Remove Panel items".
Posts: 13
Joined: Fri Aug 03, 2012 10:42 am