Torrent client for Raspberry Pi


25 posts
by sim_tcr » Tue Nov 06, 2012 1:08 pm
Hello,

I am a new user to the community.
I am planning to order a Raspberry Pi for my personal use.
I understand that loading windows OS on Raspberry is still not possible.
Are any of the OS images provided under the downloads page has a build in torrent client?
If not is it possible to install one by our self?

Thanks,
Simon Mandy
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by lsbx22 » Tue Nov 06, 2012 6:12 pm
get the debian image and open the terminal console and run:
Code: Select all
sudo apt-get -y install transmission transmission-daemon nano


then start transmission then stop it
Code: Select all
service transmission start && service transmission stop


then edit the configuration file
Code: Select all
nano .config/transmission/settings.json


edit the respective lines to:
Code: Select all
    "rpc-whitelist-enabled": false,
    "rpc-enabled": true, 


after you are done customising your settings file, type CTRL +X to save it
then type
Code: Select all
service transmission start

to start the server

you can then open the server management by typing in your browser the ip address (or hostname) with :9091 as the port
Posts: 7
Joined: Tue Nov 06, 2012 5:47 pm
by tahuds » Thu Nov 08, 2012 4:12 am
Will this save the configuration over a reboot cycle?
Posts: 1
Joined: Thu Nov 08, 2012 4:09 am
by sim_tcr » Thu Nov 08, 2012 1:31 pm
lsbx22 wrote:get the debian image and open the terminal console and run:
Code: Select all
sudo apt-get -y install transmission transmission-daemon nano


then start transmission then stop it
Code: Select all
service transmission start && service transmission stop


then edit the configuration file
Code: Select all
nano .config/transmission/settings.json


edit the respective lines to:
Code: Select all
    "rpc-whitelist-enabled": false,
    "rpc-enabled": true, 


after you are done customising your settings file, type CTRL +X to save it
then type
Code: Select all
service transmission start

to start the server

you can then open the server management by typing in your browser the ip address (or hostname) with :9091 as the port


Thank you. I cant wait to try this. My pi is yet to arrive.
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by Leestons » Thu Nov 08, 2012 11:04 pm
For the above instructions they won't work, you need to type transmission-daemon rather than transmission. Otherwise you will just get "Service not found"

You will also need to run the commands as root or put sudo before them

Code: Select all
sudo service transmission-daemon start


The above guide still didn't work, after some time on google I found you were editing the wrong file

instead of
Code: Select all
.config/transmission-daemon/settings.json


edit
Code: Select all
/etc/transmission-daemon/settings.json
User avatar
Posts: 53
Joined: Sun Jul 22, 2012 2:19 pm
by xcorex » Fri Nov 09, 2012 9:54 am
Leestons is right. You may prefer transmission-daemon over transmission (transmission-gtk/transmission-qt). Another option is rtorrent.
Transmission-daemon is, obviously, a daemon and depends of transmission-common, a web client.
rtorrent is a command line client, very light and efficient. You will need to customize it as a daemon by hand and install a web client if you want.
Make your choice. ;)
Posts: 4
Joined: Thu Oct 04, 2012 8:01 pm
by sim_tcr » Thu Nov 15, 2012 6:07 pm
pi@raspberrypi /etc/transmission-daemon $ sudo service transmission-daemon status
[ ok ] transmission-daemon is running.

When i try to browse http://192.168.1.3:9091 i get an authentication promt. i tried pi as username and raspberry as password. But it did not work.

Any thoughts?
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by Leestons » Thu Nov 15, 2012 8:48 pm
sim_tcr wrote:pi@raspberrypi /etc/transmission-daemon $ sudo service transmission-daemon status
[ ok ] transmission-daemon is running.

When i try to browse http://192.168.1.3:9091 i get an authentication promt. i tried pi as username and raspberry as password. But it did not work.

Any thoughts?


Change the password at /etc/transmission-daemon/settings.json
User avatar
Posts: 53
Joined: Sun Jul 22, 2012 2:19 pm
by diablopop » Fri Nov 16, 2012 6:55 am
your artice is fine ,thinks!






_____________________________________________________
I like video games and online games,the site is http://www.vipdiablo3.com/
Posts: 4
Joined: Wed Aug 01, 2012 8:52 am
by sim_tcr » Sat Nov 17, 2012 7:01 pm
Leestons wrote:
sim_tcr wrote:pi@raspberrypi /etc/transmission-daemon $ sudo service transmission-daemon status
[ ok ] transmission-daemon is running.

When i try to browse http://192.168.1.3:9091 i get an authentication promt. i tried pi as username and raspberry as password. But it did not work.

Any thoughts?


Change the password at /etc/transmission-daemon/settings.json


I tried to change ,
"rpc-password": "raspberry",
"rpc-username": "pi",

But when i restart transmission daemon, above values are going back to original.

"rpc-password": "{0082efcb658c70808999caa271479eb704c91265DokKaybY",
"rpc-username": "transmission",

Please help
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by azeam » Sat Nov 17, 2012 8:02 pm
Stop the daemon before you edit the config file and then start it again.
User avatar
Posts: 192
Joined: Fri Oct 26, 2012 11:13 pm
by sim_tcr » Sun Nov 18, 2012 9:13 am
I am still not successful in accessing transmission client web url. I see below error message when i try to http://<ip>:9091

403: Forbidden
Unauthorized IP Address.
Either disable the IP address whitelist or add your address to it.
If you're editing settings.json, see the 'rpc-whitelist' and 'rpc-whitelist-enabled' entries.
If you're still using ACLs, use a whitelist instead. See the transmission-daemon manpage for details.


I am also posting the contents of my settings.json . Can someone please have a look and tell me whats wrong with my setup?

{
"alt-speed-down": 50,
"alt-speed-enabled": false,
"alt-speed-time-begin": 540,
"alt-speed-time-day": 127,
"alt-speed-time-enabled": false,
"alt-speed-time-end": 1020,
"alt-speed-up": 50,
"bind-address-ipv4": "0.0.0.0",
"bind-address-ipv6": "::",
"blocklist-enabled": false,
"blocklist-url": "http://www.example.com/blocklist",
"cache-size-mb": 4,
"dht-enabled": true,
"download-dir": "/var/lib/transmission-daemon/downloads",
"download-limit": 100,
"download-limit-enabled": 0,
"download-queue-enabled": true,
"download-queue-size": 5,
"encryption": 1,
"idle-seeding-limit": 30,
"idle-seeding-limit-enabled": false,
"incomplete-dir": "/root/Downloads",
"incomplete-dir-enabled": false,
"lpd-enabled": false,
"max-peers-global": 200,
"message-level": 2,
"peer-congestion-algorithm": "",
"peer-limit-global": 240,
"peer-limit-per-torrent": 60,
"peer-port": 51413,
"peer-port-random-high": 65535,
"peer-port-random-low": 49152,
"peer-port-random-on-start": false,
"peer-socket-tos": "default",
"pex-enabled": true,
"port-forwarding-enabled": false,
"preallocation": 1,
"prefetch-enabled": 1,
"queue-stalled-enabled": true,
"queue-stalled-minutes": 30,
"ratio-limit": 2,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": true,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-password": "{29c6ec5ca758c6f26c351dae3a51397f1a27aee1uZBiBJBA",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "pi",
"rpc-whitelist": "127.0.0.1",
"rpc-whitelist-enabled": true,
"scrape-paused-torrents-enabled": true,
"script-torrent-done-enabled": false,
"script-torrent-done-filename": "",
"seed-queue-enabled": false,
"seed-queue-size": 10,
"speed-limit-down": 100,
"speed-limit-down-enabled": false,
"speed-limit-up": 100,
"speed-limit-up-enabled": false,
"start-added-torrents": true,
"trash-original-torrent-files": false,
"umask": 18,
"upload-limit": 100,
"upload-limit-enabled": 0,
"upload-slots-per-torrent": 14,
"utp-enabled": true
}
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by azeam » Sun Nov 18, 2012 10:25 am
You need to add the IP address of the computer you are accessing the daemon from in

Code: Select all
"rpc-whitelist": "127.0.0.1",
Separate them with a comma - for example
Code: Select all
"rpc-whitelist": "127.0.0.1,192.168.0.2",
You can also use wildcards:
Code: Select all
"rpc-whitelist": "127.0.0.1,192.168.*.*",


And if you don't want a whitelist (so that all IP addresses can access the daemon) change
Code: Select all
"rpc-whitelist-enabled": true,
to
Code: Select all
"rpc-whitelist-enabled": false,
User avatar
Posts: 192
Joined: Fri Oct 26, 2012 11:13 pm
by sim_tcr » Sun Nov 18, 2012 12:48 pm
I managed to make transmission working with the help of http://www.webupd8.org/2009/12/setting- ... ui-in.html
2 times the pi crashed after few time i left the transmission running to download a movie.
I suspect that transmission's cpu utilization and memory utilization is high. top command shows transmission is utilizing 6 to 10% (or even 20% sometimes) of CPU. Memory utilization is 3.4%. Could it be the reason my pi is crashing?
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by dom » Sun Nov 18, 2012 1:07 pm
smsc95xx.turbo_mode=N should be added to cmdline.txt if you are using torrents. See:
https://github.com/raspberrypi/linux/issues/153
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4307
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by sim_tcr » Sun Nov 18, 2012 1:21 pm
dom wrote:smsc95xx.turbo_mode=N should be added to cmdline.txt if you are using torrents. See:
https://github.com/raspberrypi/linux/issues/153


should i perform below?
sudo vi /etc/modprobe.d/smscnonturbo.conf
and add line options smsc95xx turbo_mode=N
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by sim_tcr » Sun Nov 18, 2012 1:45 pm
sim_tcr wrote:
dom wrote:smsc95xx.turbo_mode=N should be added to cmdline.txt if you are using torrents. See:
https://github.com/raspberrypi/linux/issues/153


should i perform below?
sudo vi /etc/modprobe.d/smscnonturbo.conf
and add line options smsc95xx turbo_mode=N


I understood what you said, I added smsc95xx.turbo_mode=N to /boot/cmdline.txt and rebooted. WIll let you know if that fixed the issue.
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by sim_tcr » Mon Nov 19, 2012 8:41 am
sim_tcr wrote:
sim_tcr wrote:
dom wrote:smsc95xx.turbo_mode=N should be added to cmdline.txt if you are using torrents. See:
https://github.com/raspberrypi/linux/issues/153


should i perform below?
sudo vi /etc/modprobe.d/smscnonturbo.conf
and add line options smsc95xx turbo_mode=N


I understood what you said, I added smsc95xx.turbo_mode=N to /boot/cmdline.txt and rebooted. WIll let you know if that fixed the issue.


Nothing resolved my issue.
But i switched from wireless to Ethernet and it working fine.
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by orca » Wed Feb 13, 2013 9:34 am
add "smsc95xx turbo_mode=N" is not useful for my Raspberry Pi while using transmission-daemon
It still crashed.

I add four heat sinks on top of the ICs (on PCB board) and remove "smsc95xx turbo_mode=N" in /boot/cmdlines, and now it doesn't crash, just perfect.
Posts: 3
Joined: Tue Feb 12, 2013 5:28 pm
by sim_tcr » Tue Feb 19, 2013 1:27 pm
I use transmission-gt (GUI client on a VNC session). Pi Never Crashes.
http://raspisimon.no-ip.org
Raspberry Pi Model B x 2, Raspberry Pi 2 x 2, Transcend 32GB Class 10, Transcend 16GB Class 10, Transcend 8GB Class 4, Custom 12V 1.5A (stepped down to 5.5V)
Posts: 319
Joined: Tue Nov 06, 2012 1:01 pm
Location: Bangalore
by catbehemoth » Thu Apr 04, 2013 11:07 am
a question

i changed the default download directory
"download-dir": "/var/lib/transmission-daemon/downloads",
to
"download-dir": "/home/pi/Downloads",

when i add a torrent via WebUI i get write permission problem , how can i allow transmission-daemon to write into this directory?

i've tried to run daemon as a pi user still the same problem. this is the limit of my linux knowledge=)

thank you.
Posts: 1
Joined: Fri Mar 01, 2013 12:41 pm
Location: UK
by pevans91 » Sat Apr 06, 2013 9:00 pm
I'm having the same problem,

Cannot write into the directory where I want to save my downloads :shock:

Any help would be appreciated!
Posts: 2
Joined: Sat Apr 06, 2013 8:58 pm
by abhishek2386 » Tue Aug 12, 2014 6:42 pm
Friends you can try the complete guide posted here http://www.techjawab.com/2014/08/how-to-install-transmission-on.html
Posts: 4
Joined: Mon Jul 15, 2013 8:25 am
by glitter » Wed Aug 13, 2014 2:14 am
Thanks a ton, abhishek2386! I'd been having trouble with that for days now, but your tutorial got me through it. I owe you a drink. :lol:



Part-Time Photographer Who Buys All The Manicure Tables She Can Find.
Posts: 1
Joined: Wed Aug 13, 2014 2:06 am
by jochenstacker » Wed Dec 31, 2014 10:31 pm
I have installed full Transmission on my Pi and then connect to the desktop using Xtightvncviewer.
That way Transmission works the same as on my Debian system, except via remote desktop and I find managing multiple torrents and moving files and folders around a bit easier.
Check out this very useful article:
http://www.penguintutor.com/linux/tightvnc
Will give the web based version a blast and see how that goes. Because other than Transmission I manage the Pi fully via SSH.
Posts: 4
Joined: Mon Dec 08, 2014 5:15 pm