Composite does only show black and white/no colors


11 posts
by Chrunchstick » Sat May 12, 2012 2:15 pm
Hello all,

A few days ago I received my Raspberry Pi and I am quite happy with it, I only have one question.

When I try to connect the Raspberry to my (quite old)  TV using Composite there are no colors  on the screen, just black and white. All my other devices that I connect with Composite (gamecube, PSX, N64 etc.)  do have color. On another (newer) TV Composite does work with the same cable, so I know the problem is probably on the TV's end.

The TV is a Sony KV-14M1D and is +/- 10 years old.

Is there anything that I can do to fix this? I would like the TV to use in some sort of Mame machine because of the classic looks.

Edit:

Almost forgot, the sides of the output image fall off the monitor. Maybe because Its 4:3?
Posts: 12
Joined: Sat May 12, 2012 12:58 pm
by dom » Sat May 12, 2012 2:51 pm
Composite output defaults to NTSC. Most TVs will accept either PAL or NTSC. Older ones may not, but the usual failure mode is displaying monochrome.

Try:

sdtvmode=2

Look here for more info: http://elinux.org/RPi_config.txt

You can also try adding overscan_left=32 (and right,top,bottom) to create larger borders around image to handle overscan.
Raspberry Pi Engineer
Raspberry Pi Engineer
Posts: 3864
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by JeremyF » Sat May 12, 2012 2:58 pm
I can"t answer the question about black and white, but the cut off image is due to overscan.

You can fix this by using http://elinux.org/RPi_config.txt

overscan_bottom= overscan_top= overscan_left= overscan_right=


Editing config.txt can be done from the Pi or from a Windows/Linux/Mac x86 computer.

From the Pi:


  1. Open up a terminal

  2. Type "sudo nano /boot/config.txt" (no quotes)

  3. Add the lines about overscan to the document

  4. Hit Control-X, then hit the y key

  5. Reboot


From a computer:


  1. Insert img"d SD card in your non-Pi computer

  2. Open up the FAT partition in your computer"s file manager (Windows Explorer, Finder, etc.) On Windows and Mac, this should be the only viewable partition.

  3. Create a new file called "config.txt" and add the lines about overscan

  4. Eject the card

  5. Insert in Pi and reboot


————————————–

Another thing to add-

For reading text, it might be a bit fuzzy and tiny on a larger screen. Something you may want to consider is doubling the pixel size with

framebuffer_width=320

framebuffer_height=240
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 522
Joined: Wed Jan 25, 2012 9:06 pm
by Chrunchstick » Sat May 12, 2012 3:09 pm
Thanks dom, (edit: and Jeremy F, saw you reply after i reloaded ;-)

The overscan fix worked, but the switch to PAL did not. Any other possible fixes?
Posts: 12
Joined: Sat May 12, 2012 12:58 pm
by jbeale » Sat May 12, 2012 3:20 pm
possibly a silly question, but in the VIDEO menu on the TV, is the COLOR adjustment set at midrange?

EDIT- nevermind, you said the other devices do show color.
User avatar
Posts: 1886
Joined: Tue Nov 22, 2011 11:51 pm
by JeremyF » Sat May 12, 2012 3:22 pm
Just for fun, try sdtv_mode=3

I have no idea, tbh.
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 522
Joined: Wed Jan 25, 2012 9:06 pm
by Chrunchstick » Sat May 12, 2012 7:06 pm
Solved by using sdtv_mode=2

Dom: I copy/pasted your solution but you missed the underscore ;-p Thanks though, my Pi is running great :-)

Mame Machine here I come
Posts: 12
Joined: Sat May 12, 2012 12:58 pm
by Robert_M » Fri May 25, 2012 1:28 pm
JeremyF wrote:Another thing to add-

For reading text, it might be a bit fuzzy and tiny on a larger screen. Something you may want to consider is doubling the pixel size with

framebuffer_width=320
framebuffer_height=240


I was looking to sort out another problem, and found this comment of yours useful for working with my old Sylvania 20" TV. Cutting down to half-standard resolution made things more readable, but didn't give much room for the text, so I went to a "three quarters" setting of 480x360 and it now looks wonderful! :D
I sometimes ride my Pi to the Forum.
User avatar
Posts: 209
Joined: Fri Nov 25, 2011 12:50 am
by JeremyF » Fri May 25, 2012 7:30 pm
Robert_M wrote:
JeremyF wrote:Another thing to add-

For reading text, it might be a bit fuzzy and tiny on a larger screen. Something you may want to consider is doubling the pixel size with

framebuffer_width=320
framebuffer_height=240


I was looking to sort out another problem, and found this comment of yours useful for working with my old Sylvania 20" TV. Cutting down to half-standard resolution made things more readable, but didn't give much room for the text, so I went to a "three quarters" setting of 480x360 and it now looks wonderful! :D


Thanks, always happy to help.
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 522
Joined: Wed Jan 25, 2012 9:06 pm
by REDWILD2113 » Thu Sep 12, 2013 6:50 pm
Thanks for this! I was using my Pi on a small SDTV because I was building an arcade machine and thought it'd look great instead of a big HDTV in it. Do you have any idea on what wire I need to get audio on the RasPi? I'm using composite, but I tried the red-red and white-white cables, no sound. Sound works on the TV with other things, I just can't find the wire I need.
Thanks.
Posts: 10
Joined: Thu Aug 01, 2013 7:51 am
by jbeale » Thu Sep 12, 2013 8:48 pm
sound from the Pi comes from the headphone / line-out jack, which takes a 1/8" plug and sits right next to the video output on the board. It is the one colored blue in this photo. You would need a cable adaptor to connect that to the RCA audio inputs on a monitor.
User avatar
Posts: 1886
Joined: Tue Nov 22, 2011 11:51 pm