Fire! SD card melted! [solved]


14 posts
by boarsblood » Fri May 04, 2012 1:21 pm
Just got my RPi in the post.

Connected usb keyboard, video cable (no hdmi in the house), put SD card in (original 2GB SanDisk micro SD in original SanDisk adaptor.), connected to PC's USB port as power supply.

Nothing appeared on the screen but the LED lit on the RPi and stayed on. I picked it up to check the connections and the micro SD card was so hot it had started melting the adaptor. The RPi was on a wooden surface so no risk of a short.

I have recently used the micro SD in my HTC HD2 phone, and copied data from it to my PC using the adaptor to fit it to a full sized SD-USB adaptor so I know all parts work. Does anyone have any idea what happened.

I'm now going to get another SD card but will be buying something cheap in case that gets fried too. (I really don't want to have to wait 8 weeks to get a replacement from Farnell if this RPi is knackered)
Posts: 29
Joined: Mon Jan 30, 2012 8:13 pm
by boarsblood » Fri May 04, 2012 1:47 pm
I've just done a destructive test on the microSD-SD adaptor and there were no shorts in there either. The micro SD card is now dead.
Posts: 29
Joined: Mon Jan 30, 2012 8:13 pm
by jamesh » Fri May 04, 2012 1:49 pm
If the Raspi is dead you won't wait that long for a replacement.

The fault sounds very odd, never heard anything like that before. Check the solder joints on the SD card connector to see if there is anything bridged.
Soon to be employed engineer - Hurrah! Volunteer at the Raspberry Pi Foundation, helper at PiAcademy September 2014.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 11930
Joined: Sat Jul 30, 2011 7:41 pm
by boarsblood » Fri May 04, 2012 2:32 pm
That was the first thing I checked. I actually gave the board a good look over before I connected anything and made sure there were no bits of wire or foil in any connectors. Everything is visually fine.

I'll have to assume a catastrophic failure inside the micro SD card and try another one, when I find one.
Posts: 29
Joined: Mon Jan 30, 2012 8:13 pm
by boarsblood » Fri May 04, 2012 2:40 pm
From another source - "If you have software constantly swapping data on and off the card then it will generate more heat."

If the card was corrupt, i.e. the image didn't write properly. What happens during boot? Will the hardware routines looking for the image on the card keep searching again and again thousands of times a second, causing the card to heat up? Would this affect the micro SD package more than a standard sized SD card?
Posts: 29
Joined: Mon Jan 30, 2012 8:13 pm
by jamesh » Fri May 04, 2012 2:53 pm
boarsblood said:


From another source - "If you have software constantly swapping data on and off the card then it will generate more heat."

If the card was corrupt, i.e. the image didn't write properly. What happens during boot? Will the hardware routines looking for the image on the card keep searching again and again thousands of times a second, causing the card to heat up? Would this affect the micro SD package more than a standard sized SD card?


Constant use does heat them up, but I think from the OP that this happened very fast - which implies a short rather than just usage. It takes some time to heat them enough to notice, and they should never heat up enough to melt.
Soon to be employed engineer - Hurrah! Volunteer at the Raspberry Pi Foundation, helper at PiAcademy September 2014.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 11930
Joined: Sat Jul 30, 2011 7:41 pm
by dom » Fri May 04, 2012 3:03 pm
boarsblood said:

If the card was corrupt, i.e. the image didn't write properly. What happens during boot? Will the hardware routines looking for the image on the card keep searching again and again thousands of times a second, causing the card to heat up? Would this affect the micro SD package more than a standard sized SD card?

Copying a large file will cause the sdcard to be accessed just as fast. It's not that.

You have a hardware fault. Either the R-Pi board, the micro sdcard adaptor or the micro sdcard.

Ideally test it next with a full size sdcard. If that dies, then the Pi is faulty (probably a short).

If that works try the adaptor with a different micro sdcard. If that fails it's the adaptor (again, probably a short).

If that works, then it was just the initial micro sdcard which expired in a bad way.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4042
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by Steady_Bear » Fri May 04, 2012 4:10 pm
I couldn't help but wonder if the BBC had seen this one and decided to jump on the 'electronics getting hot and melting' news band-wagon. I know, it's normally batteries that takes the news, but I had to check. And, I know I'm not helping matters here.

Amusingly, I did find this in the Science section on the side (it would work a bit better if I had access to my webspace I'm paying my ISP for so you could see the screenshot with piccies and all):

Up in smoke
Counting the ecological costs of raging fires in Nepal
Heritage crops
Do strawberries taste as good as they used to?

Close, but not there yet.
Posts: 110
Joined: Sat Jan 14, 2012 12:06 pm
by jbeale » Fri May 04, 2012 4:26 pm
User avatar
Posts: 2076
Joined: Tue Nov 22, 2011 11:51 pm
by jbeale » Fri May 04, 2012 4:28 pm
jbeale said:


In a few minutes I was able to find quite a few cases of hot or melting MicroSD cards, none of them on RasPi hardware, so it does sometimes happen.  One possibility is an internal short on the chip caused by ESD (static discharge).

http://samsunggalaxysforums.co.....g-Very-Hot
http://answers.yahoo.com/quest.....334AAuPiXh
http://answers.yahoo.com/quest.....431AAZmn0b
http://answers.yahoo.com/quest.....337AAPo6ri
http://answers.yahoo.com/quest.....650AA1Hd1X
http://www.evo4gforum.net/htc-.....-warning!/

User avatar
Posts: 2076
Joined: Tue Nov 22, 2011 11:51 pm
by boarsblood » Fri May 04, 2012 5:43 pm
It was a failure of the SD card. Posting this from my RPi
Posts: 29
Joined: Mon Jan 30, 2012 8:13 pm
by Vindicator » Fri May 04, 2012 5:51 pm
That great news for you and your PI.
If you are more worried about ,spelling, punctuation or grammar you have probably already missed the point so please just move on.
User avatar
Posts: 314
Joined: Sat Sep 17, 2011 11:10 pm
Location: Susanville Ca USA
by liz » Sat May 05, 2012 10:36 pm
Oh, thank heavens for that. Eben and I were talking about your melty card over dinner this evening, wondering what the hell could be causing it (neither of us had ever come across that happening either) - VERY glad it wasn't our fault!
--
Head of Comms, Raspberry Pi Foundation
User avatar
Raspberry Pi Foundation Employee & Forum Moderator
Raspberry Pi Foundation Employee & Forum Moderator
Posts: 4112
Joined: Thu Jul 28, 2011 7:22 pm
by aaroncoffey » Mon May 14, 2012 6:52 pm
As a thought, in the OP it was stated that you are using your computers USB port to power the Pi.

connected to PC's USB port as power supply.


USB spec states 500mA of draw, the Pi needs more. I would switch power supplies for the future.
Posts: 10
Joined: Mon May 14, 2012 6:43 pm