Openelec composite video bad picture


6 posts
by mark120 » Sun Jul 22, 2012 10:14 am
ive got build r11627 on sd card and hdmi output works perfectly, but when i use composite video the pictures all sorts of strange colours and lines, have i got a dodgy lead or am i doing something wrong, Thanks!
Posts: 2
Joined: Sun Jul 22, 2012 10:09 am
by redhawk » Sun Jul 22, 2012 1:33 pm
Do you have sdtv_mode=2 in your config.txt file it's possible you're experiencing NTSC mode.
The composite video technology isn't great (dot crawling and chromatic artifacts) unfortunately the PI's video seems a lot worse than other composite devices I own.

RIchard S.
User avatar
Posts: 3328
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by Jim JKla » Sun Jul 22, 2012 2:31 pm
If you have the option do a blind login using ssh with something like putty (there's info on the wiki) It will give you a stable screen while you adjust settings.

The instructions on the wiki are at noob level so disregaurd any temptation to feel patronised it is a necessary evil to keep the noob community on board. :D
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 2099
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by mark120 » Sun Jul 22, 2012 6:10 pm
thanks, yeah i have sdtv_mode=2 in config, is there a setting within the xmbc gui im not seeing because the first openelec image comes up fine while booting but as soon as i get to xmbc menu it all goes wrong
Posts: 2
Joined: Sun Jul 22, 2012 10:09 am
by redhawk » Sun Jul 22, 2012 6:36 pm
If your picture dies as soon as XBMC starts then there is probably something wrong with your build, if it happens when you try to watch videos then that's something else.
I seem to recall having problem with composite video although it was set to 720x576 in the system preferences the picture would go bad unless I change to HD mode and then back to 720x576.
You also need to set your audio output to 2.0 mode otherwise the audio is streamed via HDMI and not the headphone jack.

Richard S.
User avatar
Posts: 3328
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by aspoon » Sat Aug 04, 2012 4:50 am
Think I have it solved. I downloaded r11707 from http://openelec.thestateofme.com/, configured everything via HDMI, then rebooted via composite video. This gave me the same outcome as described above.

Dug around a bit. (see http://noopsa.blogspot.com/2012/08/openelec-on-raspberry-pi-with-composite.html) You'd eventually have to ssh into the OpenELEC installation and disable CEC to get it to work:

  • ssh into openelec as root
  • edit /storage/.xbmc/userdata/peripheral_data/rpi_2708_1001.xml
  • disable it by changing the value for the "enabled" setting from "1" to "0"
  • save and reboot

Alvin
Posts: 2
Joined: Sat Aug 04, 2012 4:35 am