broken kernel image?


5 posts
by chmurli » Fri May 25, 2012 8:20 pm
Hi,
today I have installed arch arm on raspi. Everything was ok, until first "pacman -Syu" (about 20 packages). Upgrade was looking properly, but raspberry didn't boot up after reboot. Now it cannot boot, "OK" not even blink :/.

kernel_emergency.img and kernel_debug.img work but default kernel.img dont :/.
I think it is "raspberrypi-firmware-20120522" package fault. Just look at http://mirror.archlinuxarm.org/arm/alarm/
Why there is no new kernel.img in "raspberrypi-firmware-20120522-1-any.pkg.tar.xz" or in "raspberrypi-firmware-20120418-2-any.pkg.tar.xz"? There are new emergency and debug images.
Anyone tried install this new firmware upgrade?
Posts: 8
Joined: Sat May 19, 2012 8:38 pm
by chmurli » Sat May 26, 2012 6:52 am
Ok, apperently I was right.

On https://github.com/raspberrypi/firmware there is new kernel.img which is not included to arch packages! OMG, why? I replaced kernel.img and system boot (only hdmi video dont work now :/).
Posts: 8
Joined: Sat May 19, 2012 8:38 pm
by pepedog » Sat May 26, 2012 8:40 am
The kernel is in package linux-raspberrypi, as are modules
Have asked for kernel and firmware to be rebuilt, guess our builder is busy
Posts: 958
Joined: Fri Oct 07, 2011 9:55 am
by chmurli » Sat May 26, 2012 2:17 pm
pepedog wrote:The kernel is in package linux-raspberrypi, as are modules
Have asked for kernel and firmware to be rebuilt, guess our builder is busy

You are right. This package has been updated together with firmaware so it should work.
I have reinstalled linux-headers-raspberrypi, linux-raspberrypi, raspberrypi-firmware packages and now system boots up correctly. But still no hdmi, must investigate it futher.
Posts: 8
Joined: Sat May 19, 2012 8:38 pm
by pepedog » Sun May 27, 2012 5:48 pm
Delete /boot/config.txt file
Posts: 958
Joined: Fri Oct 07, 2011 9:55 am