Debian ARM on Raspberry Pi


136 posts   Page 2 of 6   1, 2, 3, 4, 5, 6
by vodor48 » Fri Mar 23, 2012 6:34 pm
Thx rurwin!

It's Work!:)
Posts: 3
Joined: Thu Mar 22, 2012 9:45 am
by Joe Schmoe » Fri Mar 23, 2012 7:22 pm
Note, incidentally, that the "you're a windows person, we'll give you a Linux virtualbox to run on your windows system, then you run QEMU under Linux (as God intended it to be run) to run the Pi simulation" really isn't necessary anymore.

If I can get it to run  effectively directly under Windows (using QEMU for Windows), then anyone can.  It wasn't really that hard.  I was a little daunted at first, but really it's no harder running QEMU under Windows than it is to run it under Linux.
Never answer the question you are asked. Rather, answer the question you wish you had been asked.

- Robert S. McNamara - quoted in "Fog of War" -
Posts: 2510
Joined: Sun Jan 15, 2012 1:11 pm
by rmm200 » Tue Mar 27, 2012 3:01 am
The Debian package includes Geany, but not "make" or "xterm" which Geany uses. I suggest including those two packages also. Kind of cool seeing Geany open an xterm window and showing my Ruby execution. apt-get install works for both.
Posts: 259
Joined: Sat Mar 03, 2012 10:25 pm
by Chris.Rowland » Wed Mar 28, 2012 11:16 am
I'm having a problem with the root password both using the GUI and using the su command.

In both cases I get a password prompt but nothing I have tried works.  It gives the authentication failure message.  I thought the default root password was suse.

This is using the debian6-17-02-2012.img image, zImage_3.1.9 and qemu-windows-1.0.1 - on a Windows system.

sudo works and does not require a password.

Thanks for any help,
Posts: 239
Joined: Thu Jan 12, 2012 5:45 pm
by grumpyoldgit » Wed Mar 28, 2012 11:19 am
id = pi

password = suse

Has worked for me.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by grumpyoldgit » Wed Mar 28, 2012 11:20 am
I don't think you need su.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by Chris.Rowland » Wed Mar 28, 2012 11:28 am
?
Posts: 239
Joined: Thu Jan 12, 2012 5:45 pm
by grumpyoldgit » Wed Mar 28, 2012 11:44 am
Debian is like Ubuntu. You don't get direct access to root. The account is locked. Just sudo. I am sure someone can explain this better than me.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by grumpyoldgit » Wed Mar 28, 2012 11:51 am
Actually, sudo su will get you there.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by Chris.Rowland » Wed Mar 28, 2012 12:29 pm
Is this what stops applications run from the LXDE GUI from getting root access?
Posts: 239
Joined: Thu Jan 12, 2012 5:45 pm
by grumpyoldgit » Wed Mar 28, 2012 12:36 pm
Perhaps. I seem to recall having difficulties installing software on a couple of occasions.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by jojopi » Wed Mar 28, 2012 1:21 pm
The sudo security model is superior because it does not depend on the secrecy of a shared password.  Also, it allows precise control of which users and groups can run what commands, and it has good logging.

But if you do want a root password, you can set one with "sudo passwd root".

In any case, it is really not recommended to log in to the GUI as superuser.  Log in as a regular user and escalate privileges only when required.
User avatar
Posts: 1960
Joined: Tue Oct 11, 2011 8:38 pm
by Chris.Rowland » Wed Mar 28, 2012 1:42 pm
I'm not trying to log onto the IDE as a superuser I enter the user name and password (pi/suse). This give me a prompt with a $ which I think means normal user.

I type startx and get the LXDE desktop.

Then, in the LXDE desktop I select  - Gparted

And I get a window headed "Enter the administrative password" (sic) There is a place to type a password.

What do I type there?

It looks like this:

Posts: 239
Joined: Thu Jan 12, 2012 5:45 pm
by rurwin » Wed Mar 28, 2012 2:03 pm
You type your password: suse
User avatar
Forum Moderator
Forum Moderator
Posts: 2903
Joined: Mon Jan 09, 2012 3:16 pm
by Chris.Rowland » Wed Mar 28, 2012 2:19 pm
And I get  the form back with a line:

"Incorrect password... try again".

After three tries I get a form - "Failed to run /usrsbin/gparted as user root."
Posts: 239
Joined: Thu Jan 12, 2012 5:45 pm
by grumpyoldgit » Wed Mar 28, 2012 2:52 pm
Interestingly I don't. What are you trying to do?

I suspect I have the same setup; Debian Squeeze in Quemu.

It's running on Lubuntu 11.10, whether that makes any difference, which I doubt.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by jamesh » Wed Mar 28, 2012 3:02 pm
Have you tried password : raspberry
Soon to be unemployed software engineer currently specialising in camera drivers and frameworks, but can put mind to most embedded tasks. Got a job in N.Cambridge or surroundings? I'm interested!
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 11541
Joined: Sat Jul 30, 2011 7:41 pm
by Chris.Rowland » Wed Mar 28, 2012 3:14 pm
just tried it, exactly the same, incorrect password.

But I'm in!

I used the line that jojopi suggested, "sudo passwd root" and entered a password. That one works.

Total power is mine!

Thanks everyone.
Posts: 239
Joined: Thu Jan 12, 2012 5:45 pm
by rurwin » Wed Mar 28, 2012 7:54 pm
That's broken.

Gparted seems to want to escalate permissions itself and expects the root password. On a Debian system there is no such thing; the root password hash is "*" which is not the hash of anything -- nothing you can type will be a valid root password.

Gparted should have invoked some GUI form of sudo and so taken your user password. The workaround would have been to give the command "sudo gparted".

Your workaround -- to create a root password -- is also good, although it leaves your computer infinitesimally less secure and may lead to confusion when you are asked for a password.
User avatar
Forum Moderator
Forum Moderator
Posts: 2903
Joined: Mon Jan 09, 2012 3:16 pm
by jojopi » Wed Mar 28, 2012 9:20 pm
rurwin said:

Gparted seems to want to escalate permissions itself and expects the root password.

It is not GParted itself.  LXDE's menu system is using GKSu as a wrapper on graphical applications that need privilege.  GKSu supports using either su or sudo to gain privilege, but it is defaulting to su, which is the wrong choice for this image.

To fix it, run the following command and then restart LXDE:
gconftool-2 -\-type bool -\-set /apps/gksu/sudo-mode true

Note that this is a per-user setting, and it is the setting for the unprivileged user that is effective, so the configuration change should not be sudo'd.

Now the menu system will start privileged applications without asking for a password, just as sudo does.  Unless you also remove "Defaults exempt_group = users" from sudoers, in which case both will ask for your password, not root's.
User avatar
Posts: 1960
Joined: Tue Oct 11, 2011 8:38 pm
by error404 » Wed Mar 28, 2012 9:44 pm
You may run into similar issues with other packages, as Debian default is to set a root password and use su, not sudo.
Posts: 351
Joined: Wed Dec 21, 2011 11:49 pm
by vtraveller » Thu Mar 29, 2012 9:31 am
I don't know if anyone is interested, but I've just worked out how to get an rt2870 WiFi USB dongle working with debian.  Please excuse my nativity but until yesterday I'd never played with linux, rpi or debian.

As far as I can tell the distribution ends up with the wrong firmware (a 4k version of rt2870.bin rather than an 8k version).  If you replace the .bin file with a suitable good one, wifi leaps into life.

Here's a quick rune summary of what I did (sudo / su permitting):

# Install wireless
vi /etc/apt/sources.list
change "deb http://ftp.us.debian.org/debian squeeze main" to "deb http://ftp.us.debian.org/debian squeeze main contrib non-free"
aptitude update && aptitude install firmware-ralink wireless-tools
aptitude install wicd
cp /mnt/myusb/rt2870.bin /lib/firmware
reboot

# Connect to a WiFi network

startx

run wicd

# Connect at start-up
vi /etc/network/interfaces
auto wlan0
iface wlan0 inet dhcp
wpa-ssid "mynetworkname"
wpa-psk "mysecretpassphrase"

Hope it helps - caused me a little bit of a headache.  Same headache appears in the Fedora remix except all that needs patching there is rt2870.bin and then a reboot.

Apologies if this isn't useful / involved egg sucking.
Posts: 2
Joined: Thu Mar 29, 2012 9:06 am
by jamesh » Thu Mar 29, 2012 9:52 am
Just for completeness, there are other firmwares for other wifi adapters...

For a 3Com I have

sudo apt-get install zd1211-firmware

For a Sumvision N dongle

sudo apt-get install firmware-realtek

Also, if you are using a WPA network on the command line, you may need to install wpasuplicant, and do some jiggery pokery including setting a psk key and creating a conf file. Then grab a DHCP lease using dhclient (I think).
Soon to be unemployed software engineer currently specialising in camera drivers and frameworks, but can put mind to most embedded tasks. Got a job in N.Cambridge or surroundings? I'm interested!
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 11541
Joined: Sat Jul 30, 2011 7:41 pm
by vtraveller » Thu Mar 29, 2012 10:20 am
True about the wpasuplicant.  I think wicd does a chunk of the magic for you.  Certainly I had everything I needed after installing it.
Posts: 2
Joined: Thu Mar 29, 2012 9:06 am
by jamesh » Thu Mar 29, 2012 10:56 am
Yes, I think wicd does a lot of the hard lifting, otherwise there are quite a few command lines to type in, at least for setup.
Soon to be unemployed software engineer currently specialising in camera drivers and frameworks, but can put mind to most embedded tasks. Got a job in N.Cambridge or surroundings? I'm interested!
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 11541
Joined: Sat Jul 30, 2011 7:41 pm

136 posts   Page 2 of 6   1, 2, 3, 4, 5, 6

 

Who is online
Users browsing this forum: No registered users and 3 guests