Wallpaper


7 posts
by Blank Reg » Sun Aug 05, 2012 11:38 pm
Hello, how would you change the wallpaper in Wheezy?
"All day every day, making tomorrow seem like yesterday."
User avatar
Posts: 2
Joined: Thu May 31, 2012 1:34 pm
by EtheB » Thu Aug 16, 2012 7:31 am
Blank Reg wrote:Hello, how would you change the wallpaper in Wheezy?


Hi Reg,

Right click on desktop, choose 'Desktop Preferences', select 'Wallpaper' and then choose one of the image files such as 'desktop-grub'.

Good luck!
If it doesn't fit, use a larger hammer, else fit a bigger fuse and 'tune' for maximum smoke :-)
Posts: 23
Joined: Sat Dec 24, 2011 6:43 am
Location: Rangiora, New Zealand
by Hubertus » Sun Oct 07, 2012 2:29 pm
Doesn't work.

When i Rightclick on the Desktop i can only choose between:

Terminal Emulator
Web Browser
--
Dekstops ->
--
obConfig
Reconfigure
Restart
--
Exit



I googled this for two days. seems like i am missing something very important here. please help me. i am using the normal raspian debian squeeze.
Posts: 1
Joined: Sun Oct 07, 2012 2:18 pm
by Briareos » Sun Nov 04, 2012 8:17 pm
Quickest way to change LXDE Wallpaper :
1) Open a terminal session
2) Type :
Code: Select all
pcmanfm --desktop-pref

You may also (for conveniance) want to create an icon on your desktop.
Proceed as follow :

1) Using you favorite editor (nano/vi/...), create a desktopchanger.desktop file, located in /home/pi/Desktop (assuming you're logged in as 'pi'...)
2) Copy/paste the following lines into this brand new file
Code: Select all
[Desktop Entry]
Type=Application
Name=Desktop Changer
GenericName=Desktop Changer
Comment=Change LXDE Desktop wallpaper
Categories=FileManager;Utility;Core;GTK;
Exec=pcmanfm --desktop-pref
Icon=/usr/share/icons/nuoveXT2/64x64/apps/xscreensaver.png
StartupNotify=true
Terminal=false
MimeType=x-directory/normal;inode/directory;

3) save and exit. That's all
--
Jean-Philippe
User avatar
Posts: 32
Joined: Sun Nov 04, 2012 8:03 pm
Location: Mulhouse, France
by Kvantti » Sun Dec 09, 2012 1:22 pm
Hi, I'm very new to Raspberry Pi as well as unix environment, and I'm having this same issue. It seems I somehow got Openbox to replace the normal X11 desktop manager? Trying the above solution didn't work, as it outputs

Cannot open display:


- and nothing else. Am I missing something here?
Posts: 2
Joined: Sun Dec 09, 2012 1:16 pm
by Kvantti » Sun Dec 09, 2012 2:29 pm
Ah, figured it out. You have to be inside X and use LXTerminal when doing the steps.

How I got rid of Desktop Preferences in the contextual menu in the first place and replaced the menu with that of the Openbox was foolhardily checking a checkbox labeled "Show menus provided by the window manager when desktop is clicked" under the Advanced tab in the Desktop Preferences. Apparently there is no GUI way of getting it to reverse afterwards, only that described above. Lesson learned.
Posts: 2
Joined: Sun Dec 09, 2012 1:16 pm
by royleith » Thu Dec 13, 2012 12:31 pm
Fancy losing your desktop context menus!

Anyway, I Googled the interweb and found this terminal command that gets the desktop preferences back.

pcmanfm --desktop-pref

Then untick the 'Show menus provided by the window manager when desktop is clicked' box.

Roy Leith
Posts: 7
Joined: Sun Jul 01, 2012 2:39 pm