LXMusic does it play mp3 files?


13 posts
by RussIT » Sat May 05, 2012 1:08 pm
Using the latest debian squeeze image I downloaded a free to play mp3 file to test the audio. I added to the LXMusic play list and hit the play button but nothing happens?

Can LXMusic play mp3 files?

or is ther some configuration I need to do first

I have a monitor without sound via dvi from the hdmi port and headphones plugged in to the audio output jack
Posts: 28
Joined: Thu Jan 05, 2012 11:34 am
by JeremyF » Sat May 05, 2012 2:18 pm
I'm not sure but are the mp3 drivers (called "non-free" and sometimes have to be downloaded manually) included by default?
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 522
Joined: Wed Jan 25, 2012 9:06 pm
by RussIT » Sat May 05, 2012 2:42 pm
Update

sudo apt-get install vlc

I instaled video lan client and audo plays on the headphones :)

with the vlc player of course, LXMusic still does nothing
Posts: 28
Joined: Thu Jan 05, 2012 11:34 am
by grumpyoldgit » Sat May 05, 2012 2:44 pm
Any word on the playability of FLAC files?
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by JeremyF » Sat May 05, 2012 2:57 pm
RussIT said:


Update

sudo apt-get install vlc

I instaled video lan client and audo plays on the headphones :)

with the vlc player of course, LXMusic still does nothing



http://packages.debian.org/sea.....ywords=vlc

So VLC works on the Pi, as I had suspected a long time ago...

So, 2 questions:


  1. Playing accelerated-by-GPU video: Does VLC know to do that?

  2. I assume it automatically downloaded 1.1.3, not an unstable 2.0.1, right?

{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 522
Joined: Wed Jan 25, 2012 9:06 pm
by RussIT » Sat May 05, 2012 3:10 pm
It is vlc 1.1.3 but it hasnt managed to play a video file yet although I did glimps a picture for a few seconds on a home movie in mpg format
Posts: 28
Joined: Thu Jan 05, 2012 11:34 am
by JeremyF » Sat May 05, 2012 3:20 pm
Unless the video was encoded in Xvid or H264...it's not going to play period (the CPU will max out in less then a second)
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 522
Joined: Wed Jan 25, 2012 9:06 pm
by robotmad » Sat May 05, 2012 11:04 pm
Tip we picked up from somewhere else to enable the audio (ASLA) driver:

sudo modprobe snd_bcm2835

Then LXMusic played MP3 files OK.
Posts: 3
Joined: Mon Mar 19, 2012 5:49 pm
by Mortimer » Tue Jun 19, 2012 11:33 pm
To get LXMusic to work I had to install decoders. I did the following:

Code: Select all
sudo apt-get install xmms2-plugin-all


This installs a lot of decoders*, many of which I am unlikely to ever use, so being more selective could save some space on RPi using smaller SD-Cards.

* Including:
MPeg layers 1, 2 and 3
Vocoder
Vorbis
MP4
FLAC
User avatar
Posts: 710
Joined: Sun Jun 10, 2012 3:57 pm
by SN » Fri Jun 22, 2012 12:33 pm
Thanks for this little gem - Pi R1 is sat behind my Big Plasma TV throwing media out on it.

R1 is running Debian Wheezy on an Aldi 8Gb card with this update hooked up via ethernet
Steve N – binatone mk4->intellivision->zx81->spectrum->cbm64->cpc6128->520stfm->pc->raspi ?
User avatar
Posts: 1009
Joined: Mon Feb 13, 2012 8:06 pm
Location: Romiley, UK
by AndrewS » Fri Jun 22, 2012 12:58 pm
JeremyF wrote:Playing accelerated-by-GPU video: Does VLC know to do that?

At this stage AFAIK only omxplayer and the various XBMC distros know how to play hardware-accelerated video.
User avatar
Posts: 3021
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
by dannyberlin » Fri Jun 22, 2012 9:46 pm
robotmad wrote:Tip we picked up from somewhere else to enable the audio (ASLA) driver:

sudo modprobe snd_bcm2835

Then LXMusic played MP3 files OK.

Thanks, that was helpful! I was going nuts as I couldn't get to play any music for my first steps.
:D
Posts: 1
Joined: Fri Jun 22, 2012 9:42 pm
by rocketero » Mon Feb 11, 2013 4:27 pm
I get audio with omxplayer, guayadeque, lxmusic.

I don't get any audio with audicious, vlc. I don't know why vlc such a nice app don't get audio output, I went into preferences and changed all kind of audio out and didn't get any sound.
Posts: 64
Joined: Wed Jul 11, 2012 5:45 pm