USB Ethernet adapters


6 posts
by Neil Johnson » Mon Jun 18, 2012 4:25 pm
Hi,

I would like to add a 2nd Ethernet adapter to my RPi via USB.

Has anybody got any suggestions of known working ones?

I've looked @ http://elinux.org/RPi_VerifiedPeriphera ... t_adapters

And the section is empty :(

Thanks...
Posts: 2
Joined: Tue Aug 30, 2011 8:59 am
by blurp » Fri Jun 22, 2012 10:07 am
Hello,

i tried the "Wintech USB 2.0 LanCard Model: LAU-15 (CK0049C) successful.
They are working with the mcs7830 driver.

I dont know if the (unmodified) RPi can provide enough power.
On my RPi i shortened both USB-fuses and use an unfused separate power supply/input (5V 1,5A).

Good luck, and

Best Regards
Posts: 11
Joined: Tue Jun 05, 2012 2:38 pm
by Neil Johnson » Mon Jun 25, 2012 10:23 am
Hi,

Thanks for the suggestion. I'll look in to it.

Cheers...
Posts: 2
Joined: Tue Aug 30, 2011 8:59 am
by mrraspberrypi » Tue Sep 25, 2012 2:43 am
Just bought a Pluscom usb to ethernet adapter off ebay (item id: 220708690400). Plugged it in and red light is on. Ifconfig shows eth1 and eth0 in the terminal window. But no data being transmitted (dont know if this info helps but shows status '....RUNNING MULTICAST...'). How can I trouble shoot this? Do I need a specific driver using apt-get?
Posts: 10
Joined: Tue Sep 25, 2012 2:37 am
by mrraspberrypi » Sat Sep 29, 2012 11:03 am
ok so my quest to build a traffic shaper (using wondershaper) resulted in me having to enable the dhcp and stuff, so from command prompt:

leafpad /etc/networks/interfaces

then added these lines to the file, saved and rebooted:

allow-hotplug eth1
iface eth1 inet dhcp

now i can ping the router and get a response but getting 'DNS can't resolve' error message from a browser
Posts: 10
Joined: Tue Sep 25, 2012 2:37 am
by mrraspberrypi » Sat Sep 29, 2012 12:12 pm
all working with dhcp on all interfaces....

sudo leafpad /etc/network/interfaces -->

auto lo
auto eth0
auto eth1

iface lo inet loopback
iface eth0 inet dhcp
iface eth1 inet dhcp
allow-hotplug eth0
allow-hotplug eth1

allow-hotplug wlan0
iface wlan0 inet manual
wpa- roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp


once saved then restart your interfaces like this -->

sudo /etc/init.d/networking restart
Posts: 10
Joined: Tue Sep 25, 2012 2:37 am