Camera module on Arch Linux?


13 posts
by silentsnake » Tue May 21, 2013 7:49 pm
Hi there,

my camera module will be delivered tomorrow, so I am curious if it will work on Arch Linux at the moment?

Thanks for information.
Posts: 7
Joined: Tue May 21, 2013 7:46 pm
by towolf » Tue May 21, 2013 9:19 pm
Yes. Add /opt/vc/bin to your path and add these lines to your /boot/config.txt
Code: Select all
gpu_mem=128
start_file=start_x.elf
fixup_file=fixup_x.dat

optionally
Code: Select all
disable_camera_led=1
Posts: 388
Joined: Fri Jan 18, 2013 2:11 pm
by silentsnake » Tue May 21, 2013 10:06 pm
Perfect. Thank you! I will try this out as soon as I get my hands on the camera.
Posts: 7
Joined: Tue May 21, 2013 7:46 pm
by CatherineH » Sat Sep 21, 2013 1:41 am
I did this, and borked my installation (it just hangs at the raspberry pi image).

I'm guessing I was either supposed to install X first, or that I was supposed to comment out the other gpu_mem lines in config.txt... Any possible explanations would be helpful. Meanwhile I'm going to mount my SD card on another arch installation and see if can edit config.txt without borking it further.
Posts: 7
Joined: Sat Sep 21, 2013 1:35 am
by towolf » Sat Sep 21, 2013 12:39 pm
CatherineH wrote:I did this, and borked my installation (it just hangs at the raspberry pi image).

I'm guessing I was either supposed to install X first, or that I was supposed to comment out the other gpu_mem lines in config.txt... Any possible explanations would be helpful. Meanwhile I'm going to mount my SD card on another arch installation and see if can edit config.txt without borking it further.


Well I’ve set up another Arch system with camera attached and changing the gpu values was not needed.

The Arch image by default uses the variable GPU memory allocation setup. And apparently that’s enough to let it allocate sufficient memory for the camera.

So you could just omit the gpu_mem line.

Also, you can edit the config.txt from any computer with an SD reader, the file is on the FAT formatted /boot partition.
Posts: 388
Joined: Fri Jan 18, 2013 2:11 pm
by towolf » Sat Sep 21, 2013 12:39 pm
And you do not need Xorg if you do not want it.
Posts: 388
Joined: Fri Jan 18, 2013 2:11 pm
by CatherineH » Sun Sep 22, 2013 1:36 pm
Alright, so it's definitely the line

Code: Select all
start_file = start_x.elf


that is causing my alarmpi not to boot.

Running without those lines gives me the error that the camera is not enabled. I'm assuming it needs some codec from start_x.elf. According to pacman everything is up to date and start_x.elf and fixup_x.dat are in /boot. So I guess this is a separate issue.
Posts: 7
Joined: Sat Sep 21, 2013 1:35 am
by towolf » Sun Sep 22, 2013 10:41 pm
If you remove the references in the first post to .elf and .dat files and add this line, does it work then?

Code: Select all
start_x=1
Posts: 388
Joined: Fri Jan 18, 2013 2:11 pm
by Seiduna » Thu Feb 20, 2014 1:40 pm
hello all,

(I got my camera module hu-hey!!)

ehm, I have arch on rpi, and I added 3 lines from above,
so far so good I guess,
but in /dev/ there is no video* ....?
now what?

also, cli software, raspivid/still is not in arch repo
(I am also new with arch, but I need space on sd therefore arch)
I am going to use ffmpeg, but no /dev/video*...

kind regards
Linux,
because I'd rather own a free OS
than steal one that's not worth paying for.
User avatar
Posts: 22
Joined: Wed Nov 20, 2013 4:12 pm
by towolf » Fri Feb 21, 2014 4:09 pm
You need to load the v4l2 driver manually for /dev/video0 to show up.

Code: Select all
modprobe bcm2835-v4l2


The raspi* tools are in /opt/vc/bin. Add this to your PATH in e.g. /etc/profile

Code: Select all
PATH="$PATH:/opt/vc/bin"


You seem to have missed that.
Posts: 388
Joined: Fri Jan 18, 2013 2:11 pm
by Seiduna » Sat Feb 22, 2014 8:00 am
hello towolf,

oh man, thanks, driver loaded and shooting!
follow up Q on that, is there a way to do that on boot?

big time Q:
-how does gpu_mem efects camera module?
-if I have camera module in /dev/video0 will ffmpeg lack behind raspivid (as stated here)?


as I mentioned, I am new to arch so I already have raspistill/vid,
as you said it is in /opt/vc/bin directory, i did not know existed
(I am fairly new to gnu/linux, but PATH is getting bigger, khaha)

kind regards
Linux,
because I'd rather own a free OS
than steal one that's not worth paying for.
User avatar
Posts: 22
Joined: Wed Nov 20, 2013 4:12 pm
by towolf » Sat Feb 22, 2014 4:51 pm
Seiduna wrote:hello towolf,

oh man, thanks, driver loaded and shooting!
follow up Q on that, is there a way to do that on boot?


Put it the module name into a file under /etc/modprobe.d

big time Q:
-how does gpu_mem efects camera module?


I think you need minimum 64M

-if I have camera module in /dev/video0 will ffmpeg lack behind raspivid (as stated here)?


That snippet is talking about the *user space* v4l driver that was advertised here earlier. The official kernel mode driver is structured differently and it exposes most of the functionality of raspivid minus some special features like segmented writing or listening to trigger signals. Much of that can be achieved differently with software that supports V4L natively. For example, you can write segments using ffmpeg -f ssegment.
Posts: 388
Joined: Fri Jan 18, 2013 2:11 pm
by Seiduna » Sat Feb 22, 2014 9:05 pm
hello towolf,

I set gpu_mem and set module in /etc/modules-load.d/raspberrypi.conf (as I tabbed away) and module is now loaded at boot.
I 'wrote' some ffmpef while ago, for converting to .ogg,so now I can put them in use for my camera board too!

to wolf, ...houuuUUUUUUU!!!UUUUuuulll...

man, thanks a bunch!
Linux,
because I'd rather own a free OS
than steal one that's not worth paying for.
User avatar
Posts: 22
Joined: Wed Nov 20, 2013 4:12 pm