Can't install Samba on Raspbian


9 posts
by scorp » Fri Oct 19, 2012 10:32 pm
Hello,
Today I tried to install Samba and have this
Code: Select all
pi@raspberrypi ~ $ sudo apt-get install samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
samba is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up samba (2:3.6.6-3) ...
[FAIL] Starting Samba daemons: nmbd failed!
invoke-rc.d: initscript samba, action "start" failed.
dpkg: error processing samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

This is actually second attempt. First one had the same failure. I did run update&upgrade but only after trying to install samba. So after realising this mistake i removed samba, run update&upgrade then installed samba and it failed again the same way. And /etc/samba doesn't exist after installation although samba installes
Posts: 96
Joined: Tue May 29, 2012 6:21 pm
by texy » Sat Oct 20, 2012 9:09 pm
I don't its just samba you need to install, so try :

Code: Select all
sudo apt-get install samba samba-common-bin


Texy
"2.8inch TFT LCD + Touch screen" add-on boards for sale here :
http://www.raspberrypi.org/phpBB3/viewtopic.php?f=93&t=65566
50p goes to the Foundation ;-)
Forum Moderator
Forum Moderator
Posts: 2410
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England
by elatllat » Tue Oct 23, 2012 10:34 am
might be file system corruption due to over clocking, try it on a fresh install. (I think texy fails to understad what apt is; not dpkg)
Posts: 1212
Joined: Sat Dec 17, 2011 5:05 pm
by scorp » Tue Oct 23, 2012 12:04 pm
Unfortunately system is on HDD and few things running so I decided not to do fresh install. Better to find different solution for my task - will share files via miniDLNA, they are media files which is good. I use only 800MHz overclock. Thanks for suggestions.
Posts: 96
Joined: Tue May 29, 2012 6:21 pm
by texy » Tue Oct 23, 2012 12:33 pm
elatllat wrote:might be file system corruption due to over clocking, try it on a fresh install. (I think texy fails to understad what apt is; not dpkg)



Well yeah, you could be correct. I was just following the Pi wiki on installing a NAS with samba here :
http://elinux.org/R-Pi_NAS

Texy
"2.8inch TFT LCD + Touch screen" add-on boards for sale here :
http://www.raspberrypi.org/phpBB3/viewtopic.php?f=93&t=65566
50p goes to the Foundation ;-)
Forum Moderator
Forum Moderator
Posts: 2410
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England
by scorp » Tue Oct 23, 2012 12:36 pm
texy wrote:
elatllat wrote:might be file system corruption due to over clocking, try it on a fresh install. (I think texy fails to understad what apt is; not dpkg)



Well yeah, you could be correct. I was just following the Pi wiki on installing a NAS with samba here :
http://elinux.org/R-Pi_NAS

Texy

Sorry, I didn't reply on your message. I did try to run both samba & samba-common-bin in one line or separately, same result :(
Posts: 96
Joined: Tue May 29, 2012 6:21 pm
by NewPi » Tue Nov 06, 2012 6:45 am
Start from scratch using instructions at - http://www.megaleecher.net/Adding_External_USB_Disk_Drive_Storage_On_RasPi. These worked for me twice, last time two days ago with newest official wheezy built.
Raspberry Pi Howto, Tips, Tricks and Tools -> http://bit.ly/RPiTricks
Posts: 66
Joined: Sat Aug 18, 2012 2:52 pm
by spannernick » Thu Oct 23, 2014 2:00 pm
I have a problem too...

I get this after typing

Code: Select all
sudo apt-get install samba-common-bin


Code: Select all
unable to locate package samba-common-bin


What do I need to do to sort this out..?
Posts: 6
Joined: Sun Oct 12, 2014 11:50 am
by RaTTuS » Thu Oct 23, 2014 2:04 pm
WARNING thread necro

what does
sudo atp-get update && sudo apt-get upgrade
sudo apt-get install samba

say
http://www.catb.org/esr/faqs/smart-questions.html <- ask smart Questions
"That's not right, the badgers have moved the goalposts."
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
User avatar
Posts: 5339
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK