RFXtrx433


9 posts
by iganin » Thu Aug 09, 2012 9:11 pm
Hi,
I am searching for a good solution to create my home automation system.
I like a lot RFXtrx433 http://www.rfixcom.com/transceivers.htm#Transceiver.
It has a decent price and supports numerous sensors and devices.
But i see two issues.
The first is there is no official support FTDI USB driver for ARM processors.
I saw in this forum some persons has an issue with it.
Secondly, i don't have any ideas how to work with this device. Scripts? how?

I will be happy to get any useful information.

Thanks a lot!
Posts: 10
Joined: Thu Aug 09, 2012 8:35 pm
by oxilor » Thu Sep 13, 2012 5:12 am
Hi iganin! I found RFXtrx433 and I'd like know how to work with this device. You understood how to work with RFXtrx433 during this time?
Posts: 1
Joined: Thu Sep 13, 2012 4:51 am
by ahpcal » Wed Sep 19, 2012 1:42 pm
I bought a USB RFXtrx433 433.92MHz transceiver and attached to my Raspberry Pi.
It works perfectly !!!! :D :D :D
I installed Domotiga (http://tickett.wordpress.com/2012/07/15 ... -sd-image/) that supports RFXCom.
I can see the temperature sensors Oregon Scentific and the power consumption (OWL CM119).
I have also attached a USB controller CM15 interface to control X10 modules.
Posts: 2
Joined: Wed Sep 19, 2012 1:29 pm
by dauhee » Wed Sep 19, 2012 5:17 pm
I was considering the RFXtrx433, but got an older version BBSB kit ( online controller, 6 plug sockets + motion detector) for less than the RFX price. Can do some nice hacking with it:
http://martgadget.blogspot.ie/2008_01_01_archive.html

Its not future proof, so may end up getting RFXtrx433 eventually to replace the BBSB controller (30 quid). My goal was to have a light RPi install and have full control of send/receive RF events . I must look at the DomotiGa code to see if there is anything I can "learn"
Posts: 59
Joined: Fri Sep 07, 2012 1:50 pm
by iganin » Thu Sep 20, 2012 4:01 am
ahpcal

This is very good news. 

Could you also please tell me why are you using the controller CM15. 
I thought that RFXCom can support X10 devices as well. 
Posts: 10
Joined: Thu Aug 09, 2012 8:35 pm
by ahpcal » Thu Sep 20, 2012 7:49 am
Hi,
Initially a year ago, I only had the CM15 to control X10 modules Marmitek (LM12, AM31, SW12).
A few weeks ago I bought RFXtrx433 that I will use for other (Marmitek MS13, temperature sensor Oregon, OWL, etc.).
Posts: 2
Joined: Wed Sep 19, 2012 1:29 pm
by Funky Diver » Thu Sep 20, 2012 8:13 pm
http://tickett.wordpress.com/2012/08/16 ... -domotiga/

Some super excellent information on this guys blog, including Debian image for download.
He's also got some pretty neat mods for using low cost sensors and wotnot.
Posts: 6
Joined: Thu Sep 20, 2012 8:11 pm
by mcjeff2002 » Tue Nov 13, 2012 3:18 pm
Hello

I have an RFXtrx433 plugged on my Raspberry .
It works fine at the beginning but after some hours I have network Lost.

It's seems it's a problem on USB Port. if anybody find a solution.

Thanks

Jeff
Posts: 1
Joined: Tue Nov 13, 2012 3:13 pm
by iganin » Tue Nov 13, 2012 10:48 pm
Hi,

Pls check the following link below.

I assume you can find more info/solution regarding the issue you have reported.
http://www.domoticaforum.eu/viewtopic.php?f=38&t=7763&start=15#p59034
Posts: 10
Joined: Thu Aug 09, 2012 8:35 pm