OpenELEC meets Raspberry Pi - part 1 (XBMC)


1233 posts   Page 47 of 50   1 ... 44, 45, 46, 47, 48, 49, 50
by Oyashiro » Fri Jun 29, 2012 4:49 pm
Hi, I tried openelec on my RPi with the latest build :
http://sources.openelec.tv/tmp/image/op ... 92.tar.bz2

It works with 720p mkv over the local network, but not for all of them. For some mkv, it only displays a black screen with no sound, even if the time bar is progressing correctly.

I tried an another build, but the same problem occurs, with the same files.

How can I fix this ?
Posts: 4
Joined: Mon Jun 25, 2012 5:20 pm
by smuggly » Fri Jun 29, 2012 10:57 pm
What Player, HDMI Or Composite Video?
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by Oyashiro » Fri Jun 29, 2012 11:09 pm
On a TV via HDMI (1280x768)
Posts: 4
Joined: Mon Jun 25, 2012 5:20 pm
by milhouse » Fri Jun 29, 2012 11:26 pm
Oyashiro wrote:Hi, I tried openelec on my RPi with the latest build :
http://sources.openelec.tv/tmp/image/op ... 92.tar.bz2

It works with 720p mkv over the local network, but not for all of them. For some mkv, it only displays a black screen with no sound, even if the time bar is progressing correctly.

I tried an another build, but the same problem occurs, with the same files.

How can I fix this ?


MKV is just a container - what video/audio codec didn't play? You can view this information with MediaInfo.
Posts: 551
Joined: Mon Jan 16, 2012 12:59 pm
by smuggly » Sat Jun 30, 2012 11:16 am
First I've heard of any probs with hdmi! I would try on a 1080P TV. I Can play almost all 1080P On mine Has A Few Probs W/ AC3 Audio(Just A guess). Only 2 movies thus far Of Over 1500 I Have HD. Some Avis i have Give me Trouble too!
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by mathewjenkinson » Sat Jun 30, 2012 11:47 am
does xbmc have a way to manually ssh into the Pi, add network shares over terminal and then see them inside XBMC?
Posts: 48
Joined: Mon Mar 26, 2012 8:13 am
by Paul Webster » Sat Jun 30, 2012 12:54 pm
Yes.
User avatar
Posts: 323
Joined: Sat Jul 30, 2011 4:49 am
Location: London, UK
by Oyashiro » Sat Jun 30, 2012 1:08 pm
The codec used is H264 for all of them.
Posts: 4
Joined: Mon Jun 25, 2012 5:20 pm
by smuggly » Sat Jun 30, 2012 4:48 pm
Where should the samba.conf file be on the new build? I see a samba.conf.sample? Should i just set parameters & rename samba.conf? Thanks smuggly
Also when i ssh 192. blah blah blah i get a key error warning?
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by milhouse » Sat Jun 30, 2012 5:32 pm
smuggly wrote:Where should the samba.conf file be on the new build? I see a samba.conf.sample? Should i just set parameters & rename samba.conf?


Yes.
Posts: 551
Joined: Mon Jan 16, 2012 12:59 pm
by smuggly » Sat Jun 30, 2012 5:47 pm
Thanks Very Much
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by mactalla » Sat Jun 30, 2012 9:25 pm
smuggly wrote:Also when i ssh 192. blah blah blah i get a key error warning?


The first time you SSH to a new host you'll receive a warning because your local machine doesn't have anything to compare it to.

If the host changes in the future you'll get the warning again. If you expected it to have changed since your last ssh (ie. you just upgraded to a new release) then this is expected. If you haven't changed things then this is a warning of a security issue (ie. man-in-the-middle attack). Not a likely event on your home network.

tl;dr answer 'yes' to accepting the fingerprint on your first ssh visit and don't be concerned if it asks again after you update openelec.
Posts: 17
Joined: Fri Dec 09, 2011 6:25 pm
by Doktor-X » Sat Jun 30, 2012 9:40 pm
i think i finaly get my pi to work with my 1080p mkv's without problem i have change settings in xbmc in system -> VIdeo from 60hz to 24 and now my videos are not stuttering ;)
User avatar
Posts: 22
Joined: Mon Sep 12, 2011 2:18 pm
by smuggly » Sun Jul 01, 2012 1:37 am
mactalla wrote:
smuggly wrote:Also when i ssh 192. blah blah blah i get a key error warning?


The first time you SSH to a new host you'll receive a warning because your local machine doesn't have anything to compare it to.

If the host changes in the future you'll get the warning again. If you expected it to have changed since your last ssh (ie. you just upgraded to a new release) then this is expected. If you haven't changed things then this is a warning of a security issue (ie. man-in-the-middle attack). Not a likely event on your home network.

tl;dr answer 'yes' to accepting the fingerprint on your first ssh visit and don't be concerned if it asks again after you update openelec.



Thanks. smuggly
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by Paul Thexton » Sun Jul 01, 2012 10:12 am
Hi all,

I might be coming across as a bit dim here, but I have a bluetooth dongle which I'm trying to use to pair a spare wiimote I have to use as a remote control for my RPi with OpenELEC, but I'm struggling to really see what I need to do.

If I put my wiimote in pair mode and run hcitool scan then it finds the wiimote fine, but the installation appears to be lacking the bluez-simple-agent utility and I can't see anything in the running xbmc to assist in pairing a device?

I've found other posts where people are using wiimotes with OE so I can only assume that I'm overlooking something simple?
Posts: 2
Joined: Sun Jul 01, 2012 10:10 am
by solardust » Tue Jul 03, 2012 12:04 am
I want video/movie output to go to HDMI and music to go to analog output (when TV is turned off). Is there any way to configure separate audio outputs for music and video?
If XBMC does not allow this what are workarounds, is there automatic switching for audio output(i.e. when hdmi is off switch to secondary/analog)?
Posts: 2
Joined: Thu Jun 21, 2012 6:25 pm
by humla » Tue Jul 03, 2012 8:03 pm
Here is the link to the latest release (r11476)
http://www.mediafire.com/?ljnitzxphs9t6o5

This release includes my own patch which fixes the issue with h264 main and baseline profile videos being played with ff-h264 instead of omx-h264 (eg youtube videos being played at 1fps). I have tested it myself and it works!
Posts: 30
Joined: Sat May 05, 2012 9:02 pm
by podly » Tue Jul 03, 2012 8:28 pm
humla wrote:Here is the link to the latest release (r11476)
http://www.mediafire.com/?ljnitzxphs9t6o5

This release includes my own patch which fixes the issue with h264 main and baseline profile videos being played with ff-h264 instead of omx-h264 (eg youtube videos being played at 1fps). I have tested it myself and it works!


Thanks, can you share patch only?
I use my own compilations, becouse I include LIRC GPIO driver patch in it [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=7798] so it would be nice to have your patch in it too.
User avatar
Posts: 38
Joined: Fri Jun 22, 2012 8:57 pm
by humla » Tue Jul 03, 2012 8:43 pm
podly wrote:
humla wrote:Here is the link to the latest release (r11476)
http://www.mediafire.com/?ljnitzxphs9t6o5

This release includes my own patch which fixes the issue with h264 main and baseline profile videos being played with ff-h264 instead of omx-h264 (eg youtube videos being played at 1fps). I have tested it myself and it works!


Thanks, can you share patch only?
I use my own compilations, becouse I include LIRC GPIO driver patch in it [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=7798] so it would be nice to have your patch in it too.

Not a problem, get it here.
http://www.mediafire.com/?1yrxyar1h0jjjtj

put it in here (if you dont already know)
OpenELEC.tv/packages/mediacenter/xbmc-rpi/patches/
Posts: 30
Joined: Sat May 05, 2012 9:02 pm
by podly » Tue Jul 03, 2012 8:48 pm
humla wrote:
podly wrote:
humla wrote:Here is the link to the latest release (r11476)
http://www.mediafire.com/?ljnitzxphs9t6o5

This release includes my own patch which fixes the issue with h264 main and baseline profile videos being played with ff-h264 instead of omx-h264 (eg youtube videos being played at 1fps). I have tested it myself and it works!


Thanks, can you share patch only?
I use my own compilations, becouse I include LIRC GPIO driver patch in it [http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=7798] so it would be nice to have your patch in it too.

Not a problem, get it here.
http://www.mediafire.com/?1yrxyar1h0jjjtj

put it in here (if you dont already know)
OpenELEC.tv/packages/mediacenter/xbmc-rpi/patches/


Thanks, starting compilation ;]
User avatar
Posts: 38
Joined: Fri Jun 22, 2012 8:57 pm
by sraue » Tue Jul 03, 2012 9:24 pm
humla wrote:Not a problem, get it here.
http://www.mediafire.com/?1yrxyar1h0jjjtj

put it in here (if you dont already know)
OpenELEC.tv/packages/mediacenter/xbmc-rpi/patches/


thanks much! added in https://github.com/OpenELEC/OpenELEC.tv ... 6eb29fafe1

Stephan
Posts: 143
Joined: Tue Feb 28, 2012 12:36 am
Location: Switzerland
by smuggly » Wed Jul 04, 2012 12:45 am
Is this included In The Latest IMG? If Not Can It Be Patched Easily? Thanks Smuggly

Just Seen It...
put it in here (if you dont already know)
OpenELEC.tv/packages/mediacenter/xbmc-rpi/patches/
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by humla » Wed Jul 04, 2012 8:13 am
smuggly wrote:Is this included In The Latest IMG? If Not Can It Be Patched Easily? Thanks Smuggly

Just Seen It...
put it in here (if you dont already know)
OpenELEC.tv/packages/mediacenter/xbmc-rpi/patches/

Now that it is in the openelec git tree u shouldn't have to do anything manually, just do a git pull and u should get the patch.

As for an img, wait for one by sparky, he goes daily IMG builds.
Posts: 30
Joined: Sat May 05, 2012 9:02 pm
by smuggly » Wed Jul 04, 2012 1:19 pm
Can I Just ssh in and put it in the folder described?
I get my image from the ( openelec the state of me) from the other person (sraue) here in the thread. It's probably in his img already? Thanks smuggly
Posts: 102
Joined: Fri Feb 03, 2012 6:09 pm
by podly » Wed Jul 04, 2012 1:52 pm
smuggly wrote:Can I Just ssh in and put it in the folder described?
I get my image from the ( openelec the state of me) from the other person (sraue) here in the thread. It's probably in his img already? Thanks smuggly


Nope, you can't just use ssh. You have to compile last release from git or download prepatched r11476 from here: http://www.mediafire.com/?ljnitzxphs9t6o5 or download latest r11487 or newer. This one http://openelec.thestateofme.com/r11487.img.zip should be ok.
User avatar
Posts: 38
Joined: Fri Jun 22, 2012 8:57 pm