How MUCH is XBMC/PVR working for others/you?


29 posts   Page 1 of 2   1, 2
by HarryL » Mon Nov 19, 2012 12:36 pm
I have been using Raspbmc/Openelec/Xbian for a few month now, and it is working fine with normal video files, i have also an HDhomerun network tuner..

the tuner works great in VLC both with and without tvheadend...

But i have only had part succes with it using the PVR addon/TVheadend client for XBMC..

EPG works, if XBMC dont save local on disk.
Viewing works somtime, and HD channels less.. but when working the quality is great.

what 'success' have others had here, please add in below.
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by HarryL » Tue Nov 20, 2012 2:41 pm
HarryL wrote:I have been using Raspbmc/Openelec/Xbian for a few month now, and it is working fine with normal video files, i have also an HDhomerun network tuner..

the tuner works great in VLC both with and without tvheadend...

But i have only had part succes with it using the PVR addon/TVheadend client for XBMC..

EPG works, if XBMC dont save local on disk.
Viewing works somtime, and HD channels less.. but when working the quality is great.

what 'success' have others had here, please add in below.



no one really? :? is my english that bad?! ;-/
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by topguy » Tue Nov 20, 2012 4:05 pm
How many have an network enable HD tuner anyway.
How many of those people own a PI.
How many of them again have tried XBMC on their PI.
And how many of them again actually reads the PI forums on a daily basis...

If you haven't started to feel alone yet, you should.. ;-)
User avatar
Posts: 654
Joined: Tue Oct 09, 2012 11:46 am
Location: Trondheim, Norway
by rbmadison » Wed Nov 21, 2012 12:23 am
I have the same setup. Rasbmc on the PI running tvheadend with an hdhomerun. I can successfully get tvheadend to stream to VLC from the hdhomerun but I see a black screen on liveTV on my rasbmc. I know hdhomerun and tvheadend are working because I can stream to my VLC on my windows PC but I cant get anything on the rasbmc to stream. I have the codec licenses installed also.
Posts: 4
Joined: Thu Feb 02, 2012 1:18 am
by NisseDILLIGAF » Wed Nov 21, 2012 5:51 am
I'm running Openelec with tvheadend client, and tvheadend-server running on my home server..
I currently have 'OpenELEC-RPi.arm-devel-20120919181951-r11955' on my Pi and the channels are working all the time..
Some of the channels freeze once in a while.. but not a really big problem..

But on newer builds the 'black screen' problem on live TV channels appear.. :(
Hope someone figures out what causes it..
Posts: 7
Joined: Tue Jan 17, 2012 12:24 pm
by HarryL » Thu Nov 22, 2012 9:51 am
Have just installed RaspBMC update with 3.6.7 linux kernel and XBMC beta1.. still black screen..

but my anysee USB tuner at tvheadend now work, in the matter that i now can scan for channels...and VLC work to!.

have 2 tunes
Hdhomerun
Anysee e30 C plus

I think it is OMXplayer that is the problem, sincs the lastest update my LIVETV won't work in XMBC.. works fine on XBMC nigtlybuilds for Mac..
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by Chivato » Fri Nov 23, 2012 8:21 pm
Hi there!

Using the latest build OpenELEC-RPi.arm-devel-20121123150508-r12563 and the HD picture is looking great. No more pixelated image on that resolution, only mpeg2 channels seem to give pixelated image but this isn't much of a problem.

I have connected XBMC through the PVR addon called Vu+ Duo and made sure to just select 1 provider, otherwise the Raspberry PI has to load 1000+ channels so that takes a lot of time.

I'm very satisfied with the picture quality and speed and even the EPG channellist is working great!

I use following config.txt which works best after a lot of testing;
initial_turbo=30
force_turbo=0
arm_freq=900
core_freq=333
sdram_freq=450
over_voltage=2
hdmi_ignore_cec_init=1
decode_MPG2=xxxxxxxxxxx
disable_overscan=1

The only thing which bothers me is that if you go throught the XBMC menu while playing TV everything slows down like crazy, but maybe that;s due to the limited memory/cpu speed of the Raspberry??? Anyway if someone has a solution for that, let me know!

All the best from The Netherlands!
Chivato
OpenELEC-r12563, Vu+ Client, Vu+ Duo, Powerplug connected
User avatar
Posts: 1
Joined: Fri Nov 23, 2012 8:03 pm
by rbmadison » Sat Nov 24, 2012 1:17 am
I was able to get channels to show up rarely my editing my config.txt but I still get a black screen most of the time. I think it something to do with the monitor and refresh rate. Any suggestions on what I could do to fix it?
Posts: 4
Joined: Thu Feb 02, 2012 1:18 am
by HarryL » Mon Nov 26, 2012 8:58 am
sometime it actually works more or less(live TV) the recordings always work(MKV)..

but now again after a reboot it does not work... it look like as stated pre post.. OMXplayer problem... with TS STREAM..

MPG2 seams to work less the MPG4, sometime the audio starts playing..only sound(only with MPG2)...

the "play video minimised" toggle in settings/TV/Video, seems to sometimes make it work..

i dont have any hard "evidence" like this work and this does not...

but i do know that both openelec(dev) and raspbmc (latest version) have this issue.
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by gogiman » Mon Nov 26, 2012 11:51 am
Hi guys,

any solution to omxplayer black screen problem?
Posts: 14
Joined: Tue Jul 10, 2012 6:55 am
by redhawk » Mon Nov 26, 2012 11:53 am
If omxplayer is blank then it's highly likely your file video codec is unsupported.

Richard S.
User avatar
Posts: 3343
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by gogiman » Mon Nov 26, 2012 11:56 am
Hi,

it is not always black. If I start/stop the stream more times, it eventually start to work....
Posts: 14
Joined: Tue Jul 10, 2012 6:55 am
by redhawk » Mon Nov 26, 2012 12:09 pm
What are you trying to stream??

Richard S.
User avatar
Posts: 3343
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by gogiman » Mon Nov 26, 2012 12:15 pm
It is in RASPBMC and the streams are from my local iptv provider. It should be mpeg2, but unfortunatelly I do not have more info about the stream format.
Is there some tool I could use to find the information?
Where can I find some omxplayer log files?
Posts: 14
Joined: Tue Jul 10, 2012 6:55 am
by redhawk » Mon Nov 26, 2012 12:26 pm
Press the 'o' key while in playback.

Richard S.
User avatar
Posts: 3343
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by HarryL » Mon Nov 26, 2012 12:43 pm
sorry but there are none channels that work all the time... and the recordings allways work afterwards...

im trying to "stream" DVB data MPG2/MPG4 video/audio... TS stream i gues.
using TVheadend as server works fine, it records....

my gues is that it is OMPplayer how it handels stream and where it get the data from, it works fine with http/rtsp/mms... MPEG 2/4 TS is not completely the same as normal MPG2/4..but should work and do sometimes...
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by HarryL » Mon Nov 26, 2012 1:52 pm
relatet post her: viewtopic.php?f=35&t=23815
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by HarryL » Tue Nov 27, 2012 2:28 pm
I will try an Mythtv solution soon, to see if it's the addon maybee...

anyone have this problem with mythtv?
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by gogiman » Tue Nov 27, 2012 7:05 pm
Hi,

this is what I get when switching channels with black screen:
18:47:02 T:3041370752 NOTICE: COMXPlayer: Opening: pvr://channels/tv/All TV channels/2.pvr
18:47:02 T:3041370752 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:47:02 T:2782553152 NOTICE: Thread COMXPlayer start, auto delete: false
18:47:02 T:2782553152 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 NOTICE: Creating InputStream
18:47:02 T:2782553152 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 NOTICE: Creating Demuxer
18:47:02 T:2782553152 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 WARNING: CDVDMessageQueue(audio)::Put MSGQ_NOT_INITIALIZED
18:47:02 T:2782553152 WARNING: CDVDMessageQueue(video)::Put MSGQ_NOT_INITIALIZED
18:47:02 T:2782553152 NOTICE: Opening video stream: 0 source: 256
18:47:02 T:2782553152 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 NOTICE: Creating video thread
18:47:02 T:2844783680 NOTICE: Thread COMXPlayerVideo start, auto delete: false
18:47:02 T:2782553152 NOTICE: Opening audio stream: 1 source: 256
18:47:02 T:2782553152 NOTICE: Creating audio thread
18:47:02 T:2853172288 NOTICE: Thread COMXPlayerAudio start, auto delete: false
18:47:02 T:2782553152 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 NOTICE: Opening video stream: 0 source: 256
18:47:02 T:2782553152 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 NOTICE: Opening audio stream: 1 source: 256
18:47:02 T:2853172288 NOTICE: OMXClock using video as reference
18:47:02 T:2782553152 NOTICE: Opening audio stream: 1 source: 256
18:47:02 T:2844783680 WARNING: CRenderManager::Configure - timeout waiting for previous frame
18:47:02 T:2844783680 NOTICE: Display resolution DESKTOP : 1280x720 @ 60.00 - Full Screen (16)
18:47:03 T:2853172288 NOTICE: OMXClock using audio as reference
18:47:03 T:2782553152 NOTICE: Opening video stream: 0 source: 256
18:47:03 T:2782553152 NOTICE: OMXClock using audio as reference
18:47:03 T:3041370752 NOTICE: Using GL_TEXTURE_2D
18:47:03 T:3041370752 NOTICE: GL: Using BYPASS render method
18:47:03 T:3041370752 NOTICE: GL: GL_ARB_texture_rectangle not supported and OpenGL version is not 2.x
18:47:03 T:3041370752 NOTICE: GL: Reverting to POT textures
Posts: 14
Joined: Tue Jul 10, 2012 6:55 am
by HarryL » Wed Nov 28, 2012 9:37 am
well setting TVheadend to record to "TS Pass-through" instead of MKV, and those file work fin to..(.ts).
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by HarryL » Thu Nov 29, 2012 10:11 am
Found this, seem to agree with me that it is an omxplayer problem?
https://github.com/opdenkamp/xbmc-pvr-addons/issues/93
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by HarryL » Wed Dec 05, 2012 8:17 am
The lastet XBMC seem to be working better.. but there is still some problems.. either codec or OMXplayer... or maybe the implementation of OMXplayer in XBMC that is the problem...

i have one thing i have not yet try'd. that is to use tvheadend directly with omxplayer, via URL/HTTP.. but dont have that much time theis days..

http://IP:9981/playlist
http://IP:9981/channels/playlist

use the address in the M3u file
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by HarryL » Fri Dec 07, 2012 7:30 am
well have some breakthrough, if i on a channel flip back and fourth are few times between channels, and look for when the "pause/play" icon "bllinks" between play and pause half a sec on each.. then the channel works...

what this means i dont know... :? but i gues it must be streaming problem then?
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark
by TomTorg » Fri Jan 11, 2013 12:24 pm
I am suffering same problems as you are having. On my other htpc I never had this problem, but my wife found a workaround.

1.Go to the channel you want to watch and get a black screen
2. press 'stop'
3. change channel
4. change back to the channel you want to watch, then you should get a picture :)

Seems like rasbmc misunderstand what type of stream livetv is. when you press stop, xnbc will try to recognize the stream codec again next time you zap the channel
Posts: 2
Joined: Fri Jan 11, 2013 12:05 pm
by HarryL » Fri Jan 11, 2013 2:11 pm
2 Model B 256MB / 2 Model B 512MB / Gertboard / HDhomerun,Anysee E30 C Plus DVB-C Tuner
Posts: 27
Joined: Mon Oct 01, 2012 12:12 pm
Location: Denmark