XBMC on Raspbian wheezy (install error)


14 posts
by save_jeff » Thu Sep 27, 2012 9:01 am
Hallo Board Members ;]

I'm using the latest image of wheezy (2012-09-18)
I want to install xbmc because omxplayer to simple is. but when i do so i get errors :

Code: Select all
pi@raspberrypi ~ $ sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xbmc : Depends: xbmc-bin (>= 2:11.0~git20120510.82388d5-1) but it is not installable
        Depends: xbmc-bin (< 2:11.0~git20120510.82388d5-1.1~) but it is not installable
        Recommends: python-qt3 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Is this an bug ? or did i forget to install something ?
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by cditty » Fri Sep 28, 2012 3:07 pm
I'm having the same problem.
Posts: 7
Joined: Fri Sep 28, 2012 3:05 pm
by notarat » Fri Sep 28, 2012 3:22 pm
If you're looking for XBMC on Pi have you tried Xbian yet?

I admit I like booting up to the command prompt first, then loading X more than booting to XBMC straight away, but at least with Xbian I can ssh into it from my other machine sitting next to it if I need to run commands
Posts: 106
Joined: Wed Sep 12, 2012 12:32 pm
by save_jeff » Fri Sep 28, 2012 7:24 pm
That s a good idea. But i want a full operating system optimized for speed and usage (apache2 mysql samba) with xbmc as an application. And xbian is optimized for xbmc.
I want to use the latest version of debian (wheezy)

A started an other thread because i tryed RaspbianXBMC
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by save_jeff » Fri Sep 28, 2012 7:28 pm
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by nIerSify » Thu Oct 11, 2012 11:32 am
save_jeff wrote:Hallo Board Members ;]

I'm using the latest image of wheezy (2012-09-18)
I want to install xbmc because omxplayer to simple is. but when i do so i get errors :

Code: Select all
pi@raspberrypi ~ $ sudo apt-get install xbmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xbmc : Depends: xbmc-bin (>= 2:11.0~git20120510.82388d5-1) but it is not installable
        Depends: xbmc-bin (< 2:11.0~git20120510.82388d5-1.1~) but it is not installable
        Recommends: python-qt3 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.



Is this an bug ? or did i forget to install something ?


Hi,

to correct this problem just deinstall xbmc and try to correct your dependencies. After you have installed all required libraries you should be able to install xbmc.

I had the same problem and fixed it that way....

Best regards
nIerSify
http://selfprogramming.bplaced.net
Posts: 65
Joined: Fri Sep 07, 2012 5:45 am
by save_jeff » Thu Oct 11, 2012 11:54 am
Ok, but how do i 'try to correct [...] dependencies' and 'install all required libraries'?
What commands do i have to use ?
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by nIerSify » Thu Oct 11, 2012 3:50 pm
save_jeff wrote:Ok, but how do i 'try to correct [...] dependencies' and 'install all required libraries'?
What commands do i have to use ?


If you use one of my versions, for example: https://sourceforge.net/projects/selfpr ... b/download

You can follow this guide for the installation process:

Code: Select all
sudo apt-get update

sudo apt-get install libplist1 libmicrohttpd10 libtinyxml2.6.2 libyajl2 libssh-4
libmysqlclient18 liblzo2-2 libfribidi0 libcurl3-gnutls liblockdev1 libpcrecpp0

sudo dpkg -i xbmc-20120917_1rpb-1_armhf.deb


To start it use either the script located here: http://selfprogramming.bplaced.net/inde ... /comments/

or just type: sudo /usr/lib/xbmc/xbmc.bin

Best regards
nIerSify
http://selfprogramming.bplaced.net
Posts: 65
Joined: Fri Sep 07, 2012 5:45 am
by save_jeff » Sat Oct 13, 2012 7:28 pm
Thank u for the answer. I will try this son. But i'm afraid because the last time it corupted the hole System and apt-get was complety messed up.
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by save_jeff » Sat Oct 13, 2012 7:52 pm
i installed all the libarys and that worked fine but at the line

Code: Select all
sudo dpkg -i xbmc_20121004-1_armhf.deb


it gave me that code :

Code: Select all
sudo dpkg -i xbmc_20121004-1_armhf.deb
Selecting previously unselected package xbmc.
(Reading database ... 65821 files and directories currently installed.)
Unpacking xbmc (from xbmc_20121004-1_armhf.deb) ...
dpkg: dependency problems prevent configuration of xbmc:
 xbmc depends on liblzo2-2; however:
  Package liblzo2-2 is not installed.
 xbmc depends on libfribidi0; however:
  Package libfribidi0 is not installed.
 xbmc depends on liblockdev1; however:
  Package liblockdev1 is not installed.

dpkg: error processing xbmc (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Errors were encountered while processing:
 xbmc
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by save_jeff » Sat Oct 13, 2012 8:13 pm
Then i installed :
liblzo2-2 , libfribidi0 and liblockdev1

Then it worked but after using
Code: Select all
sudo /usr/lib/xbmc/xbmc.bin


i got this error :
Code: Select all
pi@raspberrypi ~ $ sudo /usr/lib/xbmc/xbmc.bin
/usr/lib/xbmc/xbmc.bin: error while loading shared libraries: libpcrecpp.so.0: c                                      annot open shared object file: No such file or directory


What do i do know ?
Posts: 24
Joined: Thu Sep 27, 2012 8:49 am
by north3221 » Tue Nov 20, 2012 9:45 pm
save_jeff wrote:Then i installed :
liblzo2-2 , libfribidi0 and liblockdev1

Then it worked but after using
Code: Select all
sudo /usr/lib/xbmc/xbmc.bin


i got this error :
Code: Select all
pi@raspberrypi ~ $ sudo /usr/lib/xbmc/xbmc.bin
/usr/lib/xbmc/xbmc.bin: error while loading shared libraries: libpcrecpp.so.0: c                                      annot open shared object file: No such file or directory


What do i do know ?



Not sure if you solved this? What is it in Rasbian you are after? You could do what I did, see here:
http://www.raspberrypi.org/phpBB3/viewtopic.php?f=35&t=23051
Posts: 33
Joined: Fri Nov 16, 2012 6:06 pm
by StReSsCoOl » Tue Jan 29, 2013 2:17 am
simply install libpcrecpp0 with "sudo apt-get install libpcrecpp0"
Posts: 2
Joined: Fri Jan 11, 2013 3:49 am
by sluysen » Thu Apr 11, 2013 5:59 pm
I am going to give this a bump hence i'm stuck with the same error's

I received my Pi today. I have put wheezy on it. And now i'm trying to get XBMC on it aswell.

it should be just sudo apt-get install xbmc but it's not working.

The step's i have done so far:
sudo apt-get update (and dist-update and so one)

sudo apt-get install libplist1 libmicrohttpd10 libtinyxml2.6.2 libyajl2 libssh-4
libmysqlclient18 liblzo2-2 libfribidi0 libcurl3-gnutls liblockdev1 libpcrecpp0

--
Then the last step: sudo dpkg -i xbmc-20120917_1rpb-1_armhf.deb gives me an errormessage:

dpkg: error processing xbmc-20120917_1rpb-1_armhf.deb (--install):
cannot access archive: No such filke or directory
Errors were encountered while processing:
xbmc-20120917_1rpb-1_armhf.deb

It seems that this file is gone. what should I use to get xbmc running?
Posts: 1
Joined: Thu Apr 11, 2013 5:53 pm