Anyone Wanna Play Rise of the Triad?


5 posts
by hellguide » Sun Aug 05, 2012 4:41 pm
I saw that Rise of the Triad is getting a remake, so I downloaded the linux port source code and compiled it. Here is a tar.gz file containing the shareware files. There is a second folder containing the binary for the retail version however the retail versions wad files are not included. I have also included the source code that contains the readme with the appropriate credits.

download:
http://www.2shared.com/file/OSi1y-SL/rotttar.html

You must:
modprobe snd_bcm2835 #should be in your .bash_profile anyways
apt-get install libsdl1.2-dev libsdl-mixer1.2 xorg

in the shareware folder run:
startx ./rott

for the full version go inside the darkwar folder and run(requires wad files):
startx ./rott_darkwar


-Cole
Posts: 14
Joined: Thu Jun 21, 2012 12:18 am
by texy » Tue Aug 07, 2012 7:11 am
It was much better multiplayer deathmatch than single player - some of the weapons were awesome compared to Doom - drunken missile anyone ;)

Texy
"2.8inch TFT LCD + Touch screen" add-on boards for sale here :
http://www.raspberrypi.org/phpBB3/viewtopic.php?f=93&t=65566
50p goes to the Foundation ;-)
Forum Moderator
Forum Moderator
Posts: 2411
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England
by pygmy_giant » Mon Nov 05, 2012 5:47 pm
I found a RISC OS port of this that is supposed to work on the Pi but I can't get it to work:

http://www.riscos.info/index.php?title=Special:AWCforum&action=st/id281/Rise_of_the_Triad_%28ROTT%29_:_The_hunt_Begins_now_on_Raspberry_Pi_also

anyone else have better luck?
Posts: 1569
Joined: Sun Mar 04, 2012 12:49 am
by andPS2 » Wed Apr 03, 2013 2:02 pm
all i get is an error message:
Code: Select all
./rott_shareware
Rise of the Triad Startup  Version 1.4
 CD Version
Z_INIT: 8950000 bytes
IN_Startup: Mouse Present
Error, Could not find User file 'DARKWAR.WAD', ignoring file    Adding REMOTE1.RTS.
W_Wad: Wad Manager Started NUMLUMPS=12
W_GetNumForName: tables not found! Episode      = 0
Area         = 1
Posts: 17
Joined: Wed Apr 03, 2013 1:37 pm
by Oysterville » Fri Apr 05, 2013 12:52 am
Looks like it is missing the WAD files to run the game, which are basically the map files. Without WADs, you have no game.
Google is a helluva drug.
Posts: 54
Joined: Tue Feb 19, 2013 3:33 am