Porting libsoup


3 posts
by Gajanana » Tue Nov 06, 2012 9:45 am
Hi i am building libsoup and using glib library for that . But to remove "#error "Only <glib.h> can be included directly" this error i replaced all <glib/glibXYZ.h> with <glib.h> .

but i am now getting the error "/packages/external/libsoup-2.4.0/libsoup/soup-marshal.h:27:47: error: unknown type name 'GClosure' "
"/packages/external/libsoup-2.4.0/libsoup/soup-marshal.h:27:47: error: unknown type name 'GValue'

Pls help
Posts: 2
Joined: Tue Nov 06, 2012 9:38 am
by tufty » Tue Nov 06, 2012 12:08 pm
Sounds like you're missing other gnome libraries (or at least the headers), GObjects looks like a probable culprit.
Posts: 1330
Joined: Sun Sep 11, 2011 2:32 pm
by Gajanana » Wed Nov 07, 2012 4:58 am
yes actually missing thing is GObject only .but the problem is if i include any library the same error"#error "Only <glib.h> can be included directly" is coming only we can include glib.h .. so i tried to put "GObject.h" in glib.h but some other errors are coming.. I built Only lib soup library seperately then error is
"** (process:26727): ERROR **: initial handshake failed: -21
/bin/bash: line 4: 26727 Trace/breakpoint trap (core dumped) ${dir}$tst
FAIL: ssl-test"
Posts: 2
Joined: Tue Nov 06, 2012 9:38 am