Overclocking


915 posts   Page 2 of 37   1, 2, 3, 4, 5 ... 37
by jasjeet » Sun Jun 03, 2012 12:40 pm
Ive got mine to 900Mhz core, the Ram OC made it pretty unstable (tried 450mhz).
Openelec is more responsive, but how can i run some sort of benchmark to test stability?
Posts: 90
Joined: Thu May 31, 2012 6:00 pm
by shalo » Mon Jun 04, 2012 10:10 pm
dom wrote:These were my best setting:
over_voltage=6
arm_freq=1000
core_freq=500
sdram_freq=500

Running raspbian with those settings, and desktop/midori was pretty responsive.


I've not considered the gpu yet but is that core_freq correct? Seems like it might be a repeat of the sdram_freq and I'm curious what you have actually been running at with the gpu core with an over_voltage of 6.

I assume this is the most important sub setting relating to general performance/L2 cache, while the other sub settings are not yet in much use. Perhaps v3d_freq for future 3d apps?

"gpu_freq: Sets core_freq, h264_freq, isp_freq, v3d_freq together."
Posts: 74
Joined: Tue May 08, 2012 7:25 pm
by MegaGumbo » Sun Jun 10, 2012 2:09 pm
zomzilla wrote:950 arm
350 GPU
500 ram

No over volt

Absolutely fine. change that to all defaults and 1000 arm however, and it won't even boot.

Is there any ways I can check sdram and GPU frequencies? I know I can look at the bogomips from cpuinfo, but is there similar for the other clocks?


running "glxgears" from the mesa-utils package (Debian) shows an increase from 80 frames per 5 seconds to 99 frames per 5 seconds with your settings. I've also set init_emmc_clock=250000000, which offers a little more performance on the SD card. Rpi runs stable, not getting too hot. Midori is now usable.
Posts: 85
Joined: Mon Feb 13, 2012 4:45 pm
by dtud2 » Mon Jun 11, 2012 6:31 pm
Does the RPi hold the overclocking settings when changing to an SD card were the config.txt file isn't present or in its absence will factory settings be applied?
This is withstanding over_voltage=6 which I understand is irrevocable.
R Tape loading error, 0:1
Posts: 14
Joined: Thu May 31, 2012 10:02 pm
by itimpi » Mon Jun 11, 2012 6:38 pm
dtud2 wrote:Does the RPi hold the overclocking settings when changing to an SD card were the config.txt file isn't present or in its absence will factory settings be applied?
This is withstanding over_voltage=6 which I understand is irrevocable.

Not as far as I know - the config.txt has to be present and the over locking parameters only apply to the current run. Regarding the over-volting, I do not think this is remembered either. All that is remembered is that at some point you invoked over-volting (and voided your warranty).
Posts: 1034
Joined: Sun Sep 25, 2011 11:44 am
Location: Potters Bar, United Kingdom
by Lob0426 » Mon Jun 11, 2012 9:27 pm
I tried:
arm_freq=850
gpu_freq=350
sdram_freq=500
no overclock

Ran fine in debian, LXDE no problems. Ran Quake3 and crashed out into command line. Went to red power LED only. Rebooted fine. Wonder which one was the more likely culprit? SDRAM?
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1935
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by robwriter » Mon Jun 11, 2012 9:57 pm
Mine seems rock solid with ram at 500. I think I read there wasn't much room for GPU overclock so perhaps that's the culprit?
Posts: 108
Joined: Sat Feb 25, 2012 6:26 pm
by Nburnes » Mon Jun 11, 2012 11:53 pm
Lob0426 wrote:I tried:
arm_freq=850
gpu_freq=350
sdram_freq=500
no overclock

Ran fine in debian, LXDE no problems. Ran Quake3 and crashed out into command line. Went to red power LED only. Rebooted fine. Wonder which one was the more likely culprit? SDRAM?

I'm going with the GPU. Mine does the same thing at 350. Set it back to stock and it will run.
Posts: 23
Joined: Fri May 25, 2012 7:00 am
by JeremyF » Tue Jun 12, 2012 12:08 am
Nburnes wrote:
Lob0426 wrote:I tried:
arm_freq=850
gpu_freq=350
sdram_freq=500
no overclock

Ran fine in debian, LXDE no problems. Ran Quake3 and crashed out into command line. Went to red power LED only. Rebooted fine. Wonder which one was the more likely culprit? SDRAM?

I'm going with the GPU. Mine does the same thing at 350. Set it back to stock and it will run.

Hey Nburnes. Just a random thought, but you were the same Nburnes on iPod touch Fans a long time ago?
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 516
Joined: Wed Jan 25, 2012 9:06 pm
by Nburnes » Tue Jun 12, 2012 1:27 am
JeremyF wrote:
Nburnes wrote:
Lob0426 wrote:I tried:
arm_freq=850
gpu_freq=350
sdram_freq=500
no overclock

Ran fine in debian, LXDE no problems. Ran Quake3 and crashed out into command line. Went to red power LED only. Rebooted fine. Wonder which one was the more likely culprit? SDRAM?

I'm going with the GPU. Mine does the same thing at 350. Set it back to stock and it will run.

Hey Nburnes. Just a random thought, but you were the same Nburnes on iPod touch Fans a long time ago?

Same one there currently. o.o
Posts: 23
Joined: Fri May 25, 2012 7:00 am
by JeremyF » Tue Jun 12, 2012 12:42 pm
Nburnes wrote:Same one there currently. o.o

I don't know if you care, but back in around the 2009 and 2010 ish area, I was Gershmer. (That's enough off-topic posting now, please return to overclocking topic, future people)
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 516
Joined: Wed Jan 25, 2012 9:06 pm
by Lob0426 » Tue Jun 12, 2012 4:03 pm
When I bumped the GPU back to 350 I crashed out of Quake3 again. I will have to try something a little less or overvolt. I will not try overvolting until I have another RasPi to work with
next try at

gpu_freq=325

arm_freq=850
sdram_freq=500

seem to be working
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1935
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by Lob0426 » Wed Jun 13, 2012 5:58 am
stable so far at:
arm_freq=850
gpu_freq=325
sdram_freq=500
quake played just fine at these setting, no crash. I may push the arm-freq up a bit more.
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1935
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by MattHawkinsUK » Wed Jun 13, 2012 10:35 pm
I just wrote up my overclocking experiments here :
http://www.raspberrypi-spy.co.uk/2012/06/overclocking-benchmarking-the-raspberry-pi/

I'm playing it very safe and just wanted a slight increase in performance to start with. I created a Python script to give me something to benchmark the CPU performance against. I used some code to calculate prime numbers and I figured that was a good basic test to load the CPU and time how long it took to run.

With the CPU set to 800MHz I get an 11% increase in number crunching speed.
My Raspberry Pi blog and home of the BerryClip Add-on board : http://www.raspberrypi-spy.co.uk/
Follow me on Google+, Facebook, Pinterest and Twitter (@RPiSpy)
User avatar
Posts: 487
Joined: Tue Jan 10, 2012 8:48 pm
Location: UK
by mcfundash » Thu Jun 14, 2012 4:32 am
I have really pushed the limits today
After looking at the fact that most likely worse case scenario the life is reduced to ~2-4 years from probably ~20 years I took the plunge and overvolted. I don't want to risk extra fast death so I never went above 8 but I have been able to run semi-stable (usually its fine if it can get past boot with this) at these settings:

arm_freq=1125
gpu_freq=538
sdram_freq=513
over_voltage=8

I know they seem a little non-round but I'm still in the process of doing this and have been going by increments of 1 at this point. I found that almost everytime I changed the ram, it got unstable so I never went far from 500. I am very impressed that I was able to more than double the GPU and I'm not sure if anyone has gotten as far as this yet. Hopefully some people will have the guts to do this intense overvolting and see if they can get this far or farther! :D
Current best Overclock/volt:
arm_freq=1125
gpu_freq=538
sdram_freq=513
over_voltage=8
Posts: 3
Joined: Sat May 19, 2012 4:11 am
by AndrewS » Thu Jun 14, 2012 10:18 am
User avatar
Posts: 3626
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
by trn » Thu Jun 14, 2012 10:22 am
my config
arm_freq=850
sdram_freq=500
is unstable!

sdram is too high? or arm?
Posts: 46
Joined: Wed May 09, 2012 11:30 am
by AndrewS » Thu Jun 14, 2012 10:34 am
trn wrote:my config
arm_freq=850
sdram_freq=500
is unstable!

sdram is too high? or arm?

No way to tell, the only thing you can do is experiment. Different boards will have different upper limits.
User avatar
Posts: 3626
Joined: Sun Apr 22, 2012 4:50 pm
Location: Cambridge, UK
by dom » Thu Jun 14, 2012 12:41 pm
AndrewS wrote:Might be worth updating http://elinux.org/RPi_config.txt#Tested_values :?:


I think it needs more testing than just booting before adding to wiki. I don't believe quake will run with gpu_freq at 538...
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4030
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by Lob0426 » Thu Jun 14, 2012 5:25 pm
dom wrote:
AndrewS wrote:Might be worth updating http://elinux.org/RPi_config.txt#Tested_values :?:


I think it needs more testing than just booting before adding to wiki. I don't believe quake will run with gpu_freq at 538...


@dom has the right of it here. My RasPi crashed out of Quake3 at GPU=350. Of course I was not overvolting. I do not know if the over volt settings really help with the GPU.

We should establish at least some minimal requirements of what "stable" is.
Example:
number of successful boots at the frequencies (minimum 10).
Can enter LXDE 3 times without issues.
Can play quake3 for x number of minutes. Or quake3 demo.
Any other suggestions?

These are just examples, should not get too wild or this would become work not fun. The examples would give us a baseline for testing at stable. Mine has more than met these examples without over volting. I know where my GPU fails so far. I am going to try to move the ARM up to 900. It appears that the sdram is the least tolerant of Overclocking and does not like to exceed 500 by much.
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1935
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by Lob0426 » Thu Jun 14, 2012 9:20 pm
looks like my arm_freq limit is 850. Tried 900 crashed (lock up) in quake3. Tried at 875 same thing. Even at 850 getting a lot of sticky keys but no crashes. So my final settings without overvolting are:
arm_freq=850
gpu_freq=325
sdram_freq=500
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1935
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by mcfundash » Fri Jun 15, 2012 3:20 am
Has anyone else tried my settings?
It was semi-stable (like I said, if it got past boot and logged in, it seemed fine) but I only tried running glxgears to test it. I am going to try putting quake3 on it but currently BOTH my SD cards are corrupted from all the kernal crashes that happened getting there. Currently downloading Raspbian and will report my results asap. I encourage others to find out if this is stable and try to get the most stable settings you can with 8 overvoltage (1.4v, 0.2v extra)
Thanks!
Current best Overclock/volt:
arm_freq=1125
gpu_freq=538
sdram_freq=513
over_voltage=8
Posts: 3
Joined: Sat May 19, 2012 4:11 am
by Lob0426 » Fri Jun 15, 2012 5:16 am
@mcfundash:
Read your own post then read it as if I was the one that posted!

"If it got past boot and logged in........"
"Both my cards are currently corrupted due to kernel crashes........."

I'm sorry, that does not rate as even semi-stable. I considered mine was "stable" right up to the point I ran quake3. Dial back your settings just a little until you can at least log in reliably. Most likely culprits will be GPU and SDRAM. You have half the tests done, you know how far it will go, now see what it runs good at.
What I would try:
arm_freq=1100
gpu_freq=500
sdram_freq=500

SDRAM seems to be the touchiest one. I am not overclocked and anything above 500 crashes.
512MB version 2.0 as WordPress Server
Motorola Lapdock with 512MB
Modded Rev 1.0 with pin headers at USB

http://rich1.dyndns.tv/
(RS)Allied ships old stock to reward its Customers for long wait!
User avatar
Posts: 1935
Joined: Fri Aug 05, 2011 4:30 pm
Location: Susanville CA.
by robwriter » Fri Jun 15, 2012 12:32 pm
I'd be interested how many people found overvolting helped them reach higher stable settings? For me, overvolting doesn't appear to make a difference.
Posts: 108
Joined: Sat Feb 25, 2012 6:26 pm
by dom » Fri Jun 15, 2012 12:42 pm
@robwriter
It makes a huge difference.
Can you post your attempted config.txt file?
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 4030
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge