TL-WN725N V2, raspbian driver update


33 posts   Page 1 of 2   1, 2
by MrEngman » Thu Aug 15, 2013 10:39 pm
The latest update for raspbian, using rpi-update,
Code: Select all
uname -a
Linux raspberrypi 3.6.11+ #524 PREEMPT Thu Aug 15 15:48:48 BST 2013 armv6l GNU/Linux
stops the TL-WN725N V2 wifi, using the 8188eu driver, working.

I have compiled a new version of the driver and it can be installed using the following commands
Code: Select all
wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20130815.tar.gz
tar -zxvf 8188eu-20130815.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a

If your wifi stops working after an update check the linux kernel version with command uname -a. If it shows #524 PREEMPT Thu Aug 15 15:48:48 BST 2013 or newer you probably need to update the driver.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by ilvalle » Fri Aug 16, 2013 9:06 pm
Just tested, it works well at least with hostapd.
Online I found more than one repository for that driver, on my side I've been using this https://github.com/lwfinger/rtl8188eu
Which source have you used to compile your last version?
Posts: 12
Joined: Mon Dec 17, 2012 12:51 pm
by MrEngman » Fri Aug 16, 2013 9:22 pm
As you say there are several different locations with the rtl8188eu source. I think the one I've used is https://github.com/macliu010/pi_plus/tree/master/linux/drivers/net/wireless/rtl8188eu


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by ilvalle » Sat Aug 17, 2013 3:56 pm
Code: Select all
pi@sanvale:~$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr f8:1a:67:1a:2c:dd 
          inet addr:10.110.110.1  Bcast:10.110.110.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:125649 errors:0 dropped:154202 overruns:0 frame:0
          TX packets:130922 errors:0 dropped:78 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:44372863 (42.3 MiB)  TX bytes:133300820 (127.1 MiB)

As you can see a lot of packets've been dropped. The repository I mentioned seems more updated than the one you used, isn't it?
Posts: 12
Joined: Mon Dec 17, 2012 12:51 pm
by MrEngman » Sat Aug 17, 2013 8:14 pm
OK. I've tried the source from the repository you mentioned and there is a significant reduction in the dropped packet count, almost down to zero but not quite.

I have replaced the driver in dropbox. Same instructions to load and install it.

Thanks


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by abrennan » Sat Sep 07, 2013 2:53 am
Looks like it happened again:

uname -a
Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30

My TL-WN725N V2 has stopped working, and the August 15th driver gives an 'invalid format error' on insert. I tried compiling a new version using the instructions at http://tech.enekochan.com/2013/05/29/compile-and-install-driver-for-tp-link-tl-wn725n-version-2-in-raspbian/ and tried your instructions at http://www.raspberrypi.org/phpBB3/viewtopic.php?f=91&t=29752&p=413703&hilit=MrEngman#p413703 but couldn't get anything that would install.

Would you be able to compile and post an update sometime please?

Cheers,
-Adrian
Posts: 2
Joined: Sat Sep 07, 2013 2:46 am
by n21brown » Sat Sep 07, 2013 9:27 am
I had the update to Linux raspberrypi 3.6.11+ #538 PREEMPT Fri Aug 30 too. I've managed to compile the driver for the update. and it's tested and working.
Posts: 1
Joined: Fri Sep 06, 2013 6:58 pm
by MrEngman » Sat Sep 07, 2013 9:39 am
Try this one.

Code: Select all
wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20130830.tar.gz
tar -zxvf 8188eu-20130830.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by abrennan » Sat Sep 07, 2013 9:59 pm
Perfect. Many thanks.

-Adrian
Posts: 2
Joined: Sat Sep 07, 2013 2:46 am
by jiangchen » Sun Sep 08, 2013 3:25 pm
Hi MrEngman,

Your latest driver is the only one that I have managed to install so far after browsing through countless websites and posts.

In the first post you mentioned that if my kernel is newer it will disconnect.

My current kernel is
3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013

and the disconnect problem arises and I am not sure how to solve this problem.

Additionally, after sudo depmod -a I did a reboot and the usb wpa_gui does not detect the usb dongle again.

I repeated the same steps and wpa_gui will detect the usb dongle but keeps disconnecting. A shutdown or reboot brings everything back to square one.

I am a complete noob and any help is greatly appreciated.
Posts: 6
Joined: Sun Sep 08, 2013 3:12 pm
by MrEngman » Sun Sep 08, 2013 4:07 pm
jiangchen wrote:Hi MrEngman,

Your latest driver is the only one that I have managed to install so far after browsing through countless websites and posts.

In the first post you mentioned that if my kernel is newer it will disconnect.

This was a warning to say if the kernel is updated from the version detailed in the post the driver referred to in that post may stop working and then a newer one to match the updated kernel will need installing.
jiangchen wrote:My current kernel is
3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013

and the disconnect problem arises and I am not sure how to solve this problem.

Additionally, after sudo depmod -a I did a reboot and the usb wpa_gui does not detect the usb dongle again.

I repeated the same steps and wpa_gui will detect the usb dongle but keeps disconnecting. A shutdown or reboot brings everything back to square one.

I am a complete noob and any help is greatly appreciated.

Are you saying now you have the new driver installed that your wifi occasionally disconnects or you cannot get it connected at all? For kernel version #541 you will need driver 8188eu-20130830.tar.gz detailed in my post two posts back.

Can you run command lsmod? Does it show 8188eu in the list? If it does it should be installed OK.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by jiangchen » Mon Sep 09, 2013 2:23 am
Hi MrEngman,

I redo all the steps again, this time it seems when I start the wpa_gui it does not notify me of disconnection again.

Maybe it is because I am testing it my Pi headless connecting to my laptop and sharing my laptop wifi.

After the installation I run lsmod, the module is listed there. However, after I restart the Raspberry Pi, the module is gone.

How can I retain the installed module?

Additionally, I tried to compile my own driver but upon connecting to the github site it asks for username and password.

Thanks for the help so far and I need to apologize for my English if it is not clear.
Posts: 6
Joined: Sun Sep 08, 2013 3:12 pm
by Dutch_Master » Mon Sep 09, 2013 2:47 am
Add the name of the driver to the file /etc/modules to make it persistently loaded by the kernel at boot. This is the easiest way:
Code: Select all
sudo echo "8188eu" >> /etc/modules
Mind, the command requires 2 arrows, not a single one (you'll overwrite the existing file, bad idea) or more then 2 (dunno what'll happen, but it wouldn't be good I image :P)
Posts: 276
Joined: Sat Jul 27, 2013 11:36 am
by jiangchen » Mon Sep 09, 2013 8:36 am
Hi Dutch_Master,

Thanks for the suggestion, however,

I get a permission denied after using this code:

sudo echo "8188eu" >> /etc/modules
Posts: 6
Joined: Sun Sep 08, 2013 3:12 pm
by Dutch_Master » Mon Sep 09, 2013 10:11 am
I assumed you're running a standard Raspbian install and thus was working as the pi user. If you've obtained root access some other way, drop the sudo prefix:
Code: Select all
echo "8188eu" >> /etc/modules
Alternatively, use nano to open the /etc/modules file and add the name of the driver on a new line. Save the file under its original name.
Posts: 276
Joined: Sat Jul 27, 2013 11:36 am
by jiangchen » Mon Sep 09, 2013 2:10 pm
Hi Dutch_Master,

I manage to key in the code using root access and I can see that the /etc/modules file has the 8188eu driver name within it.

However, once I restart the Raspberry Pi, the driver still does not load....

I wonder what is the problem.

Thanks for your help so far.
Posts: 6
Joined: Sun Sep 08, 2013 3:12 pm
by MrEngman » Mon Sep 09, 2013 3:20 pm
jiangchen wrote:Hi Dutch_Master,

I manage to key in the code using root access and I can see that the /etc/modules file has the 8188eu driver name within it.

However, once I restart the Raspberry Pi, the driver still does not load....

I wonder what is the problem.

Thanks for your help so far.

Hello jiangchen,

That is very strange. It is possible the driver was not installed with the correct permissions or something like that. I don't think I've seen this problem before.

I am running the same version of raspbian, #541, with the same driver and have no problems. However I usually do not use the GUI and set up my wifi just using /etc/network/interfaces although I have also set it up using wpa_supplicant similar to using the GUI and it is OK then as well.

Can you report the output of command sudo find / -name 8188eu.ko. If you are root user you will not need sudo. This command should show all instances of the file 8188eu.ko and where they are installed. Then can you run the command ls -l /directory/where/file/is/8188eu.ko so we can check the permissions. Like the following
Code: Select all
pi@raspberrypi ~ $ sudo find / -name 8188eu.ko
/lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
/home/pi/8188eu.ko
pi@raspberrypi ~ $ ls -l /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
-rw-r--r-- 1 root root 973773 Aug 31 00:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
pi@raspberrypi ~ $ ls -l /home/pi/8188eu.ko
-rw-r--r-- 1 pi pi 973773 Aug 31 00:12 /home/pi/8188eu.ko
pi@raspberrypi ~ $

The only other thing I can think of at the moment is delete all copies of 8188eu.ko and to reinstall the driver from the command prompt using the commands
Code: Select all
wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20130830.tar.gz
tar -zxvf 8188eu-20130830.tar.gz
sudo install -p -m 644 8188eu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a
with you not logged in as root user. These will install it in the correct place with the right permissions and then hopefully you will find it works.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by jiangchen » Tue Sep 10, 2013 9:26 am
Hi MeEngman,

The results after running sudo find / -name 8188eu.ko

Code: Select all
/lib/modules.bak/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

/lib/modules/3.6.11+/kernel/net/wireless/8188eu.ko

/lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

/home/pi/ .local/share/Trash/files/8188eu.ko

/home/pi/8188eu.ko


After using ls -l on all the directory above:
Code: Select all
-rw-r--r-- 1 root root 620816 May 5 00.13 /lib/modules.bak/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

-rw-r--r-- 1 root root 620816 Sep 8 16.55 /lib/modules/3.6.11+/kernel/net/wireless/8188eu.ko

-rw-r--r-- 1 root root 073773 Aug 31 07:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

-rw-r--r-- 1 pi pi 073773 Aug 31 07:12 /home/pi/ .local/share/Trash/files/8188eu.ko

-rw-r--r-- 1 pi pi 973773 Aug 31 07:12 /home/pi/8188eu.ko


As per your suggestion, I used rm 8188eu.ko and removed all the 8188eu instance. Then I redo the steps. After restarting the driver won't load or is gone. I install it using normal Pi user. The disconnection persisted after the initial install, it keeps trying to connect but could not get the ip.

Thank you for your help so far.
Posts: 6
Joined: Sun Sep 08, 2013 3:12 pm
by MrEngman » Tue Sep 10, 2013 12:12 pm
Hi jiangchen,

I'm really not sure why you are having problems. To make sure the instructions are OK I have just tried a new raspbian SD card and set up the wifi using my instructions to load the driver and the Wifi Config GUI to connect the wifi and it set up correctly first time. This was on a old RPi with display and keyboard/mouse connected with a hub. I tried the same card on a newer v2 RPi with no display or keyboard/mouse and connected using SSH and the wifi and it was also OK.

First I loaded the image 2013-07-26-wheezy-raspbian and booted and ran raspi-config to expand the file system. This set the kernel to 3.6.11+ #474. I then rebooted and ran sudo apt-get update and sudo apt-get upgrade to update the software. This set the kernel to 3.6.11+ #538. I then rebooted again and ran sudo rpi-update to load the latest firmware. This set the kernel to 3.6.11+ #541. I then rebooted again and ran the commands to load the wifi driver. I then rebooted again and ran startx to run the GUI and used Wifi Config to connect the wifi, which it did without problems.

In both cases the wifi dongle is connected to the RPi USB port, not using a hub. How is your wifi connected to the RPi? It is possible that the power supply you use may be causing the problem. Can you measure the voltage on the RPI TP1 and TP2 to make sure it is OK? It should be between 4.75-5.25volts. 5v or a little higher would be best.

My Linux version is
Code: Select all
Linux raspberrypi 3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013 armv6l GNU/Linux
After setting up the wifi file /etc/network/interfaces looks like
Code: Select all
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
and file /etc/wpa_supplicant/wpa_supplicant.conf looks like
Code: Select all
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="network-name"
        psk="network-password"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        auth_alg=OPEN
}
my network uses WPA2 security.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by jiangchen » Tue Sep 10, 2013 1:28 pm
Hi MrEngman,

My Wifi adapter is connected directly to the Raspberry Pi. I connect my Pi to a USB charger supplying 5.1V which I have been using so far without any problem.

However, my Raspberry Pi previously connects to the internet with another USB adapter, could that be a problem? Settings conflict or so on?

I will follow what you did and do a clean install soon. I hope it will work.

Really appreciate your help. I will report back if I can get the wifi adapter to work.

Once again, thank you.
Posts: 6
Joined: Sun Sep 08, 2013 3:12 pm
by pckrullenbol » Sat Sep 14, 2013 1:56 pm
MrEngman wrote:Try this one.
[...]
MrEngman

I have a RPi model A, raspberrypi 3.6.11+ #541 PREEMPT, based on the official Wheezy image with al the software en firmware updates. The TL-WN725N v2 did work on the older firmware, so I was happy to discover this new driver 8188eu-20130830.tar.
At boot I get the "8188eu: disagrees about version of symbol module_layout" and the wifi doesn't work.
Is there a way to get this little bastard working?
Posts: 5
Joined: Fri Aug 30, 2013 3:00 pm
by MrEngman » Sat Sep 14, 2013 5:29 pm
pckrullenbol wrote:
MrEngman wrote:Try this one.
[...]
MrEngman

I have a RPi model A, raspberrypi 3.6.11+ #541 PREEMPT, based on the official Wheezy image with al the software en firmware updates. The TL-WN725N v2 did work on the older firmware, so I was happy to discover this new driver 8188eu-20130830.tar.
At boot I get the "8188eu: disagrees about version of symbol module_layout" and the wifi doesn't work.
Is there a way to get this little bastard working?

Strange, works OK with #541 on my RPI.

What does command
Code: Select all
ls -l /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
show?


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by pckrullenbol » Sat Sep 14, 2013 5:56 pm
MrEngman wrote:
pckrullenbol wrote:
MrEngman wrote:Try this one.
[...]
MrEngman

I have a RPi model A, raspberrypi 3.6.11+ #541 PREEMPT, based on the official Wheezy image with al the software en firmware updates. The TL-WN725N v2 did work on the older firmware, so I was happy to discover this new driver 8188eu-20130830.tar.
At boot I get the "8188eu: disagrees about version of symbol module_layout" and the wifi doesn't work.
Is there a way to get this little bastard working?

Strange, works OK with #541 on my RPI.

What does command
Code: Select all
ls -l /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
show?

MrEngman


Hi,

Output is:
-rw-r--r-- 1 root root 973773 Aug 30 23:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
Posts: 5
Joined: Fri Aug 30, 2013 3:00 pm
by MrEngman » Sat Sep 14, 2013 6:43 pm
pckrullenbol wrote:Hi,

Output is:
-rw-r--r-- 1 root root 973773 Aug 30 23:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

Looks like mine except there is a 1 hour time difference, maybe due to timezone difference I suppose.

My RPi shows
Code: Select all
pi@raspberrypi ~ $ ls -l /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
-rw-r--r-- 1 root root 973773 Aug 31 00:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013 armv6l GNU/Linux
Do you see the symbol module_layout error if you run command
Code: Select all
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
If not run command
Code: Select all
sudo depmod -a
and then see what happens when you reboot.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1843
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by pckrullenbol » Sat Sep 14, 2013 7:23 pm
MrEngman wrote:
pckrullenbol wrote:Output is:
-rw-r--r-- 1 root root 973773 Aug 30 23:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko

Looks like mine except there is a 1 hour time difference, maybe due to timezone difference I suppose.

My RPi shows
Code: Select all
pi@raspberrypi ~ $ ls -l /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
-rw-r--r-- 1 root root 973773 Aug 31 00:12 /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013 armv6l GNU/Linux
Do you see the symbol module_layout error if you run command
Code: Select all
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
If not run command
Code: Select all
sudo depmod -a
and then see what happens when you reboot.

MrEngman


Both commands went without errors, but restarting did not solve the probleem, still the "module lay-out error" while booting.
Posts: 5
Joined: Fri Aug 30, 2013 3:00 pm