Trying to get an RTL8188CUS wireless USB NIC working.


58 posts   Page 2 of 3   1, 2, 3
by felixfurtak » Sat May 12, 2012 7:21 am
Sorry to hear it"s not working for you. The process you describe works ok for me on Debian using the Edimax dongle. Perhaps the differing behaviour is due to the different dongles. Did you check whether it hung after blacklisting (but before installing the new module)? You may need to blacklist more Realtek modules.

If you are able to ssh into the Pi (on the working eth0 port) when you plug the dongle in, you should be able to check for error messages using

dmesg | tail

which might give you some clue.

Otherwise, I suggest you try getting it working on Arch using the module I posted above.

Since I wrote the last post, i noticed the Arch kernel has been update from 3.1.9-13+ to 3.1.9-14-ARCH+ which broke the module again.

I recompiled for 3.1.9-14-ARCH+ and it now works again (for the time being)

You can download it from here:

https://www.dropbox.com/s/g42sdrmpi2gc5p8/3.1.9-14-ARCH-8192cu.tar.gz

and unpack using

tar xf 3.1.9-14-ARCH-8192cu.tar.gz

and then copy the extracted file to the new kernel directory

cp 8192cu.ko.gz /lib/modules/3.1.9-14-ARCH+/kernel/drivers/net/wireless

followed by

depmod -a

Good luck!
Posts: 47
Joined: Wed Nov 16, 2011 10:41 am
by glynn_bird » Sat May 12, 2012 5:51 pm
Thanks for the reply.

My original reply referred to the Debian distribution, but I seem to get slightly further with Arch Linux at the moment.

1) I end up unpacking your compiled files using gunzip which produces 8192cu.ko but your next line refers to copying "8192cu.ko.gz" into the /lib/modules.....

2) I don't know what version of what I'm running here. As far as I can tell I'm on

* Arch Linux

* dmesg says "8192cu: disagrees about version of symbol module_layout"

* My /lib/modules contains:

drwxr-xr-x 3 root root 4096 Apr  4 22:54 3.1.9-10+
drwxr-xr-x 3 root root 4096 May 12 18:44 3.1.9-12+
drwxr-xr-x 2 root root 4096 Apr 28 05:52 extramodules-3.1.9--raspberrypi
 
How do I upgrade to 3.1.9-14?
 
Thanks for the help. I feel I'm getting somewhere!
Posts: 3
Joined: Sat May 12, 2012 5:28 am
by felixfurtak » Sat May 12, 2012 9:10 pm
Providing you have a working internet connection (presumably on eth0) should be able to upgrade to the latest kernel by simply typing
Code: Select all
pacman -Syu

Reboot, and then type
Code: Select all
uname -a

which should report 3.1.9-14. Don't forget, after upgrading you need to put the new module in the new kernel drivers tree. You should be able to leave it gzipped (8192.ko.gz) since the kernel appears to be able to recognise compressed modules.
Posts: 47
Joined: Wed Nov 16, 2011 10:41 am
by glynn_bird » Sun May 13, 2012 8:47 am
Thanks. I'm nearly there now (I think). The module is installed, the "rtl" one is blacklisted and something is happening. I've done:

Code: Select all
ip link set wlan0 up


I've configured a /etc/wpa_supplicant.conf for my WPA network BUT

Code: Select all
> iwlist wlan0 scan
wlan0     No scan results


FYI iwconfig returns:

Code: Select all
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Ad-Hoc  Frequency=2.412 GHz  Cell: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


ifconfig returns:

Code: Select all
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500  metric 1
        ether 48:02:2a:8b:0a:da  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


It's almost as if there isn't an ipv4 path for this device!
Posts: 3
Joined: Sat May 12, 2012 5:28 am
by felixfurtak » Sun May 13, 2012 9:40 am
It's strange that the scan does not pick up anything. It would normally produce a long list of all the wireless stations in the area, yours included.
The only think I can think of is that it is not in range or perhaps running in a low power mode, so perhaps place it next to your router, just to be sure.
To check basic functionality you could then perhaps turn off WPA encryption on your router (momentarily) so that you have an unencrypted channel. Then you should be able to associate it with your wireless station using
iwconfig wlan0 essid <YOUR_ESSID>

followed by
dhcpcd

You probably don't want to be running in Ad-Hoc mode, so you might also need to switch using
iwconfig wlan0 mode Managed

Good luck!
Posts: 47
Joined: Wed Nov 16, 2011 10:41 am
by sharktamer » Sat May 19, 2012 1:29 am
Anyone had any luck installing the drivers on openelec?
Posts: 1
Joined: Sat May 19, 2012 1:28 am
by tqm » Sat May 19, 2012 5:16 pm
Posts: 16
Joined: Tue May 08, 2012 12:00 pm
by MrEngman » Mon May 21, 2012 5:29 am
glynn_bird wrote:I'm still struggling to get this working. I have a Pi running the latest Debian and I'm trying to get a MicroNEXT MN-WD552B working.

"lsusb" hangs on Debian, but with ArchLinux it says:

Bus 001 Device 005: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN



Did you install the firmware for the RTL8188CUS - try.

wget ftp://ftp.dlink.com/Wireless/dwa130_rev ... ux_006.zip
unzip dwa130_revC_drivers_linux_006.zip
sudo mkdir -p /usr/local/lib/firmware/RTL8192U
sudo cp rtl8192u_linux_2.6.0006.1031.2008/firmware/RTL8192U/* /usr/local/lib/firmware/RTL8192U

Add the following 4 lines to /etc/modules/interfaces - sustituting for you own SSID and PASSWORD
auto wlan0
iface wlan0 inet dhcp
wpa-ssid “NETWORK SSID”
wpa-psk “NETWORK PASSWORD”

wget http://www.electrictea.co.uk/rpi/8192cu.tar.gz
tar -zxvf 8192cu.tar.gz
sudo install -p -m 644 8192cu.ko /lib/modules/3.1.9+/kernel/drivers/net/wireless/

add the line "blacklist rtl8192cu" to /etc/modprobe.d/blacklist.conf

add line "8192cu" to file /etc/modules

sudo depmod – a
sudo /etc/init.d/networking restart

works for me with Debian and Micronet Wireless LAN USB adapter SP907NS based on the Realtek RTL8188CUS chip. This adapter uses the same ID as yours.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1857
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by Sival » Thu Jun 07, 2012 11:45 am
Great !
This work fine for me.

I use a usb dongle Netgear WNA1000M with 8192cu module.

Thank's a lot !
Posts: 1
Joined: Thu Jun 07, 2012 11:43 am
by piuser » Wed Jun 20, 2012 1:42 pm
Hi,

I have tried the up to the latest beta verion of debian and cant seem to get this working. I have an asus e13 rev b usb wifi device. Any help greatly appreciated. :(
regards

Zaphod
Posts: 7
Joined: Thu Jun 07, 2012 10:12 pm
Location: uk
by MrEngman » Wed Jun 20, 2012 3:00 pm
piuser wrote:Hi,

I have tried the up to the latest beta verion of debian and cant seem to get this working. I have an asus e13 rev b usb wifi device. Any help greatly appreciated. :(


Presumably you mean the Debian wheezy beta. If you followed the instructions a couple of posts back you need to update the driver. The driver there is out of date unless you are using the original Debian6-19-04-2012 image.

Try the following
Code: Select all
wget http://dl.dropbox.com/u/80256631/8192cu-20120617.tar.gz
tar -xzf 8192cu-20120617.tar.gz
sudo install -p -m 644 8192cu.ko /lib/modules/3.1.9+/kernel/drivers/net/wireless/
sudo depmod -a
sudo /etc/init.d/networking restart
MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1857
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by piuser » Wed Jun 20, 2012 3:33 pm
Fantastic,

at long last My asus usb rev u-13 rev b1. Thanks so much. Really appreciated. :D I appreciate that the answer was there already but Im a noob and really found it difficult to follow everything.

regards and thanks again
regards

Zaphod
Posts: 7
Joined: Thu Jun 07, 2012 10:12 pm
Location: uk
by komple » Wed Jun 27, 2012 6:03 pm
MrEngman wrote:
piuser wrote:Hi,

I have tried the up to the latest beta verion of debian and cant seem to get this working. I have an asus e13 rev b usb wifi device. Any help greatly appreciated. :(


Presumably you mean the Debian wheezy beta. If you followed the instructions a couple of posts back you need to update the driver. The driver there is out of date unless you are using the original Debian6-19-04-2012 image.

Try the following
Code: Select all
wget http://dl.dropbox.com/u/80256631/8192cu-20120617.tar.gz
tar -xzf 8192cu-20120617.tar.gz
sudo install -p -m 644 8192cu.ko /lib/modules/3.1.9+/kernel/drivers/net/wireless/
sudo depmod -a
sudo /etc/init.d/networking restart
MrEngman



Thanks it worked for my dline dwa-121.
Posts: 23
Joined: Wed Jun 13, 2012 6:03 pm
by h00rj » Thu Jun 28, 2012 12:24 pm
felixfurtak wrote:Hi,

Although ajtag"s 8192.ko file worked for me on Debian, I didn"t have much success using it with Arch, so I just compiled a new version for the current Arch distribution (currently 3.1.9-13+, after running pacman -Syu).

For reference, I am using an Edimax EW-7811un with USB ID 7392:7811 [RTL8188CUS] with the module compiled from the latest Realtek driver v3.4.2_3727.20120404

I uploaded it to here:

https://www.dropbox.com/s/vuih1z7e866omp9/8192cu.ko.gz

Installation is similar as the Debian image:

Firstly create a file in /etc/modprobe.d called blacklist.conf and add the line

blacklist rtl8192cu

and then type the following...

cp 8192cu.ko.gz /lib/modules/3.1.9-13+/kernel/drivers/net/wireless
depmod -a
modprobe 8192cu.ko
ifconfig wlan0 up
iwconfig wlan0 essid <MYESSID>
dhcpcd
should get you going.

Would appreciate any feedback on whether this works for you.

Felix


I got this to work quite easily with my Belkin n300 with the rtl8192cu chipset, BUT after using it for a little while it just stops working. lsusb still recognizes it, but debian won't admit there's a wlan0

It cuts out within a few minutes of use (I was unable to download the Quake 3 pak file)
It works again after a reboot, or unplugging/plugging back in. Any ideas?
Posts: 2
Joined: Thu Jun 28, 2012 12:18 pm
by felixfurtak » Mon Jul 02, 2012 11:00 pm
Here is an update to the 8192cu.ko module for Arch 3.1.9-26 kernel.

https://www.dropbox.com/s/7nyqd06dhs3j2 ... 2cu.tar.gz

To install, firstly create file /etc/modprobe.d/modprobe.conf and add the line blacklist.rtl8192cu

Next

Code: Select all
wget http://dl.dropbox.com/s/7nyqd06dhs3j2bk/3.1.9-26-ARCH-8192cu.tar.gz
tar xvf 3.1.9-26-ARCH-8293cu.tar.gz
install -p -m 644 8192cu.ko.gz /lib/modules/3.1.9-26-ARCH+/kernel/drivers/net/wireless
depmod -a
modprobe 8192cu


Regards,

Felix
Posts: 47
Joined: Wed Nov 16, 2011 10:41 am
by devacc12 » Sat Jul 07, 2012 6:28 pm
Similar to the above with: Linux alarmpi 3.1.9.28-ARCH+1 #1 PREEMPT
updated all packaged a few minutes ago:

lsusb now identifies the Edimax EW-7811Un as RTL8188CUS

but

there's no wlan0 device created.

Please can you advice how to create it or is there still a device problem.

Thanks
Posts: 10
Joined: Sat Jul 07, 2012 6:22 pm
by Halfdead14 » Sat Jul 07, 2012 7:45 pm
I'm a Linux beginner, but experienced PC user. I can't seem to get my asus n13 usb device to show up, lsusb shows the device there but it's not listed under iwconfig.
Posts: 1
Joined: Thu Jul 05, 2012 3:13 pm
by Chuckaluphagus » Sat Jul 14, 2012 2:46 am
I'm not having any luck getting an Edimax EW-7811Un wireless adapter working.

I've installed the Debian wheezy beta and then run rpi-update. uname -a returns:
Code: Select all
Linux raspberrypi 3.1.9+ #162 PREEMPT Thu Jul 12 12:01:22 BST 2012 armv6l GNU/Linux


So far, I've followed the instructions provided above by MrEngman for wheezy and installed the updated driver that he provided (8192cu-20120617.tar.gz). Unfortunately, it doesn't appear to have had the desired effect.

lsusb gives me:
Code: Select all
Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

However, iwconfig wlan0 returns:
Code: Select all
wlan0     No such device

Running dmesg shows me this:
Code: Select all
[   31.268254] 8192cu: disagrees about version of symbol module_layout

... which some Google research leads me to believe means that I'm running the wrong version, and that I need to compile a version of the driver for my current kernel. I don't know quite how to proceed with that; I don't even know where I get the source for the driver in the first place.

Edit: I've also found the modinfo command, and running "modinfo 8192cu" returns:
Code: Select all
pi@raspberrypi ~ $ modinfo 8192cu
filename:       /lib/modules/3.1.9+/kernel/net/wireless/8192cu.ko
version:        v3.0.2164.20110715
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     43717D922DB2B0EAD001526
alias:          usb:v0B05p17ABd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p0061d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v20F4p624Dd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp2103d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp2102d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp2102d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v4855p0091d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07AAp0056d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07B8p8178d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB2Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v7392p7822d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0586p341Fd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3309d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p330Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3307d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019p1201d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFFCd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFFBd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFF8d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFFAd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFF9d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v04F2pAFF7d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D3p3358d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D3p3359d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB2Ed*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019p4902d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0846p9041d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v9846p9041d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v4856p0091d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp5088d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p005Cd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D3p3357d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v4855p0090d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v20F4p648Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pAB2Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp1102d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3308d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v103Cp1629d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v06F8pE033d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0EB0p9071d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v07B8p8189d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v7392p7811d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p0052d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2019pED17d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8186d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Cd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8178d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8177d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Fd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8754d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Dd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp817Ed*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8170d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8176d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8191d*dc*dsc*dp*ic*isc*ip*
depends:       
vermagic:       3.1.9+ mod_unload modversions ARMv6
parm:           rtw_ips_mode:int
parm:           ifname:charp
parm:           rtw_initmac:charp
parm:           rtw_channel_plan:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_cbw40_enable:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_max_roaming_times:uint

I freely admit I have no idea what any of that after "license: GPL" means.

Any help is appreciated. I'm also happy to provide any more information that might help.
Posts: 18
Joined: Sat Jun 30, 2012 9:05 pm
by devacc12 » Sat Jul 14, 2012 10:32 am
I have the same problem with the Edimax EW7811Un.
I had it working but then updates killed it and I'm not wasting more hours trying to fix it on Debian.

Although it took a few steps on Archlinux to get working at least it keeps on working.

Maybe one day someone will fix the kernel module and it will work out the box .. but until then!
Had I know I'd have bought a different USB WiFi adapter.

Maybe the new Raspbian build will do better its released.
Posts: 10
Joined: Sat Jul 07, 2012 6:22 pm
by MrEngman » Sat Jul 14, 2012 11:57 am
Chuckaluphagus wrote:I'm not having any luck getting an Edimax EW-7811Un wireless adapter working.

I've installed the Debian wheezy beta and then run rpi-update. uname -a returns:
Code: Select all
Linux raspberrypi 3.1.9+ #162 PREEMPT Thu Jul 12 12:01:22 BST 2012 armv6l GNU/Linux


So far, I've followed the instructions provided above by MrEngman for wheezy and installed the updated driver that he provided (8192cu-20120617.tar.gz). Unfortunately, it doesn't appear to have had the desired effect.


Any help is appreciated. I'm also happy to provide any more information that might help.


The driver you've used is for the non-updated wheezy beta. As you've updated using rpi_update you will need to grab hold of the latest driver and then manually install it.
The commands to do this are:
Code: Select all
sudo wget http://dl.dropbox.com/u/80256631/8192cu-latest.tar.gz
tar-zxf 8192cu-latest.tar.gz
sudo install -p -m 644  8192cu.ko /lib/modules/3.1.9+/kernel/drivers/net/wireless
sudo depmod -a
sudo /etc/init.d/networking restart
I try to ensure the file 8192cu-latest.tar.gz is compatible with the latest version of code updated by rpi-update. If any further updates stop the wifi running just run the exact same commands and it should install the latest driver version whatever that might be.
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1857
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by pdp7 » Tue Aug 07, 2012 5:44 pm
FYI - the Adafruit Occidentalis v0.1 image, based on Rasbpian Wheezy, includes the 8192cu driver in the kernel

http://learn.adafruit.com/adafruit-rasp ... s-v0-dot-1

(discussion reference: http://www.element14.com/community/message/57635#57660)

cheers,
drew
Posts: 31
Joined: Sat Mar 03, 2012 12:49 am
by MrEngman » Wed Aug 08, 2012 10:58 am
pdp7 wrote:FYI - the Adafruit Occidentalis v0.1 image, based on Rasbpian Wheezy, includes the 8192cu driver in the kernel

http://learn.adafruit.com/adafruit-rasp ... s-v0-dot-1

(discussion reference: http://www.element14.com/community/message/57635#57660)

cheers,
drew

A couple of thing you need to do to get the wifi running. Do not plug in the wifi adapter until you have gone through the following instructions. If you have already plugged it in, remove it and then go through the setup. Note if you are logged in as root you do not need to use "sudo" before the commands below.

First delete the file /etc/udev/rules.d/70-persistent-net.rules.
Code: Select all
sudo rm /etc/udev/rules.d/70-persistent-net.rules
If you do not delete this file it will expect your wifi to be named wlan1 rather than wlan0 as it is already set for wlan0 - a left over from Adafruit's configuration and their wifi adapter. This file should have been deleted before the image was made.

Second edit the /etc/network/interfaces file to setup your network name and password.
Code: Select all
sudo nano /etc/network/interfaces
This file is pre-configured for a network using WPA/WPA2 and just needs the right network name and password setting up. Change the NETWORK NAME and PASSWORD entries to suit your own network.
Code: Select all
wpa-ssid "NETWORK NAME"
wpa-psk "PASSWORD"

If you use a WEP wifi network change the lines wpa-ssid and wpa-psk to:
Code: Select all
wireless-essid NETWORK NAME
wireless-key PASSWORD

If you have an unsecured network that doesn't require a password delete the line with wpa-psk and change the line with wpa-ssid to set the network name with the line
Code: Select all
wireless-essid NETWORK NAME
Note for WPA/WPA2 the network name and password are in quotation marks. For WEP and unsecured networks there are no quotation marks around the network name and password.

Exit nano using the keystrokes cntl-X, y, enter.

Plug in the wifi adapter and it should start running automatically. If not reboot.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1857
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK
by naplam » Tue Aug 14, 2012 11:06 pm
I compiled the Realtek drivers on their website: http://www.realtek.com.tw/downloads/dow ... loads=true
and it worked (well I still have to test it, but wlan0 is there and so on). I'm using arch linux and a RTL8188CUS.
This is a pain in the ass, however. It would be nice to have it working out of the box.
Posts: 43
Joined: Tue Aug 14, 2012 11:04 pm
by waffleShirt » Wed Sep 12, 2012 12:53 pm
I have been following the instructions given by MrEngman to install the driver for the MICRONEXT wireless adapter, but I keep running into issues at the step:
Add the following 4 lines to /etc/modules/interfaces - sustituting for you own SSID and PASSWORD
auto wlan0
iface wlan0 inet dhcp
wpa-ssid “NETWORK SSID”
wpa-psk “NETWORK PASSWORD”


Every time I try to write out the file nano gives me an error, saying that modules is not a directory. I checked the /etc folder and sure enough modules is a file. I don't quite understand how I am supposed to edit the modules file.

If anyone could help I would be most greatful!

- Tom
Posts: 4
Joined: Wed Sep 12, 2012 12:48 pm
by MrEngman » Wed Sep 12, 2012 3:48 pm
waffleShirt wrote:I have been following the instructions given by MrEngman to install the driver for the MICRONEXT wireless adapter, but I keep running into issues at the step:
Add the following 4 lines to /etc/modules/interfaces - sustituting for you own SSID and PASSWORD
auto wlan0
iface wlan0 inet dhcp
wpa-ssid “NETWORK SSID”
wpa-psk “NETWORK PASSWORD”


Every time I try to write out the file nano gives me an error, saying that modules is not a directory. I checked the /etc folder and sure enough modules is a file. I don't quite understand how I am supposed to edit the modules file.

If anyone could help I would be most greatful!

- Tom

You should be editing the file /etc/network/interfaces NOT /etc/modules/interfaces. My mistake. Why I got it wrong I don't know. Must have been half asleep when I typed that. Suprised nobody hasn't mentioned it before.

MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra
Posts: 1857
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK