Dependency errors - citrix receiver


6 posts
by rene » Sun Nov 04, 2012 2:14 pm
Hi,
I'm running the default raspbian image and am trying to install Citrix receiver for Linux 12.1 After dpkg -i icaclient_12.1.0_armel.deb I get a pop-up window to accept the license agreement. After that however I get a bunch of dependency errors like 'icaclient depends on libxp6' and the install stops. Does anyone know how I can fix this?
Thanks,
René
Posts: 4
Joined: Fri Oct 26, 2012 6:16 pm
by hvr » Wed Nov 07, 2012 4:24 pm
It appears that Openmotif has been replaced by lesstif2. I think Openmotif has some "closed" bits. I am also interested how to get this work now that openmotif is replaced/removed.
Does Citrix offer src?
Thanks,
Posts: 1
Joined: Wed Nov 07, 2012 4:15 pm
by archiewinter » Wed Nov 07, 2012 6:25 pm
First thing to consider:

Did you perform the following commands?

sudo apt-get update
sudo apt-get upgrade

The library you are looking for his installed by performing:

sudo apt-get install libxp6

On top of this, here's some commands I have run on my Pi to get the Debian Citrix Receiver working. The version of Wheezy version should be armel, not the more efficient armhf, since Citrix only has a version compiled for armel.

#install the pre-reqs
sudo apt-get install libmotif4 libmotif-dev

#install iceweasel - browser by Firefox needed for Web Interface to function
sudo apt-get install iceweasel

#install the Receiver client software once you've downloaded it
sudo dpkg -i icaclient_12.0.0_armel.deb

#adding sym link
ln -s /usr/lib/libXm.so.4.0.3 /usr/lib/libXm.so.3
ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts

----

With all that in place, you *should* have a working Receiver client. Let me know how you do with the information :)

AW
Posts: 1
Joined: Wed Nov 07, 2012 6:14 pm
by rene » Thu Nov 08, 2012 10:39 pm
I had the armhf and tried to install using dpkg -i --force-architecture, with the armel version I haven't gotten any dependency errors. So far so good. Unfortunately my Pi hanged itself after a reboot (of course didn't make a backup after the apt-get upgrade and the various apt-get installs). Will try again tomorrow. Thanks for your help so far.
Posts: 4
Joined: Fri Oct 26, 2012 6:16 pm
by rene » Fri Nov 09, 2012 10:07 pm
Did a new install and followed your instructions. Got the Citrix Receiver up and running. Thanks for your help!
Posts: 4
Joined: Fri Oct 26, 2012 6:16 pm
by GaRailroader » Sat Mar 02, 2013 4:38 pm
Archiewinter:

I am running the 2012-08-08 soft float image for armel and followed your instructions exactly and Citrix is running great. Thanks for posting! This will get me by until wireless support is included in the Thin Client image.

GaRailroader
Posts: 1
Joined: Sat Mar 02, 2013 4:28 pm