no sound


2 posts
by lenster » Sun Jun 24, 2012 9:37 pm
I'm having a helluva time with sound on the raspberry pi. I realize the alsa drivers are experimental but I think I'm having more issues using the alsa utils rather than having alsa driver issues.

I am using the headset output and so I try to force the system to use the headphone jack and then set the volume. All I get is the standard "pop" from using the headphone jack and what seems to be a very faint sound from my aplay test. I also tried hello_audio with no success either. I did notice no pop with hello_audio though.

here's a log...

Code: Select all
root@raspberrypi:~# modprobe snd_bcm2835
root@raspberrypi:~# amixer cset numid=3 1
numid=3,iface=MIXER,name='PCM Playback Route'
  ; type=INTEGER,access=rw------,values=1,min=0,max=3,step=0
  : values=1
root@raspberrypi:~# amixer cset numid=1 60
numid=1,iface=MIXER,name='PCM Playback Volume'
  ; type=INTEGER,access=rw---RW-,values=1,min=-10240,max=2303,step=0
  : values=-153
  | dBscale-min=-102.40dB,step=0.01dB,mute=1


No matter the value I set for numid=1 I never get sound. I noticed the mute=1 setting but I havent figure out how to change that value

I'm pretty sure I'm just not understanding the alsa-utils as I've been away from desktop linux for quite some time now but I'm at a loss as to my next steps

Below is the contents of the the amixer if this is needed
Code: Select all
root@raspberrypi:~# amixer contents
numid=3,iface=MIXER,name='PCM Playback Route'
  ; type=INTEGER,access=rw------,values=1,min=0,max=3,step=0
  : values=1
numid=2,iface=MIXER,name='PCM Playback Switch'
  ; type=INTEGER,access=rw------,values=1,min=0,max=1,step=0
  : values=0
numid=1,iface=MIXER,name='PCM Playback Volume'
  ; type=INTEGER,access=rw---RW-,values=1,min=-10240,max=2303,step=0
  : values=-153
  | dBscale-min=-102.40dB,step=0.01dB,mute=1
Posts: 3
Joined: Mon Apr 16, 2012 6:26 pm
by lenster » Sun Jun 24, 2012 11:49 pm
Installed Debian Wheezy and all is good now.
Posts: 3
Joined: Mon Apr 16, 2012 6:26 pm