screen goes blank


5 posts
by rinky451 » Wed Nov 07, 2012 3:07 pm
Hey, I figured out alot on the pi. I run weezy and have it to where i want it. but after a period of time my pi stays powered with all the lights but the screen goes out until i hit a key and then it comes back on. Is there a setting here I am missing or in the config.txt file? I know there should be a way to keep the screen going.
tks
rinky 8-)
Posts: 25
Joined: Sun Nov 04, 2012 5:08 pm
Location: USA
by RaTTuS » Wed Nov 07, 2012 3:14 pm
edit as root
/etc/kbd/config
i.e.
sudo nano /etc/kbd/config

and change the
BLANK_TIME=30
to
BLANK_TIME=0

then after a reboot it will never blank,
you can type
setterm -blank 0
at the command line to do it now
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
"That's not right, the badgers have moved the goalposts."
User avatar
Posts: 5156
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by rinky451 » Wed Nov 07, 2012 5:08 pm
[quote=I can get into the file, I can see the blank time set to 30, i can change it to 0 but how do i get the system to accept and exit? I am in the root terminal also as you told me, but the only way i can access is to use just the sudo nano /

"RaTTuS"]edit as root
/etc/kbd/config
i.e.
sudo nano /etc/kbd/config

and change the
BLANK_TIME=30
to
BLANK_TIME=0

then after a reboot it will never blank,
you can type
setterm -blank 0
at the command line to do it now[/quote]
[quote][/quote]
Posts: 25
Joined: Sun Nov 04, 2012 5:08 pm
Location: USA
by rinky451 » Thu Nov 08, 2012 5:58 am
rinky451 wrote:[quote=I can get into the file, I can see the blank time set to 30, i can change it to 0 but how do i get the system to accept and exit? I am in the root terminal also as you told me, but the only way i can access is to use just the sudo nano /

"RaTTuS"]edit as root
/etc/kbd/config
i.e.
sudo nano /etc/kbd/config

and change the
BLANK_TIME=30
to
BLANK_TIME=0

then after a reboot it will never blank,
you can type
setterm -blank 0
at the command line to do it now

I guess I figured it out after I sent you the pm. to exit the terminal i had to hit ctlx together to bring up the accept. I did so and it works now. tks man
Posts: 25
Joined: Sun Nov 04, 2012 5:08 pm
Location: USA
by TillM » Tue Nov 13, 2012 7:27 am
You shouldn't edit system wide files, this is not windows!
Unless you know what you're doing and you want all user accounts to behave the same way.
Stick to your own profile settings and you won't stuff up your system.

You should put this at the bottom of your .bashrc file or better yet in your .xinitrc file in your home directory.
Code: Select all
xset s off -dpms &      # Stop the screen from blanking
Posts: 33
Joined: Wed Oct 17, 2012 7:54 am