USB Sound Card


4 posts
by tuzl » Fri Aug 17, 2012 7:10 pm
I just received an external USB sound card, however I have absolutely no idea how I get the Pi to use it as default output device. I am using the Raspbian distribution and after plugging the sound card in I don't get any sound from it, the Pi's own headphone jack still gives me sound instead.

The sound card seems properly installed, at least it is listed in the outputs I get from doing
Code: Select all
aplay -l
cat /proc/asound/modules

I understand that ALSA is the thing that handles sound output, and I think I did the steps explained in http://elinux.org/R-Pi_Troubleshooting#Sound to get the headphone jack to work, however trying
Code: Select all
 sudo amixer cset numid=3 <n>

with other numbers than 1 did not give me any sound from either device.

How do I make ALSA use the USB soundcard as the default device for sound output?

Thanks!
Posts: 2
Joined: Wed Jul 11, 2012 1:12 pm
by tomaz » Mon Aug 20, 2012 3:09 am
Hi tuzl,

I had the same question as you. I found your post first, but no replies :(
So I found solution here:
viewtopic.php?p=150313#p150313


Unimportant but maybe interesting:
With USB sound card sound volume is higher compared to onboard analog sound.
The control of sound with "alsamixer" is now showing also stereo. With USB sound card I can change volume of just left/right or both channels.

It seams onboard sound drivers are not totally working (yet). They are stereo but not showing as stereo...

Onboard sound problem:
range from -10239(-102.39db) to 400(+4db)
400 was upper limit but it didn't work. If I set it to 399 it changed sound level.
amixer set 'PCM' -- 399
at -2721 it was almost silence.
If I say like this, from 0-40% volume it is in real as 0% volume. Than from 40% on to 100% it start to increase volume... Not linear at all.

With my USB sound card I have have range from 0-151
amixer set 'Speaker' -- 151

if you want to set different values for left and right just use comma:
amixer set 'Speaker' -- 151,100



Tomaz.
Posts: 38
Joined: Thu Jul 12, 2012 9:08 am
by demonzrulaz » Wed Aug 22, 2012 2:32 am
tuzl wrote:I just received an external USB sound card, however I have absolutely no idea how I get the Pi to use it as default output device. I am using the Raspbian distribution and after plugging the sound card in I don't get any sound from it, the Pi's own headphone jack still gives me sound instead.


Hi tuzl,

Can you please tell me what kind of USB sound card you have? I'm looking to get one but I don't want to buy one without knowing if it'll work properly with the RPi. How well does your USB sound card work?

Thanks in advance!
Posts: 7
Joined: Fri Jun 15, 2012 12:27 am
by RaspDD » Wed Aug 22, 2012 6:34 pm
I, for example, got this one - and it WORKS even with SPDIF, which is very important for me.

http://www.ebay.de/itm/Externe-USB-6-Ka ... 6rk%3D1%26


My Problem is: the sound stutters, in apps and even with aplay, for example. I dont find much info on USB-Soundcard & Rpi, so here my question: how can i solve this ?
Posts: 59
Joined: Thu Jul 26, 2012 2:59 pm