WPA works but not WEP


20 posts
by Grumpy Mike » Thu Jun 28, 2012 9:57 am
I have a wi-fi USB dongle, I have installed all the packages and got it working successfully in one location using WPA. However when I move to another location using WEP it does not work.
I have tried lots of combinations from here:- http://www.lsi.upc.edu/lclsi/Manuales/wireless/files/wpa_supplicant.conf but nothing seems to work.
I have been modifying the wpa.conf file as I eventually want to use the two locations without having to edit files. I am running debian6-19-04-2012
Searching through this forum there have been many "answers" given, some conflicting, but nothing seems to work. Has anyone got a config file that works with WEP?
User avatar
Posts: 748
Joined: Sat Sep 10, 2011 7:49 pm
Location: Manchester (England England)
by grumpyoldgit » Thu Jun 28, 2012 10:05 am
I didn't think anyone used WEP any more.
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by Grumpy Mike » Thu Jun 28, 2012 10:10 am
I am running some old machines that can't run WPA so I am stuck with WEP.
User avatar
Posts: 748
Joined: Sat Sep 10, 2011 7:49 pm
Location: Manchester (England England)
by grumpyoldgit » Thu Jun 28, 2012 10:22 am
If you have an old wireless domestic router hanging around it can be used as an additional access point. I had a blind spot on my home network where my bedside internet radio always got poor connection. I did, however, have a box of old routers, that grew every time I changed ISP. I did some simple reconfiguration as per the instructions below and then whacked it on the network. So now I have two APs to chose from and it didn't cost me a penny.

http://www.wi-fiplanet.com/tutorials/ar ... hp/3826776
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by pXc » Thu Jun 28, 2012 11:02 am
If you want to be mobile with you pi you can download an useful GUI package that works under debian for your Rpi :
(apt-get install network-config )

It lets you scan the networks available ( So you can see what's in range and know the ssid name) and you can connect to unsecured + WPA + WEP networks , it does all the job ( reinitialize the dongle an sets the adapted parameters in wpa_supplicant.conf and connects to the network )
I discovered this a week ago and it's very useful since the wifi in my university is not secured , however it takes a significant amount of ram when you connect to a network ( and it's not so fast )
I'm using it under the lastest version of debian squeeze with a wifi dongle [RTL8188CUS] [Edimax EW-7811UN]

If you want to do it manually it also displays the commands used so you can directly paste them in the terminal. You can also only modify directly the key_mgmt of wpa_supplicant to WEP40 or WEP104 depending on the encryption of your password.

Hope that helps
Posts: 22
Joined: Sat Jun 16, 2012 12:49 pm
by dhardingham » Sat Jun 30, 2012 12:14 am
Really like using network-config. This is a fantastic tool.

I can now use my Raspberry Pi with an Iogear GWU625 USB adapter and my old Belkin router. Even WEP security works (don't ask).

Along the way, I discovered that my cheap keyboard and mouse use too much current. Both are made by Logik. My HP bluetooth keyboard and mouse work perfectly.

All I need now is a Wireless-N router, to speed things up a little.
David Hardingham
User avatar
Posts: 27
Joined: Mon Jan 02, 2012 12:45 pm
Location: Stevenage, UK
by Grumpy Mike » Sat Jun 30, 2012 6:46 pm
dhardingham wrote:Even WEP security works (don't ask).


But that is what I am asking!

Being very new to Linux I wonder if it is this yet another case of Linux being some what crap?
Sorry "not finished yet" I believe is the politically correct expression.
User avatar
Posts: 748
Joined: Sat Sep 10, 2011 7:49 pm
Location: Manchester (England England)
by dhardingham » Sat Jun 30, 2012 7:08 pm
The network-config tool allowed me to enter my WEP, so that I can connect to my Belkin router. Everything is working, but WEP security is only marginally better than no security at all. One day, I'll change to WPA and lock everyone out,
David Hardingham
User avatar
Posts: 27
Joined: Mon Jan 02, 2012 12:45 pm
Location: Stevenage, UK
by Grumpy Mike » Sat Jun 30, 2012 7:22 pm
Sorry but this is typical of what I find to be the big problem with Linux.

Something doesn't work so you ask how to fix it and you are given a totally different application to try. With it's own set of dependance and missing configurations that take hours to install.

This package that according to pXc is:-
it takes a significant amount of ram when you connect to a network ( and it's not so fast )

Oddly enough I don't want to use up lots of RAM and be slow.

According to the information on http://www.lsi.upc.edu/lclsi/Manuales/wireless/files/wpa_supplicant.conf
It should work, but it doesn't. Seemingly no one wants to or can tell me what is wrong.

but WEP security is only marginally better than no security at all.

Rubbish, that is the sort of overly geek attitude that is part of the problem with the Linux community.
User avatar
Posts: 748
Joined: Sat Sep 10, 2011 7:49 pm
Location: Manchester (England England)
by grumpyoldgit » Tue Jul 03, 2012 6:49 pm
Well. WPA was introduced in 2003 due to the lack in security of WEP. This is not a Linux thing. I was laughed at 6 or 7 years ago when I mentioned to colleagues that my home (Windows) network was still protected by WEP. There are many tools available that will get through WEP security in a few minutes.

I've just done a quick google and there are even youtube videos that show you how to do it!

I did give you a cheap (free) solution, which was to attach another AP to your WEP network. Like most people you will probably have an old wireless router or two lying around in a box in the roof or garage. These instructions will enable you to recycle that old wireless router as a WPA AP in a few minutes.

http://www.wi-fiplanet.com/tutorials/ar ... hp/3826776
User avatar
Posts: 1458
Joined: Thu Jan 05, 2012 12:20 pm
by Nr90 » Tue Jul 03, 2012 7:06 pm
I might misunderstand what you are doing, but it seems to me like you are trying to connect to a wep network with a wpa tool.
This will not work.

To test if your pi will connect to a wep network you can run
# iwconfig wlan0 essid "MyNetwork" key "s:password"
Then run dhcpcd wlan0 and it should work

I agree with the poster above me that getting a tool that will automate this is better and easier.

I would personally recommend wicd. It does not take hours to configure and is very easy to install. Does not seem to slow my pi down one bit.
Posts: 213
Joined: Sat Nov 26, 2011 12:39 pm
by paulie » Wed Jul 04, 2012 9:54 pm
I too am using wicd.
However, I am unable to connect to a network using wpa2.
I always get "bad password" - even when connecting to an "open" network.
I have heard of conflicts with network manager (which is not installed), but am stumped.
I have tried editing
Wpa_supplicant.conf by hand but still no good.
Wicd is a great front-end but something I am doing must be stopping it successfully kicking my Asus N10usb dongle into shape.
It's not a power problem: ran N10 direct from pi, and now from a variable psu 5v @20 amps
Posts: 169
Joined: Thu Jan 19, 2012 6:51 pm
by Nr90 » Wed Jul 04, 2012 10:00 pm
Did you choose the correct encryption method?
Posts: 213
Joined: Sat Nov 26, 2011 12:39 pm
by Rubber131186 » Thu Jan 24, 2013 1:13 am
I am in the situation too, i found this site here

http://jeffskinnerbox.wordpress.com/201 ... pberry-pi/

I will try this tomorrow see if it helps.
User avatar
Posts: 4
Joined: Wed Dec 19, 2012 4:22 pm
Location: Somerset, England
by Mobius » Thu Jan 24, 2013 3:25 am
Here's an example of a /etc/network/interfaces file setup for WEP:

Code: Select all
auto wlan0
iface wlan0 inet static
address 192.168.1.67
netmask 255.255.255.0
gateway 192.168.1.1
wireless-essid myssid
wireless-key mykey


You could just do DHCP and eliminate the address, network, and gateway lines.
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA
by Phugoid Floyd » Thu Nov 28, 2013 1:02 am
I trust the OP (the feared and famous Grumpy Mike, no less) has solved his WEP-related connection problems by now, seeing that a year and half has passed. But surprisingly he did not receive a simple workable solution here, it seems. So for anyone else with similar problems and possibly perusing this thread in search for help, I would like to offer a config file that at least has worked for me. I, in turn, got the relevant parts from a blog by Jeff Skinner here: http://jeffskinnerbox.wordpress.com/2012/11/05/wifi-support-on-raspberry-pi/comment-page-1/#comment-1959.

Code: Select all
# The loopback network interface
auto lo
iface lo inet loopback


# The primary (wired) network interface
iface eth0 inet dhcp


# The wifi (wireless) network interface
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
   wireless-essid MyNetworkname
   wireless-key MyPassword
User avatar
Posts: 1
Joined: Sun Nov 04, 2012 10:26 pm
Location: Sweden
by Grumpy Mike » Thu Nov 28, 2013 11:14 am
(the feared and famous Grumpy Mike, no less)

I don't bite you know ;)
Thanks for the update.

To complete the tale one of the RPI updates ( I call them the RIP updates for what they do to your system) rendered my OS totally not working and I could not face loosing a day to the long drawn out rigmarole of installing all the things required to make my Wi-Fi dogle work, so I took the easy way out. I connected the Ethernet port direct to my Mac and enabled sharing on it, that could cope no problems with the two types of encryption between my two locations.

Cheers
User avatar
Posts: 748
Joined: Sat Sep 10, 2011 7:49 pm
Location: Manchester (England England)
by sbhere » Tue Dec 31, 2013 6:58 pm
So has no one found a way to get wpa_supplicant or another configuration file to look for a multitude of networks that includes WEP networks? I'm rather frustrated with this thing right now, and can't figure out whether the edimax I have is bad, or if the settings I have are bad...
Posts: 3
Joined: Mon Dec 30, 2013 7:59 pm
by ukscone » Tue Dec 31, 2013 7:18 pm
you tried basing your wpa_supplicant.conf on the info in here? http://hostap.epitest.fi/gitweb/gitweb. ... icant.conf

you should be able to just have multiple entries and weight their usage using priority=

somewhere i have a wpa_supplicant.conf that has several entries that incl. my home ap which is wpa, then some public ap that are wpa2 then a couple of wep ap then falls through if they aren't found to open ap
User avatar
Moderator
Moderator
Posts: 2572
Joined: Fri Jul 29, 2011 2:51 pm
by sbhere » Tue Dec 31, 2013 7:25 pm
I wrote a more detailed post here: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=64922

I have several entries in my wpa_supplicant.conf file, and still none of them seem to work. :evil:
Posts: 3
Joined: Mon Dec 30, 2013 7:59 pm