Getting to GUI?


8 posts
by exchaoordo » Tue Jun 26, 2012 11:41 pm
I've downloaded and booted the Debian Squeeze install from Raspberry Pi's site.
What do I now run to get to a desktop like Gnome or Xwindows, a GUI?
I see that there is X session and similar stuff. I tried various ones but no luck.

I am VERY new to this.
Posts: 2
Joined: Sat Jun 23, 2012 3:13 pm
by felix123 » Tue Jun 26, 2012 11:57 pm
startx
Posts: 153
Joined: Tue May 15, 2012 6:06 am
by Super-Nathan » Wed Jun 27, 2012 1:23 am
Code: Select all
startx


This will get you into LXDE. LXDE is a lightweight window manager better suited to low power processors like the PI. Gnome would probably be very very slow.

If you don't like having to type start x, you can install a desktop manager. LXDE's is called LXDM. This would give you a graphical login screen, but it would take more system resources and be slower. I have not checked if it is in the repositories as i am running arch. If you want to try installing it from the command line type

Code: Select all
sudo aptitude install lxdm


Another good choice would be SLiM as it is very lightweight. however it is a little harder to configure.

here is a great how-to http://rustyshacklefordslibrarycard.wordpress.com/2010/03/12/slim-in-debian-squeeze/
echo "Something Useful" > /dev/null
User avatar
Posts: 67
Joined: Sun Jun 17, 2012 6:56 am
Location: South Korea
by exchaoordo » Wed Jul 04, 2012 9:52 pm
Thanks to all for the help. I got a GUI with startx. It is very slow and a bit blurry (indeed my text is blurry too on an old samsung syncmaster 150mp monitor through the RCA jack, but I'll work on it). :D
Posts: 2
Joined: Sat Jun 23, 2012 3:13 pm
by ibrahimansari » Sat Aug 16, 2014 8:43 am
Run
Code: Select all
startx
This will start LXDE, the default desktop environment.It's that easy ;) !If you don't like to do that every time, then run
Code: Select all
sudo apt-get install lightdm
This should install the lightdm display manager. Now configure it with
Code: Select all
sudo dpkg-reconfigure lightdm
Do not go into raspi-config and modify the boot into desktop environment to graphical login as it reduces security. lightdm prompts you for password and improves security. I personally use MATE, a continuation of GNOME 2 instead of LXDE. I don't use lightdm much. Also remember, if you are logging with SSH into your pi, then the GUI is not available. Running startx in an SSH session isn't going to get you the GUI, instead it will give what commands LXDE or whatever is running on your system.
Posts: 1
Joined: Sat Aug 16, 2014 8:22 am
by A1i2T3R » Sat Aug 16, 2014 12:11 pm
Code: Select all
startx
Enthusiastic pi user, with a hoby for modding everyday objects and using the pi as the brain!
User avatar
Posts: 98
Joined: Sat Apr 13, 2013 1:08 pm
Location: England - Kent
by klricks » Sat Aug 16, 2014 2:00 pm
exchaoordo wrote:Thanks to all for the help. I got a GUI with startx. It is very slow and a bit blurry (indeed my text is blurry too on an old samsung syncmaster 150mp monitor through the RCA jack, but I'll work on it). :D


The composite (RCA) uses the fixed resolutions of NTSC or PAL that have been in place for 50 or 60 years and cannot be altered. Text is often blurry or jittery. Text can sometimes be improved by selecting different background and text colors and/or enlarging the font. Otherwise try adjustments on the TV. Some old TV's have a focus knob that may help though not always accessible from the outside of the case.
Also you will find that some programs don't work correctly because they were coded with VGA minimum resolutions in mind which are higher res than composite.
Most of the Python games that come installed in the Raspbian image can't be played in composite mode as the playing field is larger than the screen.

IMO composite is not useable except as a temporary standby. Try to get an HDMI monitor or even an old VGA monitor using an HDMI to VGA converter box is much much better than composite.
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://home.budget.net/~klricks/Comp/RPi/Rpi.html
Posts: 1318
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
by klricks » Sat Aug 16, 2014 2:19 pm
ibrahimansari wrote:...
... Do not go into raspi-config and modify the boot into desktop environment to graphical login as it reduces security. lightdm prompts you for password and improves security. I personally use MATE, a continuation of GNOME 2 instead of LXDE. I don't use lightdm much. Also remember, if you are logging with SSH into your pi, then the GUI is not available. Running startx in an SSH session isn't going to get you the GUI, instead it will give what commands LXDE or whatever is running on your system.


The only real security is to block physical access to the RPi / SD card.

If you want a login prompt to the GUI with raspi-config enabled boot to desktop then:
Code: Select all
sudo leafpad /etc/lightdm/lightdm.conf

Find this line: (approximately line 78 in file)
autologin-user=pi

Comment out this line by inserting a # like this:
#autologin-user=pi

Save and exit then reboot
Note boot to desktop must be configured using raspi-config , and the RPi rebooted, before doing the above edit.
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://home.budget.net/~klricks/Comp/RPi/Rpi.html
Posts: 1318
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA