Issue with known working WIFI


59 posts   Page 1 of 3   1, 2, 3
by pauly24 » Fri Jun 22, 2012 10:05 pm
I have a cheapie wifi dongle I brought off amazon.
Its a RT5370 and the ID comes up as 148f:5370
I used this link, followed it 3 times on 3 fresh installs.
http://raspberry-pi-notes.blogspot.com. ... ongle.html

Also tried the way listed over on the raspberry pi wiki, cannot get it to work.
I just get this everytime...

Code: Select all
pi@raspberrypi ~ $ sudo ifup wlan0
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/7c:dd:90:0c:38:80
Sending on   LPF/wlan0/7c:dd:90:0c:38:80
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
Failed to bring up wlan0.
pi@raspberrypi ~ $


Dongle tested out on my windows machine and works fine.
Posts: 59
Joined: Fri May 18, 2012 2:42 pm
by SN » Fri Jun 22, 2012 10:11 pm
Have you poked your wireless lan settings into /etc/network/interfaces?
Steve N – binatone mk4->intellivision->zx81->spectrum->cbm64->cpc6128->520stfm->pc->raspi ?
User avatar
Posts: 1008
Joined: Mon Feb 13, 2012 8:06 pm
Location: Romiley, UK
by pauly24 » Fri Jun 22, 2012 10:43 pm
Of course, exactly like in the instructions.

My wifi dongle sees my home wireless network if I do a scan, just doesn't connect as shown above. Doesn't give any errors or wrong password messages.
Posts: 59
Joined: Fri May 18, 2012 2:42 pm
by AndyD » Sat Jun 23, 2012 4:45 am
Doesn't give any errors or wrong password messages.


Have you configured the wifi on the pi with the security setting for your router? I am not sure if this is the correct way to do it, but I ended up using the wpa_supplicant to match the security setting of my router.
Posts: 647
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
by pauly24 » Sat Jun 23, 2012 9:57 am
Do you mean editing the interfaces file?

/etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
wireless-essid YourEssID
wireless-mode managed
wireless-key xxxxx

this is for WEP, I also tried WAP, I set my router up on WEP and WAP but still doesn't work.
(And I know this is a newbee forum so yes I made sure my essid was correct and my wireless key was correct, just incase anyone asks!)
Posts: 59
Joined: Fri May 18, 2012 2:42 pm
by pjwalsh77b » Sat Jun 30, 2012 7:54 pm
I get exactly the same results: followed the instructions detailed here: http://raspberry-pi-notes.blogspot.com/ ... ongle.html, and when I reboot the Raspberry I get

    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
    No DHCPOFFERS received.
and then the boot proceeds.

If I leave the wireless adapter plugged in and try to do "lfconfig wlan0" after logging in, the box hangs until I remove the wifi adapter at which point all is fine again.
Posts: 1
Joined: Sat Jun 30, 2012 4:13 pm
by pjc123 » Sat Jun 30, 2012 9:49 pm
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13

Me and another person on these forums were trying to figure out this same exact problem a couple of days ago (same error messages), and at least in my case, we found the problem. Actually there were two problems, and both were related to a mismatch between the security settings of the router and the pi, so this is the area where you want to point your troubleshooting for this problem, even if the cause of your problem is not exactly the same as mine. Here are the two fixes I had to make to eliminate the errors, and allow the pi to connect to the router and therefore the internet.

PROBLEM #1) I had backslashes (The character "\") in my password that were acting as "escape" characters, which is a shell programming special character. So for example if your password is set as the following in your router and in the /etc/network/interfaces file on the pi:

ROUTER: wpa shared key=RPaHl/y6k
RASPBERRY PI: wpa-psk=RPaHl/y6k in the file /etc/network/interfaces

then when the operating system reads the file on the pi it will not see the slash at all, and will think that you intended to escape the letter "y".

To fix this do one of the following:
a) Remove the backslashes from the password in your router and the /etc/network/interfaces OR
b) Do what I did and use a double backslash as follows: "//" in the file /etc/network/interfaces (Do not change the router). Now you are "escaping the special meaning of the escape character" and the result is the character "/".

PROBLEM #2) The other problem I had is that I could not make a network connection if I hid the SSID in my router. There may be a way around this, but I do not know what it is (I would prefer not to broadcast the SSID for security reasons). So if the following is set on your router:

ROUTER: Wireless SSID Broadcast = Disable

then the raspberry pi will not be able to locate the router.

To fix this set the following:

ROUTER: Wireless SSID Broadcast = Enable.

Hope this helps!
Posts: 911
Joined: Thu Mar 29, 2012 3:37 pm
by pauly24 » Sun Jul 01, 2012 12:15 pm
I'm entering the password directly into the interface file, so there are no backslashes, just alphanumeric characters.
Also my SSID is broadcasted, if I do a scan with the dongle, it shows about 4 wireless networks it can pick up, one of them being my network, so I can definitely see it.
Just still cant connect!
Posts: 59
Joined: Fri May 18, 2012 2:42 pm
by dlp2k » Sun Jul 01, 2012 7:21 pm
Hi all,

I too am looking for help with this very same issue. I am not brand new to linux, but this is causing me considerable pain!

My problem is exactly described as above, but there are other symptoms which seem to be related.

I installed wicd as my connection manager in the hope that i can at least scan for networks, however the device alwas comes back with no networks found (there are at least near me).

I should mention that i am using debian wheezy and have the firmware-ralink package installed.

Lsmod shows the device connected without issue, and i have tried the adaptor on both the on board usb port and in my powered hub, the results are the same.

Sometimes on reboot wicd just hangs when searching and i am also prevented from opening a root terminal.
However, as soon as i remove the usb device all queued windows open instantly and wicd starts responding again.

The symptoms of this look like an issue with the ralinj driver/firmware package. Has anyone found a working one?

Out of interest, is everyone else using squeeze or wheezy that have this problem?
Posts: 4
Joined: Sun Jul 01, 2012 7:09 pm
by craigward2000 » Sun Jul 01, 2012 8:15 pm
I had this problem too. I was following the instructions here:
http://omer.me/2012/04/setting-up-wirel ... pberry-pi/

I found the solution was to do this:

Instead of using wpa.conf, try this (directly in /etc/network/interfaces):

auto wlan0
iface wlan0 inet dhcp
wpa-ssid “NETWORK SSID”
wpa-psk “NETWORK PASSWORD”


The other problem I had was plugging my netgear WG111V2 directly into the Rasperry Pi. I was getting lots of errors etc. and I could not scan for wireless networks using "iwlist wlan0 scan". The solution was to buy a powered hub. I got a 4 port Belkin hub from Tesco for £15.
Posts: 1
Joined: Sun Jul 01, 2012 8:06 pm
by dlp2k » Thu Jul 05, 2012 7:59 pm
I read the wiki and it says to make sure that you put the SSID and key in " " marks.

I have tried this and still I am having the same issue :(

Does anyone have any ideas??

I am using WEP by the way and i have added the config into /etc/network/interfaces but still get this result.

I have also tried connecting manually with:

iwconfig wlan1 essid BTHomeHub-****
iwconfig wlan1 key bbbbbbbbbb
dhclient wlan1

I get no response when typing these commands and the dhclient command takes a long time to complete. However, when checking the network config, still no connection.

Once these commands have completed, a basic "iwconfig" commands shows me all of the correct config for wlan1 but still no connection.

My hair is quickly getting thinner and thinner.
Posts: 4
Joined: Sun Jul 01, 2012 7:09 pm
by mjszczesiak » Sun Jul 15, 2012 5:46 pm
I'm a complete linux beginner who has been struggling up until now with what seems to be the same problem discussed here (No DHCPOFFERS received).

I had this problem on both Debian Squeeze and Raspbian distributions.

I'm using a Netgear router and a Netgear Wireless USB Adapter WG111v2 (realtek RTL8187 chipset) and WPA-PSK encryption.

Without doubt there are other methods but this (using wpasupplicant) worked for me (please excuse any crudeness):

1. Install package wpasupplicant:
Code: Select all
sudo apt-get install wpasupplicant

2. Create a config file:
Code: Select all
nano /etc/wpa_supplicant/wpa_supplicant.conf

with the following content:
Code: Select all
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
  ssid="network_id"
  psk="password"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=TKIP
  group=TKIP
  id_str="Nickname"
}

NOTE: The critical change (for WPA-PSK) I had to make from those advised elsewhere was to change "proto=RSN" to "proto=WPA"

3. Modify the interfaces file:
Code: Select all
nano /etc/network/interfaces

to use the wpa configuration, like:
Code: Select all
auto wlan0
  iface wlan0 inet dhcp
  wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

4. Then restart the interface:
Code: Select all
/etc/init.d/networking restart

This correctly obtained an IP address from the DHCP server. I also had to disable my wired ethernet with static IP since it seemed to conflict:
Code: Select all
ifdown eth0

I also removed it from the interfaces file to avoid auto detection on boot-up:
Code: Select all
#auto eth0
.
I hope this helps.
Posts: 1
Joined: Sun Jul 15, 2012 5:07 pm
by hibol » Sat Jul 28, 2012 6:18 pm
Hi,
I tried the method described in the last post.
Each time I restart the interface, it works for about 2 seconds and then the connexion is down again.
My dongle is a D-Link DWA-131 rev.A1 RTL8192SU.
Any idea why it seems to be ok and then fails ?
User avatar
Posts: 33
Joined: Thu Jul 26, 2012 9:44 am
Location: Switzerland
by freezerburn » Sat Jul 28, 2012 7:13 pm
thank you craigward, this fixed my problem. i do not need a powered hub like so many other posts i've read, i knew i could get this working. the wpa.config was the major issue. if anyone is having wifi on wpa issues then use the information below!! copy and pasting wpa.config files resulted in lots of issues for me (for one, the double quotes were not "real" double quotes). this finally works!! THANKS!

Instead of using wpa.conf, try this (directly in /etc/network/interfaces):

auto wlan0
iface wlan0 inet dhcp
wpa-ssid “NETWORK SSID”
wpa-psk “NETWORK PASSWORD”
Posts: 2
Joined: Sat Jul 28, 2012 7:10 pm
by p3trk » Wed Aug 22, 2012 9:34 pm
Huge thanks to freezerburn for the comment above as it finally fixed my wifi connectivity. :)

I followed this guide: http://elinux.org/RPi_edimax_EW-7811Un to get my Edimax wifi adapter working but had the same issue (no DHCP offers received). Turns out I did NOT need WPA_Supplicant, the solution was to put the SSID and PSK into my /etc/network/interfaces file as per Freezerburn's comment above and remove the line calling wpa_supplicant.

So if anyone else is having this issue, give that a try.

Thanks again, Freezerburn! Peter
Posts: 1
Joined: Thu Jun 07, 2012 12:40 am
by aballen » Sat Sep 08, 2012 2:38 am
freezburns fix worked for me as well (using wheezy)
Posts: 7
Joined: Tue Dec 20, 2011 3:09 pm
by Richard76 » Wed Nov 14, 2012 7:20 pm
mjszczesiak wrote:I'm a complete linux beginner who has been struggling up until now with what seems to be the same problem discussed here (No DHCPOFFERS received).

I had this problem on both Debian Squeeze and Raspbian distributions.

I'm using a Netgear router and a Netgear Wireless USB Adapter WG111v2 (realtek RTL8187 chipset) and WPA-PSK encryption.

I hope this helps.


-----------------------------------------------------------------------------------------------

Hi, I had a problem with an Edimax USB adapter which was associated with PSKs. The RPi could connect to a BT Wifi-wth-FON service, but not to my BTHomeHub3. It just cycled through a state of '4-way Handshake' and back to disconnected. After looking through lots of and lots and lots of 'cures' I tried the files suggested by this "Linux beginner" which completely fixed the problem. Thanks for your post.

Richard W.
Posts: 2
Joined: Wed Nov 14, 2012 3:56 pm
by Craigusus » Sat Nov 24, 2012 10:22 am
I have had the same issue connection a ZyXel NWD2105 to a TP-LINK TL-WA701N access point with WPA-PSK/WPA2-PSK encryption and SSID not being broadcast.
I also tried all of the above options to no avail.

BUT... I did get it to connect when I broadcast the SSID. For it to disconnected again when I re-hid the SSID.

So for my RPi to connect to a secure wireless network I have to make it less secure... Brilliant!

I guess the people at wpa_supplicant have some work to do yet.

Oh well back to Ethernet then...
Posts: 7
Joined: Tue May 08, 2012 8:22 pm
by pjc123 » Sat Nov 24, 2012 1:03 pm
Craigusus wrote:I have had the same issue connection a ZyXel NWD2105 to a TP-LINK TL-WA701N access point with WPA-PSK/WPA2-PSK encryption and SSID not being broadcast.
I also tried all of the above options to no avail.

BUT... I did get it to connect when I broadcast the SSID. For it to disconnected again when I re-hid the SSID.

So for my RPi to connect to a secure wireless network I have to make it less secure... Brilliant!

I guess the people at wpa_supplicant have some work to do yet.

Oh well back to Ethernet then...


What I discovered is that you need to set up the wpa_supplicant.conf file to handle hidden SSID's per the instructions in the documentation located at /usr/share/doc/wpa_supplicant on the pi.

See the post here for my config files:

viewtopic.php?t=11517

If this does not work right away you can experiment with the values for the "ap_scan=2" and "scan_ssid=1" parameters, and also per the documentation, it is also critical that key_mgmt, pairwise, group and proto each be set to a single correct parameter reflecting your router settings. Also, all other values must be exactly correct and there must not be any typos or other errors in the config file or else you will not get a connection or wpa_supplicant start-up errors.
Posts: 911
Joined: Thu Mar 29, 2012 3:37 pm
by mcgyver83 » Thu Nov 29, 2012 4:35 pm
Hi I have a
Bus 001 Device 009: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
and it looks like well installed and the firmware looks ok.
I have a problem:
Code: Select all
iwlist wlan0 scan

gives me always
Code: Select all
wlan0     No scan results
..

I installed Ralink firmware 0.36...
Posts: 291
Joined: Fri Oct 05, 2012 11:49 am
by mcgyver83 » Mon Dec 03, 2012 3:38 pm
No one with the same problem as me?
Posts: 291
Joined: Fri Oct 05, 2012 11:49 am
by Mobius » Wed Dec 12, 2012 11:36 pm
mcgyver83 wrote:No one with the same problem as me?


Yes, I have exactly the same problem. It has actually worked on occasion for brief periods of time. Once, long enough that I do run Midori from the graphic interface. Generally, though, it just fails to get an address from my wireless. I'm running WEP (I know, I know) and my Ralink dongle is only about 18 inches from the router. The +5 volts on-board is no longer an issue and I have shorted the USB polyfuses. I have also tried plugging the dongle into a powered USB hub. I know the dongle works because I can plug it into my desktop and it connects with no problems. I am using the 10/28/2012 version of Raspbian.
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA
by mcgyver83 » Fri Dec 14, 2012 10:43 am
No others people?
Posts: 291
Joined: Fri Oct 05, 2012 11:49 am
by terrycarlin » Fri Dec 14, 2012 7:02 pm
mcgyver83 wrote:No others people?


Try:
Code: Select all
sudo iwlist wlan0 scan
If it ain't broke, take it apart and see how it works.
User avatar
Posts: 70
Joined: Thu Jun 14, 2012 10:42 pm
by Mobius » Fri Dec 14, 2012 7:53 pm
Looks like from all of the forum and web searches I've done that this particular chipset is really hit and miss on the Pi. Sounds like the Edimax device works more consistently so I ordered one of those. I liked the Ralink one because it came with an antenna for better range performance.
Posts: 238
Joined: Thu Aug 30, 2012 1:07 am
Location: San Angelo, Texas USA