Trying 1080p, dropping to 640x480


20 posts
by blakespot » Fri Jul 06, 2012 9:27 pm
Hey there,

Just got my Pi.

I am using it with a 20" Hannspree HDMI screen that works fine with my iPad and with a PC I've got on a switch. Trying to go via HDMI to 1080p, which the display supports. Whenever I choose this mode (group 2 mode 82), or many other modes of particularly high res, the system just boots into 640x480.

Any ideas? Here's my config.txt:

- - - - -
#hdmi_safe=1

disable_overscan=1

#overscan_left=0
#overscan_right=0
#overscan_top=0
#overscan_bottom=0

hdmi_force_hotplug=1

hdmi_group=2
hdmi_mode=34

#hdmi_drive=1

config_hdmi_boost=4

#sdtv_mode=2

#arm_freq=800
- - - - -

The highest I've gotten is group 2 mode 47 -- 1400x900. Thanks.



bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by Nr90 » Fri Jul 06, 2012 10:27 pm
Have you tried http://elinux.org/RPi_config.txt#Which_values_are_valid_for_my_monitor.3F to see which specific settings are possible?
Posts: 213
Joined: Sat Nov 26, 2011 12:39 pm
by JeremyF » Sat Jul 07, 2012 12:03 am
Try ignoring the EDID. Also you say group 2 (DMT) maybe CEA would be better?

Code: Select all
 hdmi_ignore_edid=0xa5000080
hdmi_group=1
hdmi_mode=16


^ What I would try in config.txt
{sig} Setup: Original version Raspberry Pi (B, rev1, 256MB), Dell 2001FP monitor (1600x1200), 8GB Class 4 SD Card with Raspbian and XBMC, DD-WRT wireless bridge
Posts: 516
Joined: Wed Jan 25, 2012 9:06 pm
by blakespot » Sat Jul 07, 2012 1:38 pm
Those last settings work, but I get occasional blanking and no setting I try for overscan correction will get me a "native" match for my 1920x1080 display.

I don't understand why it would jump to 640x480 when I set group 2 mode 82. Is it detecting the screen can't handle it? Is there a way to tweak the dot clock? I had to do this to get my SAM 440 (PPC Amiga thing) working at 1920x1080 (on the Amiga vidcard side). ?

Thanks. Frustrated...



bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by dom » Sat Jul 07, 2012 2:33 pm
@blakespot
The blanking may be fixed with config_hdmi_boost here:
http://elinux.org/R-Pi_Troubleshooting# ... VI_monitor

Yes, if you select a mode the monitor doesn't report it supprots in the EDID, it will be ignores and it falls back to 640x480 (a manditory mode).
You need the hdmi_ignore_edid to force a mode that is not reported as supported.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by blakespot » Sat Jul 07, 2012 3:32 pm
Hmmm, it drops to 640x480 even with the hdmi_ignore_edid=0xa5000080 added.

Shouldn't it just display nothing if my screen does not support it? Why would it jump to 640 in that force situation? Something else going on here, I wonder?



bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by Vinzenz-o » Sat Jul 07, 2012 5:34 pm
Hi,

did you have check the setting of your screen ?

For example, on my TV, i have to use the mode "Fit screen" to have a full size screen show without overscan. If i use the mode "Original", "16:9", "4:3", "zoom", etc... my TV don't use all the screen or overscan.
;)

PS: I'm French, so sorry for my bad English :D
User avatar
Posts: 14
Joined: Tue Jul 03, 2012 1:48 pm
by ds18s20 » Sat Jul 07, 2012 7:35 pm
@blakespot - so how is that going? Is there a way or isn't there one to make it work in native 1080p? The fact that its ignoring the HDMI auto detect _ignore option is laughable - who knows how many other settings that the "experts" claim to exist are total gibberish....
User avatar
Posts: 40
Joined: Fri Dec 23, 2011 5:44 am
Location: San Francisco
by dom » Sat Jul 07, 2012 7:46 pm
blakespot wrote:Hmmm, it drops to 640x480 even with the hdmi_ignore_edid=0xa5000080 added.

Please post output of:
cat /boot/config.txt
/opt/vc/bin/tvservice -s
/opt/vc/bin/tvservice -m CEA
/opt/vc/bin/tvservice -m DMT
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by blakespot » Sat Jul 07, 2012 10:38 pm
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by dom » Sat Jul 07, 2012 10:59 pm


It looks like you are at 1440x900:
state: HPD high|DVI mode|HDCP off|composite off (0x120016), 1440x900 @ 60Hz, progressive

Where are you seeing 640x480?
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by blakespot » Sun Jul 08, 2012 12:47 pm
Sorry -- here it is in mode 82 = 1080p and the ignore is set...


http://pastebin.com/5Xzy4qAQ
http://pastebin.com/1WSWQh0f

Hmm...



bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by dom » Sun Jul 08, 2012 12:58 pm
Can you attach your edid.dat. You will have to zip it for forum to accept it.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by blakespot » Sun Jul 08, 2012 7:33 pm
My edid.dat is 0 bytes when /opt/vc/bin/tvservice -d edid.dat is executed in this gfx mode...


bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by blakespot » Sun Jul 08, 2012 7:51 pm
Sorry, I didn't sudo generate the file. Disregard my last comment.

Here: http://pastebin.com/BaaMZU36

Thanks!



bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by dom » Sun Jul 08, 2012 7:56 pm
blakespot wrote:Sorry, I didn't sudo generate the file. Disregard my last comment.

Here: http://pastebin.com/BaaMZU36

Thanks!



bp


Could you attach the binary edit.dat file (zipped up).
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by blakespot » Sun Jul 08, 2012 9:27 pm
Here it is.
Attachments
edid.dat.gz
(230 Bytes) Downloaded 50 times
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by dom » Sun Jul 08, 2012 10:58 pm
@blakespot
Thanks. I see the issue you are seeing. I've tweaked the behaviour of hdmi_ignore_edid, can you test it:
https://dl.dropbox.com/u/3669512/temp/start.elf

Note: this is 128M memory split. If testing is okay (and hdmi guy agrees the change is okay), I'll push out an updated firmware in next day or two.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by blakespot » Mon Jul 09, 2012 3:13 pm
Yes - that works! Thanks so much!

I still have occasional blanking issues with this mode and some others. I have boost set to 7 -- it showed a blank display at 4. This is a pretty cheapo HANNspree 20" wide display.



bp
Posts: 11
Joined: Fri Jul 06, 2012 9:22 pm
by dom » Mon Jul 09, 2012 3:19 pm
blakespot wrote:I still have occasional blanking issues with this mode and some others. I have boost set to 7 -- it showed a blank display at 4. This is a pretty cheapo HANNspree 20" wide display.


Can you try a different HDMI lead?
While we've listed 7 as the maximum, I believe you can go up to 11.
This would not be generally recommended, as that is way above the spec, and a "sensitive" monitor might react badly.
However your combination of cable and monitor seems rather "insensitive", so you might get away with it.
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 3999
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge