Clear Case doesnt fit, I'm doing something wrong


9 posts
by VeldMuijz » Wed Oct 31, 2012 12:36 pm
Hi there,
I got my Raspberrypi with the clear case.
When I started to put it al together it doesn't really seem to fit al that well. The case couldn't be closed because the case was touching the sd-card, it looks like it is too high. The area where the sd card is sticking out is where the problem is.

Does anybody have the same problem, or am I doing something wrong?
Posts: 5
Joined: Fri May 25, 2012 10:59 am
by toxibunny » Wed Oct 31, 2012 12:42 pm
Pics pls!
note: I may or may not know what I'm talking about...
Posts: 994
Joined: Thu Aug 18, 2011 9:21 pm
by mahjongg » Wed Oct 31, 2012 1:33 pm
There isn't just one version of a transparent enclosure for the PI, both farnell and RS have their own design's, and there may be many others in the market.

I heard that the RS one could have problems with one of the connectors not fitting properly unless you took some plastic off with a sharp knife. My own transparent case from farnell fits perfectly though.
User avatar
Moderator
Moderator
Posts: 4495
Joined: Sun Mar 11, 2012 12:19 am
by Gaetan » Wed Oct 31, 2012 1:47 pm
which model ? The NewIt one >> here <<?
Posts: 17
Joined: Fri Oct 26, 2012 10:19 am
Location: Lieusaint (77, France)
by mahjongg » Thu Nov 01, 2012 2:07 am
Thats the one I have, the clear one, which I have bought at Farnell.

It fits like a glove!

The RS one looks very much alike, but is clearly (no pun intended) different.

By the way, the other, non transparent ones, clearly do not come from the same mold, as many details are different.
User avatar
Moderator
Moderator
Posts: 4495
Joined: Sun Mar 11, 2012 12:19 am
by Zyzzyx39 » Thu Nov 01, 2012 8:41 pm
Veld, I don't know which one you got, but I got this with my Pi when I initially ordered it:

http://i.imgur.com/O45d2.jpg

I just woke up and was delirious but the trick is to snap the Pi into the bottom piece first then snap on the top piece.

For first 10 minutes, I was getting irritated because the ports weren't lining up to the case openings.

Hope this helps :mrgreen:
Posts: 1
Joined: Thu Nov 01, 2012 8:35 pm
by VeldMuijz » Sun Nov 04, 2012 12:16 pm
Mine looks the same as yours, though it's not the same.
I got the one from rs components.
I will struggle with it later, thanks guys.
Posts: 5
Joined: Fri May 25, 2012 10:59 am
by kalehrl » Sun Nov 04, 2012 2:21 pm
Why struggle when there's a video on how to install it properly:
http://www.youtube.com/watch?v=yRbfQCxEWYs
Posts: 342
Joined: Tue Jul 24, 2012 10:49 am
by VeldMuijz » Tue Dec 04, 2012 8:55 pm
This is solved.
Thanks for posting that video kalehrl.
I was afraid to push on the board like that but it works :lol:
Posts: 5
Joined: Fri May 25, 2012 10:59 am