HDMI VGA adapter


10 posts
by edwardl » Fri Nov 02, 2012 12:19 pm
I have already red through many posts and now understand that a simple connector cable won't work because there is no analogue signal outputted through the HDMI port of the RPi.
That Lead me to do some research and found this adapter and was wondering if this is suitable as a converter without drawing too much power and breaking the diode?
http://www.ebay.co.uk/itm/HDMI-Input-to ... 4845638e67
Edit: or this one, http://www.amazon.co.uk/gp/product/B007 ... 02_s00_i00

PS First post, please be nice :p
Posts: 13
Joined: Fri Nov 02, 2012 12:05 pm
by RaTTuS » Fri Nov 02, 2012 12:57 pm
the amazon quotes seem to say yes
I think I've seen positive posts before
so yes YMMV
1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX - Prosliver FTW
"That's not right, the badgers have moved the goalposts."
User avatar
Posts: 5207
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
by Wheel_nut » Fri Nov 02, 2012 5:18 pm
I believe that this adapter does function BUT it is NOT self powered and ther have been reports that it has blown the Diode on the power line from the RPi. Also, it does not derive the Audio signal from the HDMI.

A better solition is the Powered adapter which also provides an audio output derived from the HDMI. It costs a few quid more but is the proper job.
http://www.ebay.co.uk/itm/PC-HDMI-to-VG ... 4602af8f3f
Posts: 132
Joined: Tue Sep 18, 2012 7:51 pm
by webpaddler » Fri Nov 02, 2012 9:58 pm
I bought a Sanoxy HDMI to VGA adapter from

http://www.amazon.com/SANOXY-Audio-Conv ... B0057UNQ18
It comes with a power supply. It did not automatically go into the correct video mode when installing the various versions of Raspbian.

I came across several items on the web, but www.gilesthomas.com articles proved to be the most useful and I finally came up with the following section that I now put in every config.txt that I use in every installer.

The 'arm_freq=800' and 'force_turbo=1' lines puts the Pi in the Turbo mode.
arm_freq=800
force_turbo=1
gpu_mem_256=128
gpu_mem_512=256

overscan_left=16
overscan_right=16
hdmi_mode=19

This set up works well on my Venturer TV/Monitor. You need a working card-reader to make changes to your SD card. This also works on my Dell monitor. Your monitor may require different settings.

Below is the entire section file I copied. If you see your problem listed, simply remove the # and you can check out if it corrects the problem.) I strongly recommend only changing one item at a time. It may take longer initially perhaps, but you might retain your sanity.
(please note that every line beginning with # is disabled.) Removing the # makes the line active.
#------------------------------------------------
# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1
### Original OOB setting:
# disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
overscan_left=16
overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1
### Original OOB setting:
hdmi_mode=19

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# for more options see http://elinux.org/RPi_config.txt

I hope this will help you out.
Posts: 3
Joined: Fri Nov 02, 2012 8:53 pm
by edwardl » Fri Nov 02, 2012 10:54 pm
Thanks, This is all really helpful, Upon further investigation it says on the product page that it is compatible with the raspberry pi (the amazon one) so I've bought that, as for modes, if it does't work when it arrives I think I'll just fiddle!!
Posts: 13
Joined: Fri Nov 02, 2012 12:05 pm
by johnbeetem » Sat Nov 03, 2012 5:09 am
There's some useful lore in RasPi Wiki here: http://elinux.org/RPi_Verified_Peripher ... rter_boxes
User avatar
Posts: 942
Joined: Mon Oct 17, 2011 11:18 pm
Location: The Coast
by webpaddler » Sat Nov 03, 2012 12:54 pm
My pleasure Edward, glad to help.


Thank you for that list John. That will come in VERY handy, as I'm just beginning my Pi venture.
Posts: 3
Joined: Fri Nov 02, 2012 8:53 pm
by lordoxford » Sat Nov 03, 2012 10:07 pm
I have edited the 'config.txt' file on the SD card, hoping to enlarge the font and reduce the overscan but the system seems not to read this file.
I attempt to do it this way since the screen text is too small for me to interact effectively with the unix and edit the loaded version.
Any suggestions?
lox.
Posts: 11
Joined: Wed Oct 17, 2012 11:42 pm
by Wheel_nut » Sat Nov 03, 2012 11:03 pm
The Config.txt file is only read at boot-up so you need to re-boot to see the effect of the changes you have made.
Posts: 132
Joined: Tue Sep 18, 2012 7:51 pm
by webpaddler » Sun Nov 04, 2012 12:58 am
Lox,

Try a different number behind the HDMI statement to go to a different video mode. I'm no pro at this.
Posts: 3
Joined: Fri Nov 02, 2012 8:53 pm